Ubuntu 22.04 LTS is the current version of Ubuntu (the version on the Ubuntu download page), and you get the following message trying to install Synergy:
-code- synergy : Depends: libssl1.1 (>= 1.1.0) but it is not installable -/code-
Also, the default mode for Ubuntu is Wayland, which Synergy does not support yet.
We're working on official support for Ubuntu 22.04 LTS (Xorg only), it's currently in development and will be released soon.
The workaround for Wayland is simply to switch to Xorg. The same workaround applies to Ubuntu 21.04 and another Wayland-default Linux distributions.
The workaround involves downgrading Libssl to an older version. We are not aware of any significant risks in doing this. Both Libssl 3.0 (from Ubuntu 22.04) and Libssl 1.1.1 (from Ubuntu 21.10) use TLS1.3 and both versions are actively maintained. Please proceed only if you're comfortable with downgrading from Libssl 3.0 to 1.1.1.
To temporarily install the ~code~libssl~/code~ package from Ubuntu 21.10, run these two commands:
-code-sudo dpkg -i ./libssl1.1_1.1.0g-2ubuntu4_amd64.deb-/code-
Finally, install the Synergy .deb package as normal.
If this article didn't help, you can talk to someone on our support team (unless we sent you here, in which case please reply via the ticket you already have open).