Markland

HOWTO: CentOS 7 install

8 posts in this topic

Hi everyone!

I didn't find any good documentation on how to install Synergy on a CentOS 7 machine so I figured I'd drop a few lines describing what I did - perhaps it might help someone else!

Prerequisites:
I will assume you have CentOS 7 installed with the latest updates. In my case I am using Gnome desktop environment and thus running GDM as login manager.

Steps:
1. Ensure that you have the epel repository enabled. For more information on EPEL click here.
 

sudo yum --enablerepo=extras install epel-release

2. Install Synergy from the EPEL repository.
 

sudo yum install synergy

3. Login to your desktop environment in CentOS if you aren't already logged in.

4. Start Synergy by (if running standard Gnome) pressing WIN-key and typing in Synergy and pressing ENTER.
If you cannot find Synergy this way, you can open a terminal and run /usr/bin/synergy directly.

5. Configure Synergy as you normally would.
5a. Enter your license key.
5b. Enter the server information (or setup the server-config if running as server).

6. Create a systemd startup file.
6a. Client version:

sudo echo >> /etc/systemd/system/synergy.service << EOF
[Unit]
Description=Synergy Client Daemon
After=network.target

[Service]
ExecStart=/usr/bin/synergyc --no-daemon <SERVER IP HERE>
Restart=always
RestartSec=3

[Install]
WantedBy=default.target
EOF

6b. Server version:
 

sudo echo >> /etc/systemd/system/synergy.service << EOF
[Unit]
Description=Synergy Client Daemon
After=network.target

[Service]
ExecStart=/usr/bin/synergys &
Restart=always
RestartSec=3

[Install]
WantedBy=default.target
EOF

7. Reload systemctl daemon.
 

sudo systemctl daemon-reload

8. Enable Synergy to run at boot.
 

sudo systemctl enable synergy.service

9. If you previously closed Synergy after making the initial configuration, you can now use systemd to start it. If you reboot it will also start automatically.
 

sudo systemctl start synergy

 

And that's it! Hope it helps someone. :)

Edited by Markland

Share this post


Link to post
Share on other sites

Super set of instructions. Thanks so much for posting -- this is a great tutorial!

Share this post


Link to post
Share on other sites

I am hoping someone can help me with my install. I followed the directions above and still can't get it to auto start.  Here is what I did:

1)  Downloaded rpm 1.10, yum install with all dependencies correctly.  

2) Started up Synergy, got it seeing the server and working perfect

3) Went to /etc/systemd/system and 

nano synergy.service

[Unit]
Description=Synergy Client Daemon
After=network.target

[Service]
ExecStart=/usr/bin/synergyc --no-daemon <SERVER IP HERE>
Restart=always
RestartSec=3

[Install]
WantedBy=default.target

Control x, y, enter

Verified file was there, looks good.  I followed 7-9 exactly with no errors

7. Reload systemctl daemon.
 

sudo systemctl daemon-reload

8. Enable Synergy to run at boot.
 

sudo systemctl enable synergy.service

9. If you previously closed Synergy after making the initial configuration, you can now use systemd to start it. If you reboot it will also start automatically.
 

sudo systemctl start synergy

 

When I boot back in, I run systemctl status synergy and says loaded, with a green dot.  But I am still not getting the actual program to load on boot.  I have to manually go in and auto start it.

Does anyone have any input as what I am missing?

Any help would be much appreciated!

 

Share this post


Link to post
Share on other sites

Hi Poopsie,

Could you please type:

sudo cat /etc/systemd/system/syngery.service

And copy/paste the output here.

And also the following, please:

sudo systemctl status synergy.service -l

And copy/paste the output here.

Edited by Markland

Share this post


Link to post
Share on other sites
3 hours ago, Markland said:

Hi Poopsie,

Could you please type:

sudo cat /etc/systemd/system/syngery.service

And copy/paste the output here.

And also the following, please:

sudo systemctl status synergy.service -l

And copy/paste the output here.

Here you go!  Thanks for the help!!

[Unit]
Description=Synergy Client Daemon
After=network.target

[Service]
ExecStart=/usr/bin/synergyc --no-daemon 10.10.50.40
Restart=always
RestartSec=3

[Install]
WantedBy=default.target
-------------------------------------------------------------------------

[[email protected] ~]# systemctl status synergy.service -l
● synergy.service - Synergy Client Daemon
   Loaded: loaded (/etc/systemd/system/synergy.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2019-02-11 20:53:27 CST; 1min 32s ago
 Main PID: 4789 (synergyc)
    Tasks: 3
   CGroup: /system.slice/synergy.service
           └─4789 /usr/bin/synergyc --no-daemon 10.10.50.40

Feb 11 20:53:27 localhost.localdomain systemd[1]: Started Synergy Client Daemon.
Feb 11 20:53:27 localhost.localdomain synergyc[4789]: [2019-02-11T20:53:27] WARNING: secondary screen unavailable: unable to open screen
Feb 11 20:54:27 localhost.localdomain synergyc[4789]: No protocol specified
Feb 11 20:54:27 localhost.localdomain synergyc[4789]: [2019-02-11T20:54:27] WARNING: secondary screen unavailable: unable to open screen
 

 

 

Share this post


Link to post
Share on other sites
17 hours ago, Poopsie said:

[[email protected] ~]# systemctl status synergy.service -l

● synergy.service - Synergy Client Daemon
   Loaded: loaded (/etc/systemd/system/synergy.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2019-02-11 20:53:27 CST; 1min 32s ago
 Main PID: 4789 (synergyc)
    Tasks: 3
   CGroup: /system.slice/synergy.service
           └─4789 /usr/bin/synergyc --no-daemon 10.10.50.40

Feb 11 20:53:27 localhost.localdomain systemd[1]: Started Synergy Client Daemon.
Feb 11 20:53:27 localhost.localdomain synergyc[4789]: [2019-02-11T20:53:27] WARNING: secondary screen unavailable: unable to open screen
Feb 11 20:54:27 localhost.localdomain synergyc[4789]: No protocol specified
Feb 11 20:54:27 localhost.localdomain synergyc[4789]: [2019-02-11T20:54:27] WARNING: secondary screen unavailable: unable to open screen
 

 

 

Since you get that specific error I'm assuming you're trying to use Synergy 2, if that's the case please try starting Synergy manually by running:

sudo synergy-service

If you are using Synergy 1 then try the below.

In the startscript just below [Service] and before ExecStart add the following:

User=root
Group=root

Good luck!

 

Share this post


Link to post
Share on other sites
3 hours ago, Markland said:

Since you get that specific error I'm assuming you're trying to use Synergy 2, if that's the case please try starting Synergy manually by running:

sudo synergy-service

If you are using Synergy 1 then try the below.

In the startscript just below [Service] and before ExecStart add the following:

User=root
Group=root

Good luck!

 

Here is what I get now when I run sudo systemctl status synergy.service -l

● synergy.service - Synergy Client Daemon
   Loaded: loaded (/etc/systemd/system/synergy.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2019-02-12 17:55:17 CST; 2s ago
 Main PID: 17043 (synergyc)
    Tasks: 3
   CGroup: /system.slice/synergy.service
           └─17043 /usr/bin/synergyc --no-daemon 10.10.50.40

Feb 12 17:55:17 localhost.localdomain systemd[1]: Started Synergy Client Daemon.
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: [2019-02-12T17:55:17] DEBUG: XOpenDisplay(":0.0")
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: /builddir/build/BUILD/synergy-core-1.8.8-stable/src/lib/platform/XWindowsScreen.cpp,918
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: No protocol specified
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: [2019-02-12T17:55:17] WARNING: secondary screen unavailable: unable to open screen
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: /builddir/build/BUILD/synergy-core-1.8.8-stable/src/lib/synergy/ClientApp.cpp,413
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: [2019-02-12T17:55:17] DEBUG: retry in 60 seconds
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: /builddir/build/BUILD/synergy-core-1.8.8-stable/src/lib/synergy/ClientApp.cpp,284
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: [2019-02-12T17:55:17] DEBUG: event queue is ready
Feb 12 17:55:17 localhost.localdomain synergyc[17043]: /builddir/build/BUILD/synergy-core-1.8.8-stable/src/lib/base/EventQueue.cpp,118
 

And here is the script I am using with the additions from above

[Unit]
Description=Synergy Client Daemon
After=network.target

[Service]
User=root
Group=root
ExecStart=/usr/bin/synergyc --no-daemon 10.10.50.40
Restart=always
RestartSec=3

[Install]
WantedBy=default.target

You have new mail in /var/spool/mail/root
 

Thanks

 

Edited by Poopsie

Share this post


Link to post
Share on other sites

i'm getting the same error:

 

[email protected]:~$ systemctl status synergy.service -l
● synergy.service - Synergy Client Daemon
   Loaded: loaded (/etc/systemd/system/synergy.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-03-03 12:38:47 PST; 1min 48s ago
 Main PID: 894 (synergyc)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/synergy.service
           └─894 /usr/bin/synergyc --no-daemon 192.168.1.203

Mar 03 12:38:47 lexie systemd[1]: Started Synergy Client Daemon.
Mar 03 12:38:47 lexie synergyc[894]: [2019-03-03T12:38:47] WARNING: secondary screen unavai
Mar 03 12:39:47 lexie synergyc[894]: No protocol specified
Mar 03 12:39:47 lexie synergyc[894]: [2019-03-03T12:39:47] WARNING: secondary screen unavai

 

 

running sudo synergy-service:

[email protected]:~$ sudo synergy-service
sudo: synergy-service: command not found
 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now