BillyLavoie

Restart background service

16 posts in this topic

Every time my computer goes to sleep I have to restart the background service on the computer I use as the server (for some reason my other computer takes over and when I try to switch it everything fails). Would it be possible to include a button to automatically restart the background service so I don't have to go to the terminal every time? At least until Synergy 2 is stabilized a bit.

Share this post


Link to post
Share on other sites

It's not only possible, it's a good idea, at least for now. The developers have bounced the idea around.

When it's a mature product, such a toggle might imply that it's still needing intervention, but now...

What OSs are you using? On my Windows machine I made a shortcut to 'services' in the taskbar. It speeds up the task. Elsewhere on the forum the Linux guys have posted batch files that work.

Share this post


Link to post
Share on other sites

I'm using MacOS so it is possible to make a quick batch file but I feel like it should be in the app until things can be smoothen out. I'm a developer so I don't have a problem with it, but the average end user will

Share this post


Link to post
Share on other sites

I have posted this in a few of the sections .. not sure if this is a similar problem

still getting a re-connection problem when my laptop (win10) is woken up due to inactivity > 10 mins and goes to sleep. I wake up my laptop and click on the enter key to wake up my imac (sierra).  Client on the laptop tries to re-connect but doesn't. I have to go to services to restart synergy.

This problem with waking up and re-connecting to imac has been happening for awhile with version 2.

Share this post


Link to post
Share on other sites

Have you guys tried this? On the computer that didn't fall asleep, mouse-grab one of the screens and move it away for a few seconds. They should 'go gray.' Then reposition them touching again.

This is supposed to restart the Synergy-Core on both machines.

Share this post


Link to post
Share on other sites

When I return to my office, Win10 is asleep. Imac does not have keyboard and mouse functionality because keybd/mouse is connected to Win10. I have keybd/mouse attached to imac in case but not used unless it is an emergency. Win10 is primary workstation

Share this post


Link to post
Share on other sites
1 hour ago, GranPaSmurf said:

Have you guys tried this? On the computer that didn't fall asleep, mouse-grab one of the screens and move it away for a few seconds. They should 'go gray.' Then reposition them touching again.

This is supposed to restart the Synergy-Core on both machines.

That unfortunately didn't work for me. At first I would restart both machines but that got old quick so I dug around and found out that running the three commands to restart the background service on the server seems to be enough to get things working

Share this post


Link to post
Share on other sites

share the 3 commands???? :D

Share this post


Link to post
Share on other sites
4 hours ago, Cheryl Lomedico said:

share the 3 commands???? :D

Nothing too magical, I just found the known bug page https://symless.com/synergy/help/known-bugs and what fixes it for me is restarting the background service which lists the steps for each OS https://symless.com/synergy/help/connection/background-service

For MacOS you're looking for these 3: 

launchctl unload /Library/LaunchAgents/com.symless.synergy.synergy-service.plist
sudo killall synergy-core
launchctl load /Library/LaunchAgents/com.symless.synergy.synergy-service.plist

Then when I go back to Synergy and it will complain about not being able to talk to the background service and there will be a refresh link, click that and you should be good to go

  • Thanks 1

Share this post


Link to post
Share on other sites

Have you tried the tray icon disable/enable feature that shipped with 2.0.7?

Share this post


Link to post
Share on other sites
Posted (edited)

The disable/enable from system tray worked.

 

The 3 commands are for mac. My primary station is my win10 laptop.

Edited by Cheryl Lomedico
  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, Steve Williams said:

Have you tried the tray icon disable/enable feature that shipped with 2.0.7?

I did this morning to test and that unfortunately didn't fix it. Ran my script and clicked refresh and everything was back in business. 

Share this post


Link to post
Share on other sites

can you post your script? Step by step.

Share this post


Link to post
Share on other sites

It's just the 3 commands to restart the service:

 

#!/bin/bash

launchctl unload /Library/LaunchAgents/com.symless.synergy.synergy-service.plist
sudo killall synergy-core
launchctl load /Library/LaunchAgents/com.symless.synergy.synergy-service.plist

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Would this script be a way to trash the prefs on Mac? 

Can it be done any time?

Share this post


Link to post
Share on other sites

For what it's worth, I also had this problem today.  The problem seemed to affect the Win10 Pro machine, rather than the Win8.1 Pro machine.  I had to manually kill the Win10 processes before everything came back to life.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now