jace

Source code for version 2

16 posts in this topic

Hello Team,

I understand that due to the pressure of fixing current issues and bugs with the version 2.0.4 [which is the latest release at this time], that the priority of Symless is understandably focused on fixing the Synergy releases for the "mainstream" OS like Windows and Mac and ubuntu, etc..However, the desktop I personally use the most is my Arch Linux desktop and right now, the amount of time I have been able to use it has decreased as my home set-up greatly uses Synergy and I currently can only get my Windows and MacBook working [to some extent] with the latest versions of Symless.

 

Long story short, I was wondering if there is any predictions on the earliest that the source code for Synergy for version 2.0.4 will be made public akin to the source code for version 1.8?

Share this post


Link to post
Share on other sites
12 hours ago, jace said:

@Nick Bolton if that is the core, is there a reason why it's not available on the download page along with the rest of the downloads?

You have to build the core yourself.

Share this post


Link to post
Share on other sites
On 1/4/2018 at 8:04 AM, jaap aarts said:

you can install synergy 2 from the AUR,

https://aur.archlinux.org/packages/synergy2/

and you'd might need this:

 

@jaap aarts I downloaded and compiled and installed and I have ended up with the following commands: synergy-config   synergy-core     synergy-service  synergy-tests

which one do I need to start to get synergy going? is there documentation about properly starting synergy 2.0 somewhere online?

Share this post


Link to post
Share on other sites

to start the synergy config you can start synergy-config(this is the GUI).

but synergy should work without the GUI, the synergy service should be started on boot and is automatically enabled. (I m thinking about changing the in the AUR package since people don't seem to want that) it starts at boot and should handle everything. to manually start the service run synergy-service. if you want to manually start synergy as a server/client use synergy-core, but keep in mind that you need lots of arguments.

synergy-core --server -f --run-as-uid 1000 --debug DEBUG --name antergos --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log -c /var/lib/synergy/synergy.conf --address 127.0.0.1:24800

this works for me, as a server with the name antergos

synergy-core --client -f --run-as-uid 1000 --debug DEBUG --name antergos --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log 127.0.0.1:24800

same, but then as the client

Share this post


Link to post
Share on other sites

@jaap aartsthanks for the commands but I got this error. I dont know if you rather I post these errors here or somewhere else, let me know but for until then, I will post them here:

Sun Jan 07 15:36 jace:jace_arch/home/jace $synergy-core --client -f --run-as-uid 1000 --debug DEBUG --name jace_arch --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log 127.0.0.1:24800
[2018-01-07T15:36:41] INFO: ignoring --enable-drag-drop, not supported on linux.
[2018-01-07T15:36:41] DEBUG: XOpenDisplay(":0.0")
[2018-01-07T15:36:41] DEBUG: xscreensaver window: 0x00000000
[2018-01-07T15:36:41] DEBUG: screen shape: 0,0 3600x1080 
[2018-01-07T15:36:41] DEBUG: window is 0x02c00004
[2018-01-07T15:36:41] DEBUG: adopting new buffer
[2018-01-07T15:36:41] DEBUG: opened display
[2018-01-07T15:36:41] NOTE: started client
[2018-01-07T15:36:41] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:41] DEBUG: event queue is ready
[2018-01-07T15:36:41] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:41] DEBUG: retry in 1 seconds
[2018-01-07T15:36:42] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:42] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:42] DEBUG: retry in 1 seconds
[2018-01-07T15:36:43] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:43] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:43] DEBUG: retry in 1 seconds
[2018-01-07T15:36:44] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:44] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:44] DEBUG: retry in 1 seconds
[2018-01-07T15:36:45] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:45] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:45] DEBUG: retry in 1 seconds
^C[2018-01-07T15:36:46] DEBUG: adopting new buffer
[2018-01-07T15:36:46] DEBUG: closed display
[2018-01-07T15:36:46] NOTE: stopped client
Sun Jan 07 15:36 jace:jace_arch/home/jace $

 

Share this post


Link to post
Share on other sites

The service needs to be running to use 127.0.0.1. You could connect the cores directly using the other machine's IP.

Share this post


Link to post
Share on other sites

@Nick Bolton 
What do you mean? I need to have Synergy running on another computer in order to be able to start the synergy program on my arch?

Share this post


Link to post
Share on other sites
5 hours ago, jace said:

What do you mean? I need to have Synergy running on another computer in order to be able to start the synergy program on my arch?

There's a background service running on all computers, it has an SSL network layer which the core connects to via 127.0.0.1.

If you want SSL, you need to make sure that the core connects to 127.0.0.1. Otherwise, you can connect the cores directly (which means you don't need the service running).

Share this post


Link to post
Share on other sites

 

On 1/8/2018 at 12:40 AM, jace said:

@jaap aartsthanks for the commands but I got this error. I dont know if you rather I post these errors here or somewhere else, let me know but for until then, I will post them here:

Sun Jan 07 15:36 jace:jace_arch/home/jace $synergy-core --client -f --run-as-uid 1000 --debug DEBUG --name jace_arch --enable-drag-drop --profile-dir /var/lib/synergy --log /var/log/synergy/synergy-core.log 127.0.0.1:24800
[2018-01-07T15:36:41] INFO: ignoring --enable-drag-drop, not supported on linux.
[2018-01-07T15:36:41] DEBUG: XOpenDisplay(":0.0")
[2018-01-07T15:36:41] DEBUG: xscreensaver window: 0x00000000
[2018-01-07T15:36:41] DEBUG: screen shape: 0,0 3600x1080 
[2018-01-07T15:36:41] DEBUG: window is 0x02c00004
[2018-01-07T15:36:41] DEBUG: adopting new buffer
[2018-01-07T15:36:41] DEBUG: opened display
[2018-01-07T15:36:41] NOTE: started client
[2018-01-07T15:36:41] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:41] DEBUG: event queue is ready
[2018-01-07T15:36:41] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:41] DEBUG: retry in 1 seconds
[2018-01-07T15:36:42] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:42] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:42] DEBUG: retry in 1 seconds
[2018-01-07T15:36:43] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:43] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:43] DEBUG: retry in 1 seconds
[2018-01-07T15:36:44] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:44] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:44] DEBUG: retry in 1 seconds
[2018-01-07T15:36:45] NOTE: connecting to '127.0.0.1': 127.0.0.1:24800
[2018-01-07T15:36:45] WARNING: failed to connect to server: Connection refused
[2018-01-07T15:36:45] DEBUG: retry in 1 seconds
^C[2018-01-07T15:36:46] DEBUG: adopting new buffer
[2018-01-07T15:36:46] DEBUG: closed display
[2018-01-07T15:36:46] NOTE: stopped client
Sun Jan 07 15:36 jace:jace_arch/home/jace $

 

I am sorry for the late reply.

Can you run this and post the output?

echo $DISPLAY

or could you tell me if you are running wayland?

 

Share this post


Link to post
Share on other sites

@jaap aarts

On 2/8/2018 at 12:15 AM, jaap aarts said:

I am sorry for the late reply.

Can you run this and post the output?

echo $DISPLAY

or could you tell me if you are running wayland?

 

Sorry I didn't reply earlier, for some reason, I didn't get an email notification about your reply...
I ran that and got this outpu

:0.0

 

Share this post


Link to post
Share on other sites

@jaap aarts and I am using LXDE for a desktop environment if that is useful information

Share this post


Link to post
Share on other sites

Very cool! I was wondering how long it would take for someone to do this. I hope it takes off! Let me know if you need any help.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.