DereckR

Synergy 2 Window needs to be in foreground?

8 posts in this topic

Hello Everyone,

Issue #1

I would love for someone to shed some light or have a solution to an issue that I have experience in both v1 and v2 on some occasions. I would access the host PC on the lock screen and accidentally raise the mouse and go over too the second PC and the mouse will just get locked and not operate correctly. The only way I have found to resolve this is by locking the PC 2 with a keyboard. This happened both in v1 and v2.

Issue #2

When using the program after sometime I have to relaunch the Synergy application to be able to click on PC2. Some reason the clicking ability stops working some times after use this happened in both v1 and v2.

 

Thanks,
Dereck

Share this post


Link to post
Share on other sites

I have experienced issue 2 mostly when working on a vm on the host PC.

I have never had to relaunch synergy though. I usually just minimize the vm click somewhere on the host Pc and then if all works as normal.

i have experienced something similar to you locking issue on v1 but not yet on 2. No fixes though.

Stuart

 

Share this post


Link to post
Share on other sites

As @stuart macmillan, I suffered from this issue on v1, that's the first thing I tried after installing v2 but did not manage to have the issue. 

@DereckR, can you please provide exact steps that lead to you getting your cursor locked, I'd like to see if I can still be locked ?

sholan

Share this post


Link to post
Share on other sites

I haven't seen this on either of the RC versions, but back on beta 4, I had it happen several times. It's as if my server is still focused but the cursor is off in limbo somewhere, not showing up on either client or the server.

I found that if I hit F12 the cursor came back. It's as if the Synergy server re-initialized on some level. This worked for me, give it a try.

Either way, the Devs still need to troubleshoot this recurring issue.

Share this post


Link to post
Share on other sites

Hi All, 

Haven't read about anyone else with a similar issue yet. Has anyone experienced issues where their client PC looses the ability to click, only when the Synergy window on the server PC is not in the foreground?

At first I though it was just a complete coincidence, but I've had this been going on since Beta 2 or 3. Just downloaded and installed the full stable release this morning and installed on both.  When I close the Synergy window on the server PC, I can still move about the screen on the client PC with the cursor, and keyboard works fine. But no mouse clicks are registering. Open up the Synergy window on the server PC, and clicks work no problem on the client PC. This is a little frustrating since it isn't always practical to have Synergy in the foreground... 

Client PC is Mac OS X High Sierra, Server PC is Windows 10. 

Any help would be great, thanks. 

  • Thanks 1

Share this post


Link to post
Share on other sites
12 hours ago, ksagert said:

But no mouse clicks are registering.

This happens intermittently for a small number of users. We're working on this issue and will try to have a fix in place for 2.1. Please let me know if you need a refund.

Share this post


Link to post
Share on other sites
On 2017-11-07 at 10:52 PM, Nick Bolton said:

This happens intermittently for a small number of users. We're working on this issue and will try to have a fix in place for 2.1. Please let me know if you need a refund.

Hi Nick, thanks for the reply. I can certainly understand that this same resulting issue may be affecting other users, but has anyone experienced it only when the Synergy 2 window is not in the foreground on the Server PC? Any timeline for 2.1 or supporting bug fix releases? 

Share this post


Link to post
Share on other sites
On 09/11/2017 at 5:09 PM, ksagert said:

Any timeline for 2.1 or supporting bug fix releases? 

Early next year.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now