Matteo

No mouse and keyboard input on Ubuntu 17.10 client

18 posts in this topic

I am trying the latest version on Synergy on the daily build of Ubuntu 17.10 (as client). The server is a Windows 10 host.

I can see "entering screen" and "leaving screen" info messages, however the mouse does not move and keyboard input is ignored.

Debug logging shows that the client receives input ("recv mouse move", "keystroke", etc.), yet the mouse cursor does not move and keyboard input has no visible effect.

 

Is there any info on how to get Synergy working on Ubuntu 17.10?

I understand this version of Ubuntu is not released yet and my expectations are set accordingly.

Share this post


Link to post
Share on other sites

Same here when server is Ubuntu 16.04 and client is Ubuntu 17.10.

When both are 17.10, there is no connection at all. Logs contain an error:

[2017-10-20T16:29:23] INFO: starting client
[2017-10-20T16:29:23] INFO: config file: .synergy/synergy.conf
[2017-10-20T16:29:23] INFO: log level: ERROR
[2017-10-20T16:29:23] INFO: log file: /var/log/synergy.log
[2017-10-20T16:29:32] ERROR: ssl error occurred (system call failure)
    /build/synergy-R40txi/synergy-1.8.8-stable+dfsg.1/src/lib/net/SecureSocket.cpp,576

Share this post


Link to post
Share on other sites

It works, if you use "ubuntu xorg" .. which can be selected if you click the "cog icon" on the login screen. ... New ubuntu uses the "wayland" display manager, which may not be supported ....

Share this post


Link to post
Share on other sites

I'm using Ubuntu 17.10 for server and Windows 10 for client, move movement works, except when on the ubuntu machine terminal is opened and maximized, in which case I can't move the mouse cursor to the client. Keyboard works mainly well, except for alt+tab, which executes on the server even if the mouse cursor is on the client.

Share this post


Link to post
Share on other sites

Running 1.8.8 on a Windows 10 Server, and Ubuntu 17.10 client. 

Can confirm what @pmariosays:
- works as expected if you login with the `ubuntu xorg` 
- network connectivity works on the new display manager (but the mouse cursor doesn't move, and keyboard doesn't work)
- `alt+tab` seems to have no issue

Share this post


Link to post
Share on other sites

Confirmed as well.  Windows 10 and Ubuntu 17.10  using 1.8.8.  Changing to ubuntu xorg works.

Share this post


Link to post
Share on other sites

Windows 10 server and Ubuntu 17.10 client crash

59f21e30df3f3_Capturade2017-10-2619-39-05.png.6c048d92faa249357800231e2c4153e0.png

Can they help me?

Regards

Share this post


Link to post
Share on other sites

This is just a warning. .. If you click OK, the program is shown, because it can't display the icon in the system tray. ... API is different, since ubuntu switched to gnome UI from Unity.

For me the connection is established, as soon as it shows the program UI.

Share this post


Link to post
Share on other sites
pmario,
Thank you for answering. It does not work, I can not access the UI 
Greetings

Share this post


Link to post
Share on other sites

@pmario

Yes, I am working with xorg but it still does not work

Captura de 2017-10-30 09-48-01.png

Share this post


Link to post
Share on other sites

Did you click OK? ... Then you'll probably need to wait several seconds. .. I think there are some timeouts involved. ... For me after about 5 seconds the config UI pops up and the connection can be configured and it is established, once it is configured.

Share this post


Link to post
Share on other sites

@pmario

yes, I clicked to accept but the user interface never appears.
Thank you very much for your interest

Share this post


Link to post
Share on other sites

@pmario

I have totally removed and I have installed again. 
Synergy now works but the graphical interface still does not appear. 
Best Regards

Share this post


Link to post
Share on other sites

Running 1.8.8 on a Windows 10 , and Ubuntu 17.10 client. 

Can confirm what @pmariosays:
- works as expected if you login with the `ubuntu xorg` 
- network connectivity works on the new display manager (but the mouse cursor doesn't move, and keyboard doesn't work)
- `alt+tab` seems to have no issue

- I also have to disable SSH

Share this post


Link to post
Share on other sites

@Klaasvortex

I confirm ubuntu xorg works perfectly with the keyboard and the mouse.
I don't know how to disable SSH
It works fine except that I can not access the synergy graphic interface

Regards

Share this post


Link to post
Share on other sites

I've had the same issue ... or lets say it looks for me like these issue because the solution was pretty easy and unexpected.

synergy connected from ubuntu 17.10 and windows 10 successfully.

BUT i was not able to move to cursor to the windows screen, because they was on the left side, and the dock was capturing the mouse (for any reason synergy will not work if the mouse is on top on any menu element in gnome) 

so i moved the dock to the right side .... and now it works

 

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now