Jiri Tomek

Alt+Shift on client breaks connection

2 posts in this topic

A have two Windows 10 computers and installed Beta 4 on them. Initial setup was s(y|e)amless. I'm using two keyboard layouts on both machines - English and Czech - and I use Alt+Shift combo to switch between them. And that causes issues.

STR:

  1. Have two Windows 10 machines using two keyboard layouts and Synergy 2 Beta 4
  2. Move mouse to client
  3. Press Alt+Shift to switch keyboard layout.
  4. Connection breaks. You can't move mouse to client anymore.
  5. Close Synergy windows and restart services on both client and server. -> Does not help
  6. Restart service on client, open Synergy window and press F12 -> still not working
  7. Restart service on server, open Synergy window and press F12 -> computer boxes in UI flash few times and connection is finally restored
  8. Move mouse to client and press Alt+Shift -> Broken again, you have to repeat steps 5 to 7 to restore it.

This makes Beta 4 unusable for me for now, I need to switch keyboard layouts quite often.

Uploaded logs:

Note: It would be great if Synergy 2 supports side-by-side install with synergy 1.x. I had to uninstall 2.0 beta and install back 1.8 so if you need any further troubleshooting from me and I have to go through install round back and forth few times it will be quite annoying.

Edited by Jiri Tomek

Share this post


Link to post
Share on other sites

Hey, this'll be fixed in beta5 (due in about 4 weeks). Thanks for your patience!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now