Sergio Garcia

Failed to connect to server: Incompatible Client 1.5

14 posts in this topic

I'm using the following setup:
Client - Windows 10 64bit (Synergy version: 1.8.8-Stable-25a8cb2)
Server - Linux Ubuntu 16.04 LTS (Synergy version 1.6.2)

On the client I'm getting the error message:
Warning: Failed to connect to server: incompatible client 1.5

-If I use the Win PC as Server and the Linux as client, synergy works, but in this case I need the Linux PC as Server.

Thanks for the help.

Share this post


Link to post
Share on other sites

Hi @Sergio Garcia. Please take a screenshot of Synergy's information (Help> About Synergy...) and post it here. Thanks! :)

Share this post


Link to post
Share on other sites

joe,

 client wont connect. here is my screen shots. 

help, please.

thanks.

sny1.png

syn.png

Share this post


Link to post
Share on other sites

Hey @dan lardner. Based on the screenshot. It doesn't show an SSL fingerprint generated. That could be the reason why it doesn't work. Make sure for it to have an SSL fingerprint shown on all of the machines before trying to connect. You can try turning the SSL off and then on again for it to generate the SSL fingerprint.

Share this post


Link to post
Share on other sites

The same issue with me:

Server - Ubuntu 16.04.2 LTS, Synergy 1.6.2
Client: Windows 7 x64, Synergy 1.8.8-stable-25a8cb2 / Build date: 16 March 2017

Synergy basic, NO SSL.


When press "Start" on the CLIENT, it gives me:

NOTE: connecting to '10.150.48.52': 10.150.48.52:24800
WARNING: failed to connect to server: incompatible client 1.5

On the server:

2017-08-09T11:22:58 NOTE: new client disconnected
/build/synergy-CUL4K_/synergy-1.6.2/src/lib/server/ClientProxyUnknown.cpp,282
2017-08-09T11:22:59 NOTE: accepted client connection
/build/synergy-CUL4K_/synergy-1.6.2/src/lib/server/ClientListener.cpp,137
2017-08-09T11:22:59 NOTE: new client disconnected
/build/synergy-CUL4K_/synergy-1.6.2/src/lib/server/ClientProxyUnknown.cpp,282
2017-08-09T11:23:00 NOTE: accepted client connection
/build/synergy-CUL4K_/synergy-1.6.2/src/lib/server/ClientListener.cpp,137

Just bought your app and can't use it. Please FIX!!

Share this post


Link to post
Share on other sites

I am having the same issue and client messages as ZSasha when trying to have Ubuntu 16.04 Synergy server and windows 10 client. If I have the windows 10 synergy take role of client it works fine, but when the Ubuntu synergy acts as server I get same issues and log responses.

A similar setup at home worked with same windows 10 client. The only difference was the Ubuntu 16.04 server at home was running an Intel CPU rather than an AMD. The only reason I purchased this was so that I could avoid setting up a KVM at work.

I am also waiting a response.

Share this post


Link to post
Share on other sites
1 hour ago, BSlosman said:

I am having the same issue and client messages as ZSasha when trying to have Ubuntu 16.04 Synergy server and windows 10 client. If I have the windows 10 synergy take role of client it works fine, but when the Ubuntu synergy acts as server I get same issues and log responses.

A similar setup at home worked with same windows 10 client. The only difference was the Ubuntu 16.04 server at home was running an Intel CPU rather than an AMD. The only reason I purchased this was so that I could avoid setting up a KVM at work.

I am also waiting a response.

i love synergy, i've had it for years. i just wish it would start working again. :(

  • Like 1

Share this post


Link to post
Share on other sites

Confirm, it WORKS!!

 

Have no idea how or why, but it works!
One thing I noticed when I tried to install the app first time was that it did NOT ask me about key. Only client asked.
Now when I manually installed server from command line - it also asked me for my key so may be indeed an old version is kept in Ubuntu repos or I have no idea.

Anyway - it works, yey!!

Share this post


Link to post
Share on other sites
On 8/10/2017 at 9:50 PM, BSlosman said:

Solved/Success:

What I did ...

1. Completely remove Synergy from Ubuntu 16.04 using Ubuntu software (you may have to reboot if you have not done so since install to populate Ubuntu software)

2. Go to Files and search for Synergy (Activate hidden files with Ctrl-h)

3. Delete anything Synergy related (besides .deb file downloaded) and empty trash

4. Reboot system (precautionary)

5. open terminal in directory of .deb file

6. install manually with: sudo dpkg -i synergy-v1.8.8-stable-25a8cb2-Linux-x86_64.deb

7. I had an error on the first try that said: Package libavahi-compat-libdnssd1 is not installed.

7a. If you have this error type:  sudo apt-get install libavahi-compat-libdnssd1

7b. repeat step 6

8. You should now be able to start synergy from dash, and activate it by entering key

Issue: it seems that if you attempt to install Synergy from Nautilus or your web browser that after you click install the first time for version 1.8xxxx that Ubuntu switches to installing version 1.6xxx. Manually installing as above ensures that the correct version is installed on Ubuntu 16.04.

Synergy: you are welcome to reimburse me with an additional software key for my trouble at my listed email address for the troubleshooting

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now