Ryan71

Keyboard issue

12 posts in this topic

 

I am having an odd issue where when I move from screen 1 ( the server) to screen 2 (host) and back to screen 1 my keyboard is getting switched? Some of the keys work normally but others are not the correct character when typing. For example the a becomes q. I can usually "fix" the problem by going back to screen 2 and clicking then coming back to screen 1 and clicking. But sometimes I have to restart the computer to correct the problem. I do not have this problem if I stop Synergy. Both host and server computers are Windows 10 computers.

Share this post


Link to post
Share on other sites

Hi @Ryan71. Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

Computer 1 (Synergy Server) - Windows 10 Home 64 bit OS build 15063.483 connected via wifi - Synergy Pro Version 1.8.8-stable-25a8cb2

Computer 2 (Synergy Client) - Windows 10 Home 64 bit OS build 14393.1480 connected via ethernet - Synergy Pro Version 1.8.8-stable-25a8cb2

Client - Interface.JPG

Server - Configuration.JPG

Server - Interface.JPG

Share this post


Link to post
Share on other sites

So that screen named "Desktop" is not an actual machine right? If so, please remove it.

Also, can you try v1.9.0rc3 instead? You can get it from the tagged forums thread below.

 

Share this post


Link to post
Share on other sites

No. The screen Desktop is Computer 2. The center screen N7RYN-Dell is computer 1 and Toshiba is my second laptop that isn't always on. When i have noticed the problem the Toshiba has been off.

Share this post


Link to post
Share on other sites

I see, can you move the Toshiba screen one box to the right when if it's not turned on? This triggers the other machines not to look for that machine when they try to establish a connection. 

Have you tried v1.9.0rc3?

Share this post


Link to post
Share on other sites

I loaded v1.9.0rc3 on all my computers and moved the Toshiba config one box to the right. I removed and rebuilt the configuration on all computers. Both systems have been restarted and the problem remains. When moving between screens it is messing up the keyboard.

Edited by Ryan71

Share this post


Link to post
Share on other sites

Please post a screenshot of your current Server Configuration interface.

Share this post


Link to post
Share on other sites

Here it is.

 

Advanced.JPG

Basic.JPG

Hotkeys.JPG

Edited by Ryan71
Added images

Share this post


Link to post
Share on other sites

Can you delete the "Desktop" screen and put the "Toshiba" screen next to dell(left)?

Share this post


Link to post
Share on other sites

Additionally I have noticed that at times I cannot click an item on the Desktop screen without going back to the N7RYN-Dell and clicking on the screen at random first.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now