Gleidson Medeiros

failed to connect to server: server refused client with our name

3 posts in this topic

Hello there,

I'm receiving this error message when trying to connect:

A. Server
OS: Windows 7 Enterprise SP1 x64
IP: 192.168.1.129
Debug
NOTE:accepted client connection
WARNING: unrecognised client name "DESKTOP-R8IKKHC" check server config
NOTE: client "DESKTOP-R8IKKHC" has disconnected

B. Client
OS: Windows 10 Home x64
IP: 192.168.1.129
Debug
[2017-07-06T12:09:27] INFO: starting client
[2017-07-06T12:09:27] INFO: config file: C:/Users/bisonho/AppData/Local/Temp/qt_temp.Hp6480
[2017-07-06T12:09:27] INFO: log level: INFO
[2017-07-06T12:09:27] INFO: service command updated
[2017-07-06T12:09:27] INFO: starting new process
[2017-07-06T12:09:27] INFO: activeDesktop:Default
[2017-07-06T12:09:27] ERROR: could not get session id for process id 11784
[2017-07-06T12:09:27] INFO: starting new process
[2017-07-06T12:09:27] INFO: drag and drop enabled
[2017-07-06T12:09:27] NOTE: started client
[2017-07-06T12:09:27] NOTE: connecting to '192.168.1.129': 192.168.1.129:24800
[2017-07-06T12:09:27] INFO: watchdog status: ok
[2017-07-06T12:09:27] ERROR: server refused client with name "DESKTOP-R8IKKHC"
[2017-07-06T12:09:27] WARNING: failed to connect to server: server refused client with our name

I have checked Windows firewall in both devices and the application is allowed. Additionally I have allowed inbound and outbound connection in 24800 port. Devices are under a route without firewall enabled. Both devices have Bonjour installed.

What else should I check?

Thanks in advance,

Gleidson

Sin título.png

Untitled.png

Share this post


Link to post
Share on other sites

Hi again, =)

I'm not sure if this was what fixed, but after I added the client IP as an alias it's working.

DEBUG
[2017-07-06T12:18:52] NOTE: accepted client connection
[2017-07-06T12:18:52] NOTE: client "GMEDEIROS440" has connected
[2017-07-06T12:18:53] INFO: switch from "DESKTOP-R8IKKHC" to "GMEDEIROS440" at 0,540
[2017-07-06T12:18:53] INFO: leaving screen

Feel fre to close 

  • Like 1

Share this post


Link to post
Share on other sites

Thank you! I had the same issue, and didn't know how to add the client IP as an alias, but figured it out.

In case anyone else is in the same boat, here's what I did to the aliases section of the Synergy Configuration file:

section: aliases
     <client name goes here>:
     <client IP goes here>
end

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now