prmccar

Can't get Synergy to connect and work at all

11 posts in this topic

 have done exactly what the tutorials say to do and I still can't get the client to connect to the server. I have my server on my Windows 10 computer and the client on my MacBook Pro. On the MacBook Pro, it just tells me over and over again in the output WARNING: failed to connect to server: Timed out

I have done everything to try and make this work and for some reason, it will not connect. Can someone help get synergy to work? It would be greatly appreciated. I don't know what I am doing wrong.

Share this post


Link to post
Share on other sites

The client is the Mac and the server is the PC. It is all connected over wifi. I have even set the Server IP to the one shown on the server and not use Auto config hoping that would work. That did not work. I am truly stumped on what to do. This software is horrible.

Edited by prmccar

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

It is 64 OS on MacBook pro being Version 10.12.5. The Windows PC is also 64 bit version 1607. The synergy version 1.8.8. It is connected via Wi-Fi. The Windows PC is the server and the MacBook pro is the client.

Synergy PC.PNG

Synergy Mac.png

Server Configuration.PNG

Share this post


Link to post
Share on other sites

*Two things

First:

I noticed that you only mention two machines but has 3 screens in Server Configuration interface. You might be confused of it representing how many monitors you have. The screens in that interface represents how many computers/machines you want to connect through Synergy. If you have a machine that has two or more monitors, the multiple monitor setup of it will be handled by that computer alone.

Second:

Based on the screenshot, it shows that your server has two valid IP addresses (169.254.x.x are not valid). Server is connected to 192.168.56.x and 192.168.86.x networks. While your client is only connected to 192.168.86.x network. Though the primary network your server machine uses is 192.168.56.x. What you can do to set your server to prioritize the network where your client is on, you can add a primary interface for it to check.

  1. On your server machine, click Edit
  2. Click Settings
  3. Enter your server's IP address (where your client machine can connect) in the Interface box
  4. Click Ok

Let us know how it goes.

Share this post


Link to post
Share on other sites

I removed one of the screens and I have no idea why it was doing that. I set the server's IP address in the interface box and on the server, it is giving me the output:

FATAL: failed to start server: cannot bind address: The specified address is not available from the local machine

ERROR: failed to launch, error: process stopped immediately

 

The client side stayed the same. Any other ideas, because I don't think this worked.

Share this post


Link to post
Share on other sites

What IP address use in the interface box? Can you post a current screenshot of the Server's interface and for the interface box?

Share this post


Link to post
Share on other sites
3 hours ago, prmccar said:

Settings.PNG

That's the IP address on a network where your client is not connected to. You should use the 198.168.86.25

Share this post


Link to post
Share on other sites

I made that change and I am still getting errors on both the client and server. The server side is still giving fatal error messages. It just doesn't want to connect.

Share this post


Link to post
Share on other sites

Can you post a new set of screenshots of both machine's Synergy interface and the Server Configuration interface on your server machine?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now