Julia Purdy

SSL protocol unknown - client not connecting

5 posts in this topic

I( have 3 PCs I am trying to connect. two are working. The server and one client. One client will not connect. I uninstalled and reinstalled it fresh, but it's not working. Here is the message: activeDesktop:Default INFO: starting new process INFO: drag and drop enabled NOTE: started client NOTE: connecting to '192.168....': 192.168....:24800 INFO: watchdog status: ok ERROR: secure socket error: SSL_ERROR_SSL ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol ERROR: failed to connect secure socket INFO: server connection may not be secure NOTE: disconnected from server

Share this post


Link to post
Share on other sites
I am getting the same error, after updating to the latest Synergy. How do I fix this?

Share this post


Link to post
Share on other sites
I am getting a similar error when trying to connect after the upgrade. So far none of my other client can connect to my server system. Are there any updates on this for a resolution?

Share this post


Link to post
Share on other sites
I was having a similar problem with my Win7 client connecting to my Xubuntu 14.04 server. In checking the server log, I found that the client seemed to have been connected already. I'm not sure why, since there was no active connection, but I went through a compelte reinstall process and this particular error went away. It would be nice if there was another way to fix this.... Mark

Share this post


Link to post
Share on other sites
I finally got it to work. deleted and re downloaded server and all clients. I also went in an manually deleted all the app data files I could find since configuration seems to have been stored and not deleted with uninstall. Don't know if that made any kind of real difference, but it was the magic mix that made it connect on the 3rd time downloading. Works great now. !!! yea.

Share this post


Link to post
Share on other sites
I ran into this same issue. I found that this was caused when the client was able to login to my account by the server was not. This enabled the SSL connection option on the client but disabled it on the server. After I disabled the network security option in the client settings it was able to connect.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now