Sign in to follow this  
Kristian Scheibe

Synergy server on Ubuntu: mouse grabbing issue

0 posts in this topic

Hi, I recently switched from a setup having a Windows 7 laptop as the server and a Ubuntu (Linux Mint 18, MATE Edition) PC as the client to having the Ubuntu PC as the server and the laptop as the client. Now I'm having weird problems with my mouse on the server: In irregular intervals throughout the day the mouse gets stuck to one window so that all clicks and mouse movements are only processed by it. So far I had this happen on different windows in different types of applications (the terminal, Firefox, a few Java programs, ...). One way to fix this is to switch to a virtual terminal and back to the GUI. Also when trying to move the mouse over to the laptop the pointer doesn't move over. The log shows the following output: [code] [2016-08-04T08:07:27] DEBUG2: event: MotionNotify 3839,942 [2016-08-04T08:07:27] DEBUG2: find neighbor on right of "workstation" [2016-08-04T08:07:27] DEBUG2: "laptop" is on right of "workstation" at 0.785417 [2016-08-04T08:07:27] DEBUG1: try to leave "workstation" on right [2016-08-04T08:07:27] DEBUG2: mapping state: 16 [2016-08-04T08:07:27] DEBUG2: |= modifier: 4 [2016-08-04T08:07:27] INFO: switch from "workstation" to "laptop" at 0,413 [2016-08-04T08:07:27] INFO: leaving screen [2016-08-04T08:07:27] DEBUG2: grabbed keyboard [2016-08-04T08:07:27] DEBUG2: ungrabbed keyboard, waiting to grab pointer [2016-08-04T08:07:27] DEBUG2: grabbed keyboard (about 20 times in total) [2016-08-04T08:07:28] DEBUG2: grabbed keyboard [2016-08-04T08:07:28] DEBUG2: ungrabbed keyboard, waiting to grab pointer [2016-08-04T08:07:28] DEBUG2: grab pointer timed out [2016-08-04T08:07:28] WARNING: can't leave screen [/code] The reason seems to be that the call to XGrabPointer(...) doesn't return GrabSuccess in XWindowsScreen::grabMouseAndKeyboard() [url]http://fossies.org/linux/synergy/src/lib/platform/XWindowsScreen.cpp[/url] which matches the behaviour of the pointer already having an existing grab, locking it to the one window. I never had this problem either using a similar Ubuntu PC without Synergy or running the opposite setup, using the Windows PC as server. Any help or ideas are appreciated! Thanks! -- Kristian

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this