Sign in to follow this  
Justin Hoff

Microsoft Surface Pro 4 as Client - Upper-Left Mouse

6 posts in this topic

Hello, I just installed the most current version of Synergy on my Windows 10 Laptop, and Windows 10 Surface Pro 4. The laptop is the Server, the Tablet is the client. The tablet/client seems to connect fine, but when I move my mouse over from the Laptop to the Tablet client (positioned to the direct left of the server) the mouse jumps over to the top left of the client screen, and will not move. I can use the server's keyboard, and I can use the server's mouse buttons and scroll. For example, if I use the client's mouse to move the pointer over to something like a scroll bar, I can use the scroll wheel on the server's mouse, and the mouse buttons, but the pointer will still not move (if attempting to move using the server's mouse). Justin

Share this post


Link to post
Share on other sites
Just wanted to pipe in to say that I am having a very similar issue using my Surface Book as a server. Very interested in whatever solution is found. I did notice that the server and the client log indicates that they connect. When I move my mouse to go to the client, the server says that it is leaving the screen to go to the client computer. However the mouse doesn't move. However the buttons for the mouse and keyboard do work. I tested this by clicking and found that I was lucky enough for the mouse to be on the "minimize all windows" button in the bottom right of the screen. If I move the cursor using the physically attached mouse on the client machine and then click the mouse from the server. The mouse buttons also behave as I'd expect. Just can't move the cursor. Also worthy of note, if I switch the roles between the two computers everything works flawlessly. Hope this makes finding a solution easier. Thanks -Devin

Share this post


Link to post
Share on other sites
I'm thinking that this may have something to do with the touchscreen on the computer acting as the server. I'm going to test this out with a Lenovo Yoga. I'll post my findings here once complete.

Share this post


Link to post
Share on other sites
Having the same issue. Wanted to use my Surface Pro 3 as the server, and a Macbook Pro as the client, but when I move over to the client it gets immediately locked in the upper left of the screen. Curiously, does work when I use the MBP as the server, but not ideal as my keyboard is a Windows keyboard and just works better the other way around even with the switches in key bindings. Even more curiously, my previous set up worked just fine a couple of weeks ago. Not sure what changed to cause the issue.

Share this post


Link to post
Share on other sites
Thank you Devin for the suggestion, Mouse Without Borders seems to work in my setup. I will check back with Synergy later to see if they have it fixed, but for now I am up and working :) Justin

Share this post


Link to post
Share on other sites
So I found another poster on one of the forums saying he just resized the text in Windows to 100% instead of his 200% value and it fixed the connection issue. I tried this and it fixed one of the machines I was trying to control (macbook pro 10.11 from a windows 10 machine on a 4K monitor.) See if that helps you guys.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this