Sign in to follow this  
Kelvin D. Olson

Linux Mint Debian Edition LMDE 17 x64 and Synergy Pro 1.7.1

2 posts in this topic

Installation on Mac OS X 10.10.3 of the 1.7.1 Synergy Server was tricky, but successful. Or so I think. It came up, started, was logging activity and client connection attempts, but since the (Linux) client was still on 1.6.2, it didn't complete the SSL handshake, so it was denied. Fair enough - I should have expected that. Desiring to change only one thing at a time, and ease into it, I looked for how to disable SSL on the Mac Synergy Server. Didn't find it. Nick indicates it's in Edit -> Settings. That is where I was looking... I will have to look again after I get back home. Anyway, the Linux install of 1.7.1 wasn't successful yet. Sorry, I'm using the [b]code[/b] tag for stuff that ain't code, but I haven't found the this-is-just-preformatted-terminal-text feature in this forum yet. [code]$ openssl version OpenSSL 1.0.1f 6 Jan 2014[/code] This is the latest one in the distro. I keep my distro up to date - green check-mark in the shield - and yeah, some days that means doing updates 2 or 3 times a day, but I do not let it slip behind. And I [b]rarely[/b] install stuff [b]later[/b] that what's in the distro's software channels, if there's a version that [b]is in[/b] the channels. I just don't have that kind of time. But when Synergy Pro came out, I decided to color outside the lines a bit (and so far, I regret having done so). The following are not all [b]exact[/b] quotes, but have been pieced together based on the most recent error that I did have copied to an email, and stuff in my bash history... [code]$ /usr/bin/synergyc -f --debug NOTE --name kelvind-Latitude-D830 10.0.1.30 > /dev/null ERROR: failed to load plugin: libns.so FATAL: An error occurred: /usr/lib/x86_64-linux-gnu/libssl.so.10: version `libssl.so.10' not found (required by /home/kelvind/.synergy/plugins/libns.so) [/code] ...(did some googling about synergy troubles with libns dependencies, and tried this)... [code] $ sudo ldconfig $ /usr/bin/synergyc -f --debug NOTE --name kelvind-Latitude-D830 10.0.1.30 > /dev/null ERROR: failed to load plugin: libns.so FATAL: An error occurred: /usr/lib/x86_64-linux-gnu/libssl.so.10: version `libssl.so.10' not found (required by /home/kelvind/.synergy/plugins/libns.so) [/code] ...(did more googling, decided to lie to my machine about the filename and version of libssl.so)... [code] $ sudo ln -s /lib/x86_64-linux-gnu/libssl.so.1.0.0 libssl.so.10 $ sudo ldconfig $ /usr/bin/synergyc -f --debug NOTE --name kelvind-Latitude-D830 10.0.1.30 > /dev/null ERROR: failed to load plugin: libns.so FATAL: An error occurred: /usr/lib/x86_64-linux-gnu/libcrypto.so.10: version `libcrypto.so.10' not found (required by /home/kelvind/.synergy/plugins/libns.so) [/code] ...(ok, so that first lie fooled it, let's toss in another symlink lie)... [code] $ sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 libcrypto.so.10 $ sudo ldconfig $ /usr/bin/synergyc -f --debug NOTE --name kelvind-Latitude-D830 10.0.1.30 > /dev/null ERROR: failed to load plugin: libns.so FATAL: An error occurred: /usr/lib/x86_64-linux-gnu/libcrypto.so.10: version `libcrypto.so.10' not found (required by /home/kelvind/.synergy/plugins/libns.so) [/code] So - apparently, I can only fool it once. And even though my OpenSSL is version 1.0.1f, the distro's libssl and libcrypto are 1.0.0, and Synergy 1.7.1 (with libns) really wants them to be ... uh ... [b]version 10?![/b] That can't be right. I'd suggest that the dependencies follow the version numbers (filenames) that [b]exist[/b] out there in up-to-date, LTS distros. Dot-ten doesn't appear to make sense in this scenario. Well, at least, that's what I'd suggest if I knew what the heck I was doing (I don't), or knew what the heck I was talking about (again, clearly, not so much). Can anyone post a [b]detailed[/b] (preferably with pictures) approach to shutting off SSL on the Mac OS X Synergy Server 1.7.1? I'd like to have at least one of them upgraded, yet let the 1.6.2 client(s) still connect. Then, for later, can anyone suggest a way to tell libns to depend on other libs which [b]exist[/b]? Or am I asking the wrong question?

Share this post


Link to post
Share on other sites
To turn off SSL on Mac, go to Synergy and then to the Synergy menu and then Preferences, uncheck 'Use SSL Encryption'. Have you tried installing 1.7.5?

Share this post


Link to post
Share on other sites
Kevin, the Synergy SSL plugin is turned on/off in "Edit" -> "Settings" on Windows/Linux, and "Synergy" -> "Preferences" on Mac (in either case, a "Use SSL encryption" box). If you don't see this option, then probably you have not run the wizard and successfully downloaded/installed the OpenSSL plugin. If you have Synergy Pro, then you might have access to email support (depending on how you obtained Pro) which I suggest using for an installation this complex. Your support options are displayed when you are logged into Synergy site, in the "Account" page. I don't know enough about custom installs or package t-shooting to tell you what you can do here. - Brian

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this