server using wrong resol'n; can't reach client

Get help when something crashes.
Posts: 3
Joined: Thu Oct 13, 2016 1:01 pm

server using wrong resol'n; can't reach client

Postby chris gallant » Thu Oct 13, 2016 1:26 pm

I'm a long time user w/ a simple side-by-side 2 monitor setup. The left monitor is 1920x1200, the right is 1440x900. The server uses both as an extended desktop, whereas the client uses only the right monitor. While running version synergy-v1.7.6-stable-51705f7-Windows-x64, synergy one day just stopped working (Windows update was the only software changed). It turns out that the server was starting w/ incorrect horizontal resolution, "--res-w 4200" (should be 3360), thus the mouse can never reach the right edge of the desktop. (I can move the mouse pointer to the right edge of the right screen fine, but its x coordinate will never get to 4200)

If I alter my Display's Settings to 'Show only [monitor] 1', the server detects the change, resets the resolution (1920) and now I can reach the client.

I've updated to synergy-v1.8.4-stable-a6ff907-Windows-x64 and the problem persists.
========================================================
[2016-10-13T15:52:52] DEBUG: adopting new buffer
[2016-10-13T15:52:52] DEBUG: event queue is ready
[2016-10-13T15:52:52] DEBUG: found sas.dll
[2016-10-13T15:53:03] DEBUG: accepted ipc client connection
[2016-10-13T15:53:04] DEBUG: start ipc handle data
[2016-10-13T15:53:04] DEBUG: ipc read: IHEL
[2016-10-13T15:53:04] DEBUG: finished ipc handle data
[2016-10-13T15:53:04] DEBUG: ipc hello, type=gui
[2016-10-13T15:53:04] INFO: watchdog status: error
[2016-10-13T15:53:10] DEBUG: starting process
[2016-10-13T15:53:10] DEBUG: screen resolution: 4200 1200 primary screen center: 960 600
[2016-10-13T15:53:10] INFO: starting server
[2016-10-13T15:53:10] INFO: command: "C:/Program Files/Synergy/synergys.exe" -f --no-tray --debug DEBUG --name gamer --ipc --stop-on-desk-switch --enable-drag-drop --enable-crypto --profile-dir "C:\Users\cag\AppData\Local" -c "C:/Users/cag/AppData/Local/Temp/qt_temp.Hp2784" --address :24800 --res-w 4200 --res-h 1200 --prm-wc 960 --prm-hc 600
[2016-10-13T15:53:10] INFO: config file: C:/Users/cag/AppData/Local/Temp/qt_temp.gq2784
[2016-10-13T15:53:10] INFO: log level: DEBUG
[2016-10-13T15:53:10] DEBUG: start ipc handle data
[2016-10-13T15:53:10] DEBUG: ipc read: ICMD
[2016-10-13T15:53:10] DEBUG: finished ipc handle data
[2016-10-13T15:53:10] DEBUG: new command, elevate=0 command="C:/Program Files/Synergy/synergys.exe" -f --no-tray --debug DEBUG --name gamer --ipc --stop-on-desk-switch --enable-drag-drop --enable-crypto --profile-dir "C:\Users\cag\AppData\Local" -c "C:/Users/cag/AppData/Local/Temp/qt_temp.Hp2784" --address :24800 --res-w 4200 --res-h 1200 --prm-wc 960 --prm-hc 600
[2016-10-13T15:53:10] INFO: service command updated
[2016-10-13T15:53:10] DEBUG: getting elevated token, elevation required
[2016-10-13T15:53:10] DEBUG: processes in session 1: csrss.exe, winlogon.exe, dwm.exe, glidesvc.exe, atieclxx.exe, sihost.exe, svchost.exe, taskhostw.exe, RuntimeBroker.exe, explorer.exe, mbam.exe, gziface.exe, ShellExperienceHost.exe, SearchUI.exe, LWEMon.exe, networx.exe, RadeonSettings.exe, Steam.exe, SbieCtrl.exe, VirtualDesktops.exe, VCDDaemon.exe, steamwebhelper.exe, SkypeHost.exe, InstallAgent.exe, InstallAgentUserBroker.exe, ApplicationFrameHost.exe, taskhostw.exe, fontdrvhost.exe, dllhost.exe, SbieSvc.exe, smartscreen.exe, pwsafe.exe, explorer.exe, backgroundTaskHost.exe, synergy.exe,
[2016-10-13T15:53:10] DEBUG: found winlogon.exe in session 1
[2016-10-13T15:53:10] DEBUG: got token 776, duplicating
[2016-10-13T15:53:10] DEBUG: duplicated, new token: 780
[2016-10-13T15:53:10] INFO: starting new process
[2016-10-13T15:53:11] DEBUG: launched syntool to check active desktop
[2016-10-13T15:53:11] INFO: activeDesktop:Default
[2016-10-13T15:53:11] DEBUG: processes in session 1: csrss.exe, winlogon.exe, dwm.exe, glidesvc.exe, atieclxx.exe, sihost.exe, svchost.exe, taskhostw.exe, RuntimeBroker.exe, explorer.exe, mbam.exe, gziface.exe, ShellExperienceHost.exe, SearchUI.exe, LWEMon.exe, networx.exe, RadeonSettings.exe, Steam.exe, SbieCtrl.exe, VirtualDesktops.exe, VCDDaemon.exe, steamwebhelper.exe, SkypeHost.exe, InstallAgent.exe, InstallAgentUserBroker.exe, ApplicationFrameHost.exe, taskhostw.exe, fontdrvhost.exe, dllhost.exe, SbieSvc.exe, smartscreen.exe, pwsafe.exe, explorer.exe, backgroundTaskHost.exe, synergy.exe, syntool.exe, conhost.exe,
[2016-10-13T15:53:11] DEBUG: did not find logonui.exe in session 1
[2016-10-13T15:53:11] DEBUG: getting non-elevated token
[2016-10-13T15:53:11] DEBUG: duplicated, new token: 808
[2016-10-13T15:53:11] INFO: starting new process
[2016-10-13T15:53:11] INFO: drag and drop enabled
[2016-10-13T15:53:11] DEBUG: opening configuration "C:/Users/cag/AppData/Local/Temp/qt_temp.Hp2784"
[2016-10-13T15:53:11] DEBUG: configuration read successfully
[2016-10-13T15:53:11] DEBUG: screen shape: 0,0 4200x1200 (multi-monitor)
[2016-10-13T15:53:11] DEBUG: window is 0x00040504
[2016-10-13T15:53:11] DEBUG: using desktop for drop target: C:\Users\cag\Desktop
[2016-10-13T15:53:11] DEBUG: adopting new buffer
[2016-10-13T15:53:11] DEBUG: opened display
[2016-10-13T15:53:11] DEBUG: active sides: 4
[2016-10-13T15:53:11] DEBUG: active sides: 4
[2016-10-13T15:53:11] DEBUG: desk Default window is 0x000f05f6
[2016-10-13T15:53:11] DEBUG: switched to desk "Default"
[2016-10-13T15:53:11] DEBUG: desktop is now accessible
[2016-10-13T15:53:11] DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1
[2016-10-13T15:53:11] NOTE: started server, waiting for clients
[2016-10-13T15:53:11] DEBUG: event queue is ready
[2016-10-13T15:53:11] DEBUG: add pending events to buffer
[2016-10-13T15:53:11] DEBUG: accepted ipc client connection
[2016-10-13T15:53:11] DEBUG: screen "gamer" shape changed
[2016-10-13T15:53:11] DEBUG: start ipc handle data
[2016-10-13T15:53:11] DEBUG: ipc read: IHEL
[2016-10-13T15:53:11] DEBUG: finished ipc handle data
[2016-10-13T15:53:11] DEBUG: ipc hello, type=node
[2016-10-13T15:53:11] INFO: watchdog status: ok
[2016-10-13T15:53:12] DEBUG: started process, session=1, elevated: no, command="C:/Program Files/Synergy/synergys.exe" -f --no-tray --debug DEBUG --name gamer --ipc --stop-on-desk-switch --enable-drag-drop --enable-crypto --profile-dir "C:\Users\cag\AppData\Local" -c "C:/Users/cag/AppData/Local/Temp/qt_temp.Hp2784" --address :24800 --res-w 4200 --res-h 1200 --prm-wc 960 --prm-hc 600
[2016-10-13T15:54:15] INFO: OpenSSL 1.0.2 22 Jan 2015
[2016-10-13T15:54:15] INFO: accepted secure socket
[2016-10-13T15:54:15] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD
[2016-10-13T15:54:15] NOTE: accepted client connection
[2016-10-13T15:54:15] DEBUG: received client "browser" info shape=0,0 1680x1050 at 0,0
[2016-10-13T15:54:15] DEBUG: active sides: 4
[2016-10-13T15:54:15] NOTE: client "browser" has connected
[2016-10-13T15:54:38] DEBUG: screen shape: 0,0 1920x1200
[2016-10-13T15:54:38] DEBUG: screen "gamer" shape changed
[2016-10-13T15:54:50] INFO: switch from "gamer" to "browser" at 0,218
[2016-10-13T15:54:50] INFO: leaving screen
[2016-10-13T15:54:50] DEBUG: open clipboard
[2016-10-13T15:54:50] DEBUG: close clipboard
[2016-10-13T15:54:50] INFO: screen "gamer" updated clipboard 0
[2016-10-13T15:54:50] DEBUG: open clipboard
[2016-10-13T15:54:50] DEBUG: close clipboard
[2016-10-13T15:54:50] INFO: screen "gamer" updated clipboard 1
[2016-10-13T15:54:50] DEBUG: sending clipboard 0 to "browser"
[2016-10-13T15:54:50] DEBUG: sent clipboard size=1381
[2016-10-13T15:54:50] DEBUG: sending clipboard 1 to "browser"
[2016-10-13T15:54:50] DEBUG: sent clipboard size=1381
[2016-10-13T15:54:50] DEBUG: dropped bogus delta motion: +0,+0
[2016-10-13T15:54:50] INFO: switch from "browser" to "gamer" at 1884,549
[2016-10-13T15:54:50] INFO: entering screen
[2016-10-13T15:54:51] INFO: switch from "gamer" to "browser" at 0,421
[2016-10-13T15:54:51] INFO: leaving screen
[2016-10-13T15:54:51] DEBUG: open clipboard
[2016-10-13T15:54:51] DEBUG: close clipboard
[2016-10-13T15:54:51] DEBUG: ignored screen "gamer" update of clipboard 0 (unchanged)
[2016-10-13T15:54:51] DEBUG: open clipboard
[2016-10-13T15:54:51] DEBUG: close clipboard
[2016-10-13T15:54:51] DEBUG: ignored screen "gamer" update of clipboard 1 (unchanged)
[2016-10-13T15:54:52] INFO: switch from "browser" to "gamer" at 1903,844
[2016-10-13T15:54:52] INFO: entering screen
[2016-10-13T15:54:59] DEBUG: screen shape: 0,0 4200x1200 (multi-monitor)
[2016-10-13T15:54:59] DEBUG: screen "gamer" shape changed

Posts: 3
Joined: Thu Oct 13, 2016 1:01 pm

Re: server using wrong resol'n; can't reach client

Postby chris gallant » Wed Nov 30, 2016 2:28 pm

Figured it out!

With resolution @ 1920x1200, I was using 'Scaling' display setting of 125% to make text more readable.
(The slide bar above Orientation in Settings - Display)

Apparently, Windows 10 changed how they reported it, causing Synergy to think I had more pixels and so
could never reach the right edge of the screen(s).

I blame Windows by default, because it updates in the background and I would surely notice if I installed a
new version of Synergy and it stopped working. AMD updates in the background too, but my money's on MS.

Anyway, setting the 'Scaling' back to 100% fixes the Synergy problem. Windows lets you set font sizes for
Title bars, menus, icons, etc. but that is only a partial solution. E.g. the text in Control Panel where this feature
is located does NOT change ( [email protected] Microsoft)

Return to Crashing

Who is online

Users browsing this forum: No registered users and 1 guest