Mouse laggy on wifi, works well on ethernet

If you can't figure out where else to post.
User avatar
Posts: 1
Joined: Sun Nov 27, 2016 8:14 am

Re: Mouse extremely laggy on WiFi, works OK on Ethernet

Postby ZenBalancer » Sun Nov 27, 2016 8:17 am

I have the same issue, and the Synergy Support Agent said this to be a bug and offered me a refund or waiting for a fix.

I'm waiting for a fix, with no timeline given.

Posts: 2
Joined: Tue Dec 20, 2016 12:09 pm

Re: Mouse extremely laggy on WiFi, works OK on Ethernet

Postby Peter B. » Tue Dec 20, 2016 12:14 pm

Same issue here.
I know Synergy since its early days, and I've been using it in several environments without issues or lag. Even over WiFi.
The older version from Ubuntu's default repositories (v1.3.8) works fine.

With the current version 1.8.6-stable-2ab21aa, I experience the mouse-lag on a notebook over WiFi.
Connecting a cable is not an option, since this notebook doesn't have a connector anymore.


Anything we could do to help debugging this issue?

Posts: 1
Joined: Wed Dec 21, 2016 6:06 am

Re: Mouse extremely laggy on WiFi, works OK on Ethernet

Postby Peter B. » Wed Dec 21, 2016 6:09 am

I've now attached a borrowed USB ethernet adapter, and I can confirm that the mouse/keyboard lag is only an issue on WiFi.

Yet, it is still extremely annoying, and more of an issue as less notebooks have RJ45 jacks anymore :(
Is this something that can't be fixed, or is it simply very tricky to fix?
(Just curious to know if there's a remedy to expect :))

Thanks in advance!

Posts: 2
Joined: Mon Jan 02, 2017 2:06 am

Re: Mouse extremely laggy on WiFi, works OK on Ethernet

Postby Ruben Vandeginste » Mon Jan 02, 2017 2:26 am

I recently bought Synergy and I have the same problem: keyboard and mouse are lagging, which is very annoying. It does not seem consistent: at times it does work fluently and at other times mouse and keyboard get stuck for a couple of seconds. Both server and client are connected over WiFi.

Is any work done on this? This seems to be an existing issue since at least may 2016...

User avatar
Posts: 12
Joined: Wed Sep 28, 2016 1:44 am

Re: Mouse extremely laggy on WiFi, works OK on Ethernet

Postby Lyndsay Weitzel » Mon Jan 02, 2017 3:14 pm

Inconsistent lag can happen easily because of the way wireless connections work. Even on a network with only one client device can see lag simply because of electromagnetic noise in the air.

A few things you can do:

Run a ping utility to get an idea what kind of lag spikes your network has. Try it with normal network use and when no other devices are in use. Compare different wireless networks if you have the option.

Disable any unneeded apps that regularly use the network connection. This is important especially with download programs, such as a torrent client. Even when set to use only a small portion of your total bandwidth, the constant connection will introduce lag.

Check your wireless device. Reorienting the antenna, using a replacement antenna, physical position, signal barriers (walls), distance, Quality of Service (QoS) settings, checking for updates, signal channel, wireless protocol, replacement, etc.

User avatar
Posts: 15
Joined: Wed Feb 08, 2017 9:39 am
Location: Camberley, UK

Re: Mouse laggy on wifi, works well on ethernet

Postby Sam Rimmer » Tue Feb 14, 2017 6:20 am

To see if it's a network delay, rather than anything else, I'd try and get one computer to ping the other, if you're on windows simply open up cmd.exe and type "ping other.computer.ip.address" or if you're on Linux or macOS just open a terminal and enter "ping other.computer.ip.address"

This will give you the time taken for data to travel from one machine to the other and will reveal if network is the cause for your delay.

I hope this helps!
Sam Rimmer
Support Engineer
Synergy Team
Symless

Image Image

Posts: 3
Joined: Wed Feb 01, 2017 1:08 pm

Re: Mouse laggy on wifi, works well on ethernet

Postby William P Mackenzie » Wed Feb 22, 2017 12:17 pm

I have had similar issues with WiFi on a Surface Pro 2 and an Ethernet connected Lenovo laptop. While simply using ping from the Surface to the Laptop, the lags in mouse movement were consistent with either a drop of one or more pings or with periods of higher than average (10x) latency. I broke down last week and purchased a $15 USB to Ethernet Dongle and have been happy ever since...

For me the problem wasn't Synergy, if there are periods of latency is in the 100s of milliseconds then the client will not know the mouse has moved until 100ms later. Changing the WiFi Access Point/Router would likely have helped; as there is likely a bug in the access point when using the 2-4 year old wireless standards which constrain my Surface Pro 2.

Now, if we could get to the bottom of my multiple times per day mouse selection problems on the clients...

Posts: 5
Joined: Sat Feb 11, 2017 1:57 pm

Re: Mouse laggy on wifi, works well on ethernet

Postby Michael Park » Thu Feb 23, 2017 12:52 am

.
.
.
Re: viewtopic.php?f=16&t=2364

Synergy Issues (Bugs) on MacOS
Post by Michael Park » Wed Feb 15, 2017 10:44 am

Hi, I've used Synergy for several years (5+), but am new to these newer forums. After my first post on Feb 11, 2017 ("Synergy & Moom (MacOS)"), I read many posts made by other users regarding issues that I've been experiencing for years, and that are apparently still unresolved (smh). Fyi, I use 2-3 identical iMacs, same high-end model hardware and software on all machines. And all are connected via gigEthernet and ethernet switch.

1) The lag over WiFi has been a known issue for years. The WiFi lag is also the reason for failed or delayed cut&paste between server and client. (You may search past Synergy related forums, like those on Google Boards, to verify that these two issues have been known and discussed for years!) The only solution that I've found, is to connect all Server and Client machines via wired ethernet and ethernet switch.

2) Keyboard shortcuts entered from the Server do not work reliably on the Client. It's Synergy, not MacOS. This can be proven by using the Client's local keyboard and mouse on an identical machine which has the same keyboard shortcuts as the Server. There's still no solution available for this issue.

3) Mission Control, by keyboard shortcut or mouse tools (like MagicPrefs), does not work. Again, it's Synergy, not MacOS. This is also proven by using the Client's local keyboard and mouse on an identical machine which has the same keyboard shortcuts or mouse tools as the Server. There's still no solution available for this issue.

4) Unpredictable mouse control, and much faster and more sensitive mouse scroll and tracking speed on the Client machine has also been reported for years! From old forums, this was thought to be a Synergy bug when waking a machine from sleep mode, but even after restarting Server and Client, the odd behavior persists. There's still no solution available for this issue.

Unfortunately, there really isn't a comparable alternative solution to Synergy, so I tolerate the bugs. However, 5+ years seems an unreasonably long period of time for these issues to still exist; especially since the company now (and for the past year or so) asks users to buy a license. (And yes, I know I can get the builds off of Github for free, but I want to support the project, so I purchased a license.) But, this is getting old. If you want sell licenses, the Synergy project, or rather the company Symless, needs to get it together. Your users have been reporting the same issues for years, yet they still haven't been resolved. And btw, the knowledge base is just silly; it only has 8 articles. 8? Lol, cmon.

Bump this post if you agree. Thanks!

M

Previous

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests