Synergy 1.7.3 released

See announcements from the team.
Posts: 2
Joined: Wed Jun 17, 2015 8:22 am

Re: Synergy 1.7.3 released

Postby George Garner » Thu Jun 18, 2015 7:45 am

Many thanks the-wes.
As suggested I have just installed the latest update and initial tests are excellent. Synergy.exe CPU load on both PC's is now 0% :D
Good work
George

Posts: 2
Joined: Fri Jun 05, 2015 9:39 am

Re: Synergy 1.7.3 released

Postby Timothy Altman » Fri Jun 19, 2015 9:44 am

I too am having problems with SSL so I turned it off but i also experience other issues, and I'm still seeing them even with the latest nightly.
My server is running on OS X 10.10.3, and my client on Ubuntu 14.04.1.
One issue is that if I copy something on the client it won't be able to paste into the server and I see corrupted clipboard messages in the console.
2nd issue is that sometimes I can't type into the client as the server still has the keyboard focus even though my mouse and cursor are on the client's text field.

Posts: 7
Joined: Wed Jun 03, 2015 6:00 pm

Re: Synergy 1.7.3 released

Postby Andy Hall » Sun Jun 21, 2015 10:26 am

Nightly build 099c984 fixed the CPU usage issue for me on a pair of Windows 7 Pro 64-bit systems. In this regard I am a happy camper.

On both 1.6.3 and 1.7.3, I was occasionally experiencing MS Office programs losing focus. I had to bring up another window and then return to the Office program to regain focus and continue working. It was much more frequent in 1.7.3. Could it have something to do with the high CPU usage by synergyd.exe? If this continues on build 099c984, I will report back.

Well, as soon as I started taking screen shots, every time I moved the mouse from the server where I took a screen shot to my client, Synergy on the server crashed and the mouse started tracking unbelievably slowly. To stop this from happening I have to clear the clipboard of screen shots before moving to the client.

Here's the log,


INFO: entering screen
INFO: screen "Andy-Work" grabbed clipboard 0 from "Andy-Work"
INFO: screen "Andy-Work" grabbed clipboard 1 from "Andy-Work"
INFO: switch from "Andy-Work" to "Andy-Home" at 0,1049
INFO: leaving screen
INFO: bitmap: 496x678 32
INFO: convert image from: depth=32 comp=3
INFO: screen "Andy-Work" updated clipboard 0
INFO: bitmap: 496x678 32
INFO: convert image from: depth=32 comp=3
INFO: screen "Andy-Work" updated clipboard 1
ERROR: ssl error occurred (generic failure)
ERROR: error:1409F07F:SSL routines:ssl3_write_pending:bad write retry

// The following is probably from trying to recover
INFO: client "Andy-Home" has disconnected
INFO: jump from "Andy-Home" to "Andy-Work" at 960,540
INFO: entering screen
INFO: service command updated
INFO: process started but command is empty, shutting down
WARNING: shutdown timed out after 10 secs, forcefully terminating
Last edited by Andy Hall on Wed Jun 24, 2015 8:18 am, edited 1 time in total.

Posts: 2
Joined: Wed Jun 24, 2015 6:40 am

Re: Synergy 1.7.3 released

Postby MJ Mombourquette » Wed Jun 24, 2015 7:49 am

I upgraded like your announcement email back in May said, from 1.7.2 to 1.7.3 and thought everything was working. However, I soon became aware that my Surface 3 Pro client was running hot and the fan was always on and battery life went from 5+ hours to 45 min. I finally realized it is the new version causing this. The CPU usage on my client computer shot up to 37% and higher when I ran the client with the Synergy window closed. if I opened it up, CPU usage went back to normal. My server installation of 1.7.3 on my older desktop computer works fine. I finally uninstalled 1.7.3 and reinstalled 1.7.2 client and it works again. I hope this issue gets fixed on the next version.

Posts: 9
Joined: Thu Jun 04, 2015 4:59 am

Re: Synergy 1.7.3 released

Postby Vincent Ouwehand » Wed Jul 08, 2015 7:39 am

Been running 1.7.3 now for a few weeks and god it is unstable. My client regularly crashes and it regularly fails syncing clipboard.

Went back to 1.7.1 since i actually want to be able to do some work.

Posts: 76
Joined: Thu Jul 02, 2015 3:02 pm

Re: Synergy 1.7.3 released

Postby Brian S. » Fri Jul 10, 2015 5:46 pm

Vincent, some clipboard issues have been cleared up already in the latest nightly builds and more will probably be fixed for 1.7.4. The next stable release will be much better with regard to clipboard, and I hope you'll feel free to try out a nightly build to see whether it solves the issues.

Here's some info which would be useful in solving clipboard issues, if anyone having copy/paste issues would like to contribute by posting their answers to these:

- exact behavior when something crashes/doesn't work
- does Synergy continue working otherwise?
- minimum steps to make Synergy work again if it closes/crashes/stops
- Synbergy log content for each system involved, with logging level set to at least Debug
- SSL enabled?
- Synergy in "elevated" mode?
- size of content copied (exact size in bytes, if possible)
- where copied (application, OS, is it a Synergy server or client)?
- where pasted?
- problem occurs one-way, or both-ways?
- if successful in copy-pasting opposite way, does copy-paste the original way then work?
- intermittent?
- copying plain-text?
- are any non-English characters involved?
- are any clipboard managers such as Glipper, Glippy, or Klipper running?

Posts: 1
Joined: Fri Jul 17, 2015 7:19 pm

Re: Synergy 1.7.3 released

Postby Michael Scarchilli » Fri Jul 17, 2015 7:27 pm

I love the Synergy application, but I really wish I hadn't updated to 1.7.3. Now I find that often when some programs or even Mac System Preference are open that the mouse movement is very jerky and not smooth at all. There is also significant lag with this as well. I have tried this using two different Win7 machines as the server, and the MacBook (Yosemite 10.10.4) as a Client. They keyboard has a little lag sometimes as well, but it's not as noticeable as it is with the mouse. The lag and jerky movements with this mouse have made the program too frustrating and completely unusable now. I'm not positive which version I was on before, I really wish I did so I could download that one and use it. For now I'll just have to deal without the program because it's too annoying as it is now. :( Time to uninstall and try older versions. Ugh.

Posts: 5
Joined: Sat Apr 25, 2015 4:48 pm

Re: Synergy 1.7.3 released

Postby Scott G-D » Mon Jul 20, 2015 2:33 pm

Sadly, I think I'm going to have to step back to 1.7.2 as well. I just seem to have lost almost all stability on my PC Win 7 (server) and Mac 10.9.5 (client) setup. At least twice an hour, the Mac just stops responding. I have to go back to the Mac's trackpad and stop and restart the client to get things back to normal. It's especially fragile if I try to control my other MacBook Pro via Screen Sharing: half the time I step into the window on the Mac, the client just drops.

Never had these issues with 1.7.2. :(

Posts: 76
Joined: Thu Jul 02, 2015 3:02 pm

Re: Synergy 1.7.3 released

Postby Brian S. » Mon Jul 20, 2015 3:55 pm

From recent GitHub issues activity, it seems like some performance issues are fixed already in the latest pre-release versions and other issues are likely to be fixed for 1.7.4.

https://github.com/synergy/synergy/issues/4721

https://github.com/synergy/synergy/issues/4765

Posts: 7
Joined: Wed Jun 03, 2015 6:00 pm

Re: Synergy 1.7.3 released

Postby Andy Hall » Thu Jul 23, 2015 1:41 pm

On 7/15, I installed build v1.7.4-stable-b49b8e1 on my pair of Windows 7 Pro 64-bit machines. As advertised it is certainly much more stable than v1.7.3-stable-efd0108, especially with respect to clipboard activities. However, I am still seeing 50% CPU utilization by synergyd.exe on both the server and client machines.

Update (7/28). The CPU utilization seems to be intermittent an depends on conditions that are as yet unclear to me. I had to reboot my client machine (7/27) and the condition went away. This morning (7/28) when I woke up the server machine, the server was at 50% CPU, synergy was working but both the client and server synergy consoles indicated it needed to be started. The server had this in the logs.

[2015-07-27T17:45:12] WARNING: detected application not running, pid=6656
[2015-07-27T17:45:15] INFO: activeDesktop:Screen-saver
[2015-07-27T17:45:16] ERROR: failed to get desktop path, no drop target available, error=2
[2015-07-28T08:18:40] WARNING: failed to register hotkey ScrollLock (id=ef14 mask=0000)
[2015-07-28T08:18:47] WARNING: detected application not running, pid=4720
[2015-07-28T08:18:50] INFO: activeDesktop:Default
ERROR: ssl error occurred (system call failure)
ERROR: eof violates ssl protocol
ERROR: failed to accept secure socket
ERROR: ssl error occurred (system call failure)
ERROR: eof violates ssl protocol
ERROR: failed to accept secure socket
[2015-07-28T09:20:25] INFO: starting server
[2015-07-28T09:20:25] INFO: config file: C:/Users/Andy/AppData/Local/Temp/qt_temp.gq4016
[2015-07-28T09:20:25] INFO: log level: WARNING
[2015-07-28T09:20:27] INFO: activeDesktop:Default
Last edited by Andy Hall on Tue Jul 28, 2015 9:30 am, edited 1 time in total.

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 2 guests