Synergy 1.7.3 released

See announcements from the team.
User avatar
Posts: 67
Joined: Thu Apr 09, 2015 9:25 am
Location: Camberley, UK

Synergy 1.7.3 released

Postby Nick Bolton » Wed May 27, 2015 4:40 am

Hello,

I'd like to announce the release of Synergy 1.7.3.

» Download Synergy v1.7.3-stable

This version fixes the major SSL bugs (see below for details). Version 1.7.4 is due in about a month (track our progress).

Here's the bug fixes:

  • Bug #4565 - Incorrect plugin downloads on Debian and Mint
  • Bug #4677 - Windows service log file grows to very large size
  • Bug #4651 - High logging rate causes Windows service to crash
  • Bug #4650 - SSL error log message repeats excessively and freezes cursor
  • Bug #4624 - Runaway logging causes GUI to freeze
  • Bug #4617 - Windows service stops after 'ssl handshake failure' error
  • Bug #4601 - Large clipboard data with SSL causes 'protocol is shutdown' error
  • Bug #4593 - Locking Windows server causes SSL_ERROR_SSL to repeat
  • Bug #4577 - Memory leak in GUI on Windows caused by logging
  • Bug #4538 - Windows service crashes intermittently with no error
  • Bug #4341 - GUI freezes on first load when reading log
  • Bug #4566 - Client or server crashes with 'ssl handshake failure' error
  • Bug #4706 - Installer is not output to build config dir on Windows
  • Bug #4704 - Plugin 'ns' release build is replaced with debug build on Linux
  • Bug #4703 - Plugins are not built to config directory on Mac
  • Bug #4697 - Timing can allow an SSL socket to be used after cleanup call

And we also made some improvements:

  • Enhancement #4661 - Log error but do not crash when failing to load plugins
  • Enhancement #4708 - Download ns plugin for specific Mac versions
  • Enhancement #4587 - Include OpenSSL binaries in source for easier building
  • Enhancement #4695 - Automatically upload plugins as Buildbot step

Thanks,
Nick
CEO of Symless

Posts: 1
Joined: Wed May 27, 2015 7:34 am

Re: Synergy 1.7.3 released

Postby Craig Emery » Wed May 27, 2015 7:35 am

So I've installed 1.7.3-stable on Windows as a client and 1.7.3-stable under Debian as a server.
The encryption settings are different.
Windows speaks of a certificate.
Linux speaks of a password / PSK.

What do I do?


Ha, resolved.
I quit the upgraded server instance and restarted it & it asked for my "pro" credentials, and after logging in on that the server supported certs.
Nice that the fingerprint is /just/ visible in the server GUI.
Very simple fingerprint validation.

Nice work guys.

Posts: 10
Joined: Tue May 19, 2015 2:09 am

Re: Synergy 1.7.3 released

Postby Tomas Vorobjov » Wed May 27, 2015 8:08 am

Sorry but this installation executable is so annoying ... what's the point of using Synergy if the install cannot update the software without me having to shut it down, manually switch the keyboard/mouse cables (because the client is no longer running) and install it on each machine? And still getting this annoying error message that the service couldn't be installed and that I should check my user privileges. Then after the first failed install, of course the synergy service is marked for deletion and I have to manually edit the registry entries to get it back (no I absolutely cannot restart the machine as it is running calculation for days at a time). Here's what the installation executable should do:

1.) stop the synergy service
2.) update all files
3.) restart the synergy service

come on, virtually every piece of software out there does this without any issue. It is really that much to ask for?

Posts: 2
Joined: Tue May 05, 2015 5:34 am

Re: Synergy 1.7.3 released

Postby Steven Hoese » Wed May 27, 2015 8:59 am

Hello,
Great job on the new update! Version 1.7.2 never worked for me. I waited for the update and 1.7.3 works like a champ. Everything installed smoothly and up and running within minutes. You guys rock!

Posts: 1
Joined: Wed May 27, 2015 9:32 am

Re: Synergy 1.7.3 released

Postby mike laforet » Wed May 27, 2015 9:33 am

I did notice that when i installed and registered my 1.7.3 release on my PC and Mac to sync the two, the mouse works great! not jumpy which is GREAT! but I did notice that the keyboard does not carry over from my Mac to PC.

Posts: 23
Joined: Wed May 27, 2015 10:21 am

Re: Synergy 1.7.3 released

Postby Gareth Jones » Wed May 27, 2015 10:24 am

Tried installing 1.7.3 - Server is windows 7 -54bit client is redhat - 64 bit.

Cannot have different versions talk to one another - ok - kinda expected that looking at the changes.

Windows seems to install fine. Linus compains it cannot figure out what version of linux is running. When I run it i get the following:

ERROR: error:140C5042:SSL routines:SSL_UNDEFINED_FUNCTION:called a function you should not call
ERROR: failed to accept secure socket
INFO: accepted secure socket
NOTE: disconnected from server
NOTE: stopped client

So - bad things. 1.7.2 has issues with connections, 1.7.3 doesn't run. Next version please...

Posts: 1
Joined: Wed May 27, 2015 11:15 am

Re: Synergy 1.7.3 released

Postby Nicholas Sterling » Wed May 27, 2015 11:18 am

mike laforet wrote:I did notice that when i installed and registered my 1.7.3 release on my PC and Mac to sync the two, the mouse works great! not jumpy which is GREAT! but I did notice that the keyboard does not carry over from my Mac to PC.


I had the same problem. Keyboard and mouse worked fine on the Mac (the Synergy server), and the mouse moved to the Windows client as expected, but when I typed on the keyboard the characters went into the active window on the Mac. Rebooting Windows did not help, but rebooting the Mac did -- all is well now.

Posts: 16
Joined: Wed Apr 29, 2015 1:46 pm

Re: Synergy 1.7.3 released

Postby Scott Boutwell » Wed May 27, 2015 11:44 am

NON SSL is working now, however cannot get any of the SSL functions up and working.

Windows 7 32bit Synergy 1.7.3 server
OS X 10.10 Synergy 1.7.3 client
Windows 7 32bit Synergy 1.7.3 client

I'll post details in a different post, rather than addressing them all here.

Posts: 6
Joined: Mon May 11, 2015 6:54 am

Re: Synergy 1.7.3 released

Postby Dana Nickerson » Wed May 27, 2015 12:02 pm

Got 1.7.3 working between two Linux Mint 17.1 computers. After some trial and error I found that before you upgrade / install 1.7.3, you have to remove the .synergy directory on all systems. Then configure and you can turn on SSL and it works.

Posts: 3
Joined: Fri May 08, 2015 12:31 pm

Re: Synergy 1.7.3 released

Postby Terron Collier » Wed May 27, 2015 12:29 pm

YESS!!! It's working now! :D

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest