Albert Whale

Installing 1.7.5 fails

6 posts in this topic

I've had the problem before, and ITS BACK! So when I install 1.7.5 I get the following error mingwm10.dll is missing .... How do I fix this>???

Share this post


Link to post
Share on other sites
OK. I had this issue in 1.7.3 in May. I also paid for the Support. Can you please fix this now? Why does the installation Fail? I have to extract the files using 7-zip and then manually copy the info to the Program Files/Synergy folder. By why?

Share this post


Link to post
Share on other sites
This happens to me also. I even tried uninstalling it and reinstalling old versions that had previously worked, and get the same issue. I think it may have to do with some recent Windows Updates or something outside of the control of the Synergy devs. But the fact is that so far, only Synergy seems to be affected. No other programs are failing. Sadly, I don't have a solution, but at least you are not alone in your synergy-less-ness. I'd love to see a response on this from the devs.

Share this post


Link to post
Share on other sites
This happens with the last few installers released, or at least the 64-bit ones I used. The problem seems to be the DLL's do not get installed properly from the installer. To solve the missing DLL errors (there will be others after mingwm10.dll): 1. Open the installer with 7-zip or another zip program 2. Extract (drag and drop) all the DLL files you see to your Synergy install folder 3. Rename libgcc_s_dw2_1.dll to libgcc_s_dw2-1.dll because an error will pop up saying libgcc_s_dw2-1.dll is missing It should work after that.

Share this post


Link to post
Share on other sites
Same thing happened to me (Windows 7, 64-bit). Manually extracting/copying the files, and renaming libgcc_s_dw2_1.dll to libgcc_s_dw2-1.dll did the trick. I can vaguely remember that this was the case for 1.7.4 as well (last time I installed synergy), but couldn't exactly remember what to do ... so I had to find the solution all over again. While the "forgetting the solution part" is my problem, it would be nice if the installer did work "out of the box" without the need of manual intervention :).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now