Cory Thibault

BUG: Windows 10 Host - Unbuntu 15.10 Client (v1.7.5)

9 posts in this topic

Hello, Since the latest of Synergy (1.7.5) release a problem I have been experiencing is now 100% reproducible. When locking my computers if my mouse is on my client computer it causes the mouse to be lost and stuck on the client side. The keyboard is also locked to the client side. This can still happen even if the mouse is on my windows 10 computer when locking depending on which computer is locked first. The result is that I have to log into the client (ubuntu) computer with the shared keyboard then use a dedicated mouse on the client to go and disable Synergy. Once Synergy is disabled the mouse returns to the host and the keyboard works as well. Once logged in I have to re-enable Synergy on the client. As you can imagine this is very irritating! This problem existed in previous version but only now has it become consistent and even more likely to occur even if I follow the "proper" steps to lock the computers. Hopefully someone can look into this.

Share this post


Link to post
Share on other sites
I've also intermittently had this same problem in a Windows to Windows setup. I used to have 2x Windows 7 Pro devices side by side and had exactly the same symptoms as OP and had to resolve it in the same way. I've not experienced it since I replace the Windows 7 client with an OSX device and the Windows 7 server with a Windows 10 device. In fact I just tried locking all my screens with the mouse pointer focused on the client and was able to operate both machines. Both running Synergy 1.7.4

Share this post


Link to post
Share on other sites
Okay I've updated to 1.7.6 RC1 to see if there are any changes and there are none. I turned on Debug2 logging and noticed that when the problem occurs the mouse gets locked to the top left corner of the client screen. Moving the mouse violently causes it to move up to 30 pixels and then bounce back locked in the corner. Windows 10 log first and Ubuntu follows Check the logs here: [url]https://justpaste.it/synergy_windows10ubuntu15[/url] P: synergyhelpme Hopefully someone from Synergy actually looks here...

Share this post


Link to post
Share on other sites
Having exacly the same problem here with two windows 10 machines. I'm using 1.80 beta - still the same issue. It always happens after the synergy server pc was locked: Mouse coursor on the client machine sticking in the left top corner. Keyboard is "focused" on the client machine and I'm able to use it there. The server machine sticks on the logon screen. After stopping the synergy client process, I can use the server mashine with mouse and keyboard. Short after restarting the service on the client, the issuse happens again. I have to stop synergy on both sides and restart the service to bring it back to normal functionallity. This happens with 1.7.4 stable, 1.7.5 stable and all beta versions > 1.7.6 (but I didn't try an earlier beta!) Now I'm a bit frustrated.

Share this post


Link to post
Share on other sites
Just want chime in that I am having the same lock-screen problem on Windows 7 host, XP client, version 1.7.6. :(

Share this post


Link to post
Share on other sites
I just had this problem with v1.76 on a Windows 7 server and a Mac client. I almost pulled the plug on all my work until I tried shutting down the client first.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now