Sign in to follow this  
Felix Uster

Axis Sensitivity

2 posts in this topic

Hello, I'm new to Synergy. I have a desktop-pc with Windows 10 Pro N as Synergy Server and a Notebook with Debian 8.2 as Client. The connection between the two pc's is problem-free, but on the client (debian 8.2) is a strange behaviour of the mouse if I make slow moves to the right or the bottom. If my movement is to slow, no Input is registered. If I move the mouse to the top or the left, there is no Problem. Thanks for reading and sorry for grammatical errors. May someone help me? :)

Share this post


Link to post
Share on other sites
I'm having this exact same problem on my Windows 10 Pro (64-bit Synergy) server connecting to my Windows 7 (64-bit synergy) client. Everything was working fine a few days ago when I was on 1.4.18, but with upgrading to Windows 10, I took Synergy up to 1.7.5. Has anyone else come across this? It's incredibly frustrating on the client side, as it doesn't allow for precise clicking of E-mails, text, etc. EDIT: So I believe I've discovered what the issue is. On the Windows 10 server, I have a 4k monitor. Windows 10 has naively increase the size of text by 150% to make it easier to use, however this is slowing down mouse movements on the clients. I have moved the value back down to 100%, and the client is responding normally. I will try and log this as a bug. EDIT2: I was able to resolve this workaround by setting the compatibility of the exe files to Windows 7 and enabling the option "Disable display scaling on high DPI settings". Further info found at: [url]https://github.com/symless/synergy/issues/5030[/url]

Share this post


Link to post
Share on other sites
Ahhh.. yes, that is the exact problem I was having (I have a win10-64 server with 4k monitor and DPI scaling with a ubuntu 15.10 client). Mouse movements left or up weren't detected or came through in a very odd manner making it hard to move on the ubuntu client. And, actually, another of my favorite utils suffers from the same issue - altdrag for Windows requires you do this for Win8 and Win10 if DPI scaling is on. UPDATE: You need to use v1.7.4 to get this to work. Higher versions currently don't let this work.. annoyingly, 1.7.6 doesn't let this work but does fix a bug when copy-pasting from client to server. So, for now, 1.7.4 allows this workaround to function and I'll just avoid copy pasting ;) UPDATE2: Clarification, to get this to work, you need to change the compatibility for synergy[b]s[/b].exe and synergy[b]d[/b].exe (eg in C:\Program Files\Synergy) and you need to click the button to "Change for All Users" from them (right-click)->Properties->Compatibility tab

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this