Ian Tompkins

Pointer/cursor disappears on Linux client with Mac server

3 posts in this topic

Hello, When I move my pointer from my Mac server to my Linux (Ubuntu) client, the cursor is not visible. It appears to be functioning, as buttons change state when I hover over them and work when I click them. I just can't see where my pointer is; the button highlights are my only clue. Interestingly, the Ubuntu machine doesn't have a wired mouse plugged in, but if I plug one in and jiggle it, the cursor will appear and work with Synergy until a restart (I think). Server OS: OS X 10.10 Yosemite Client OS: Ubuntu 15.10 Server Synergy Version: 1.7.4 Client Synergy Version: 1.6.2 Any thoughts? Anything I can try?

Share this post


Link to post
Share on other sites
I have much the same issue: MacBook Pro Late 2015 OS-X 10.11.2 Synergy 1.7.6 Dell XPS 15 Ubuntu 15.10 Synergy 1.7.5 It takes about 10 - 15 seconds when moving from OS-X to Ubuntu. Once in Ubuntu, the cursor shows up, but then as soon as I start typing, specifically in a terminal, but it happens everywhere - the cursor disappears.

Share this post


Link to post
Share on other sites
No matter the server, this happens if there is no mouse plugged into the Ubuntu machine, The fix is to run this command a terminal. gsettings set org.gnome.settings-daemon.plugins.cursor active false Since my Ubuntu machine is handless, I put it in the .profile for my account and set the account to autolog in. Usually works, but not always. Your mileage may vary. The gist is, if ubuntu thinks there's not a mouse, it won't bother drawing a cursor, even if the mouse input is moving. The mechanic behind this I don't really understand, but that command seems to work, found it in the ether when I searched "ubuntu mouse cursor invisible" anyway, good luck.

Share this post


Link to post
Share on other sites
[quote="Rickey Ward"]gsettings set org.gnome.settings-daemon.plugins.cursor active false[/quote] I recognized this as the directory structure of dconf editor (which I have used before). So I launched that, unchecked the "Cursor Active" entry and rebooted. Obviously I trust that the terminal command would work quite nice as well for someone who doesn't have physical access to plug a mouse in. Anyhow, the mouse was recognized straightaway after reboot. Thanks a million! This was a small annoyance that added up after a few necessary reboots.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now