Ferdinand Goldmann

El Capitan cannot see my keyboard events

5 posts in this topic

Hello, I am running Synergy 1.7.4 on 10.11.1 server with a CentOS 6.5 client and cannot get the keyboard to work. Only the keys ctrl, alt, cmd, shift and caps lock work. I tried DEBUG2 on both the client and the server. The interesting observation is that Synergy does not even _RECOGNIZE_ other keystrokes than the ones above on the _SERVER_ side (= on my Mac). Synergy is allowed in the Security and Privacy/Accessibility preference pane. So what's the reason it does not see any keyboard events beside the modifier keys whatsoever? I tried googling the issue and found several explanations, including secure keyboard entry in iTerm2 and Chrome being the culprit. None of this helps in my case. Today I also tried downloading the latest nightly build 1.8.0 alpha. This didn't help either. For the moment, Synergy is broken unter El Capitan, at least for me. Anyone else running into this problem?

Share this post


Link to post
Share on other sites
I have a similar configuration, but with two issues - keyboard and mouse disappearing. I believe I have found the solution to the keyboard problem - I'm not certain synergy on El Capitan acting as the master can handle multiple IP addresses. I had to turn off wireless (I am connected via wire through USB through Thunderbolt2), and also shutdown Parallels desktop (which also provided additional IP addresses. When only one showed and was bolded in the window, my keyboard started working. Now, I need to determine how to get the mouse to display on my linux client - it is moving, it is just hidden. Good luck! Rick

Share this post


Link to post
Share on other sites
I read the hint about the dual network connection somewhere else and tried this already. It did not do anything for me. But maybe it's worth noting that I need to use Cisco Anyconnect at work. Still, I do not think that the issue is with the network connection, since my mouse works. Using debug mode, I can tell that Synergy does not even "see" my keyboard events on the server side! So there seems to be some other issue in my case.

Share this post


Link to post
Share on other sites
The client for me could only recognize some meta characters like shift and control. Try attaching a keyboard on the client, hold the shift key on the server, and press a key on the client? Does an upper case character appear? My mouse also worked while my keyboard did not. Does Anyconnect add another network interface? It sounds like it does. Is it possible to start synergy prior to starting anyconnect such that only one IP address shows in the server configuration window? When synergy connects, then you can open another program that adds a network interface. For me that was both turning on the wireless adapter and starting parallels. At that point, both the keyboard and the mouse worked for me.

Share this post


Link to post
Share on other sites
AnyConnect does indeed add a virtual network interface. Unfortunately I cannot test this without AnyConnect, since the client is located in a network which is only accessible with AnyConnect. That having said, I just managed to get it to work again with the nightly build from Nov. 17th. I am now running: client: synergy-1.8.0-1.x86_64, CentOS 6.5 server: 1.8.0 alpha 19835b6 OSX 10.11.1 I made no changes to the network setup whatsoever... it seems there was code introduced that made it work again... So I better not upgrade anything ever again. :->

Share this post


Link to post
Share on other sites
I am seeing the same symptoms, but downloading the build from Nov 17th does not fix the problem. My server is running Mac OS X 10.11.1 and the client is Win 7 SP1 x64. When I turn on DEBUG2 logging, I can only see keypresses in the server log for the meta keys (shift, ctl, etc.) If I attach a physical keyboard to the client, hold down the shift key on the server, and type on the client keyboard, I get capital letters, but I can't type anything on the server keyboard to show up on the client. Mouse works as expected.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now