Rodney Baker

Synergy Pro 1.7.1 crashes - cannot find libssl.so.10

9 posts in this topic

I've just upgraded from Synergy Basic to Synergy Pro. It downloaded and installed the libns.so plugin after activation, however synergy now crashes with the following message: DEBUG: loading plugin: libns.so ERROR: failed to load plugin: libns.so FATAL: An error occurred: libssl.so.10: cannot open shared object file: No such file or directory NOTE: stopping synergy desktop process This is running on openSuSE 13.1 x86_64. Libssl is installed (the openSuSE package is libssl27-2.0.5-9.1.x86_64). The default shared object file is /lib/libssl.so.1.0.0. I have created a symlink to this file called libssl.so.10 but that does not work (tried in /lib and /usr/lib. Another symlink /usr/lib/libssl.so was already created (presumably by an installation package as it wasn't me). The same behaviour occurs even after disabling ssl encryption in settings (even after restarting the gui). I love synergy, but this is just a little annoying because now it won't run at all. More detailed output from running with -d DEBUG2: DEBUG: opening configuration "/etc/synergy.conf" DEBUG: configuration read successfully DEBUG1: thread 0x00000002 entry DEBUG: plugins dir: /home/<username>/.synergy/plugins DEBUG: loading plugin: libns.so ERROR: failed to load plugin: libns.so DEBUG1: caught cancel on thread 0x00000002 FATAL: An error occurred: libssl.so.10: cannot open shared object file: No such file or directory

Share this post


Link to post
Share on other sites
Getting exactly the same issue after getting upgraded to Synergy Pro on Debian Sid. Debian does not provide a "libssl.so.10" file in any package. I've made sure I've updated my package lists. [code][~]$ apt-file search libssl.so.10 [~]$ [/code] You would indeed think that disabling SSL would unload the plugin, but no, it stays loaded and tries to enable itself. This is...odd, to say the least. EDIT: libssl.so is located in /usr/lib/x86_64-linux-gnu for me, so after doing [code]ln -s libssl.so.1.0.0 libssl.so.10[/code] I get [code]FATAL: An error occurred: libcrypto.so.10: cannot open shared object file: No such file or directory[/code] So, let's try it again [code]ln -s libcrypto.so.1.0.0 libcrypto.so.10[/code] [code]FATAL: An error occurred: /usr/lib/x86_64-linux-gnu/libcrypto.so.10: version `libcrypto.so.10' not found (required by /home/tails/.synergy/plugins/libns.so)[/code] Welp. Second EDIT: That last error message at least gives us the path to the problematic plugin, so... [code] [~]$ cd .synergy/plugins [~/.synergy/plugins]$ ls libns.so [~/.synergy/plugins]$ rm libns.so /bin/rm: remove regular file ‘libns.so’? y [/code] For now, removing the plugin located in ~/.synergy/plugins seems to be the only way to solve this. This disables the ability to use SSL, but, well, between having a non-functional SSL-enabled Synergy, or a functional Synergy without SSL, I think the choice is obvious. Hopefully this gets fixed at some point.

Share this post


Link to post
Share on other sites
I just went through this myself, except that I need the SSL encryption to work. I posted this over on this topic: viewtopic.php?f=18&t=75 "There is a bug with the version of the libns.so plugin that ships with the packages, which at the very least affects Debian and Ubuntu systems. https://github.com/synergy/synergy/issues/4565 the fix for it for Debian at least is: ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 /usr/lib/x86_64-linux-gnu/libssl.so.10 ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/lib/x86_64-linux-gnu/libcrypto.so.10 That MAY get you through the error, if it doesn't, then you will need to do like I did, and download the source tarball, and build the libns.so module from source, then move it into the ~/.synergy/plugins directory." If you're looking for a Debian specific version of the libns.so file, I can upload mine somewhere and you can try it. YMMV with it, as I don't have another Debian system to test using the module I built on my main system.

Share this post


Link to post
Share on other sites
I built synergy from source, which I thought would also build libns.so, but perhaps it was still trying to load libns.so from my ~/.synergy/plugins directory. I should have thought of copying libns.so from /usr/local/src/synergy (where it was compiled). I'll try that and report back.

Share this post


Link to post
Share on other sites
Yes - that fixed it. Synergy is now running with ssl, using the libns.so compiled from source. Synergy is installed from the rpm package.

Share this post


Link to post
Share on other sites
Has anyone been able to get 1.7.2 to work with Linux Mint 17.1? I compiled OpenSSL 1.0.2a 19 Mar 2015 hoping that would fix the the problem but I'm still getting this error: ERROR: failed to load plugin: libns.so FATAL: An error occurred: libssl.so.10: cannot open shared object file: No such file or directory NOTE: stopping synergy desktop process

Share this post


Link to post
Share on other sites
Try downloading the synergy source and building it (I do all my builds in /usr/local/src/<package>), then copy just libns.so to ~/.synergy/plugins (replacing the one automatically downloaded by synergy). That will build libns.so (the ssl plugin) against the version of libssl that you have on your system. Of course, make sure you have libssl-dev (or whatever it is called on Mint) installed first. To avoid this, synergy should either recompile libns.so at install time, or use a statically linked plugin. That would mean a larger file but it would avoid these version conflicts. In the mean time, there is a workaround.

Share this post


Link to post
Share on other sites
Founder Nick Bolton has posted a solution at this link: viewtopic.php?f=18&t=238 It may not be the problem you are facing but it is worth a try. Check it out and spread this link to anyone experiencing crash issues.

Share this post


Link to post
Share on other sites
Those issues don't seem related; the one you linked requires SSL to be enabled in the first place, and Synergy to actually start sharing, which is just plain impossible due to the issue detailed in this thread. The only workaround for now is what's been already said in this thread: recompile Synergy from source and copy the resulting libns.so to the local plugins directory.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now