Richard Åsberg

Just bought your software and can't get my PCs to connect

8 posts in this topic

I just bought your software hoping it will be more stable than the freeware alternatives I've already tried but it didn't start out very good and I hope it's just me missing something obvious. I've installed Synergy on both my PCs and configured the one with the keyboard and mouse as the server and the other PC (which is a laptop) as the slave. On the server PC when I click the Configure server button I only see my server PC, guess I should also see the client PC there to be able to arrange the screens? Looking on the client side I've configured it as a slave and typed in the IP address of my server PC. When I then hit the Start button on both PCs this is what I get in the log on the client PC where TheMiniNest is the hostname of my client PC and 192.168.1.100 is the IP of my server PC. [b][2015-10-21T20:54:07] NOTE: connecting to '192.168.1.100': 192.168.1.100:24800 [2015-10-21T20:54:07] ERROR: server refused client with name "TheMiniNest" [2015-10-21T20:54:07] WARNING: failed to connect to server: server refused client with our name [/b] Thanks in advance for your help guys!

Share this post


Link to post
Share on other sites
Hmm...doesn't like this feeling paying for a software I can't use and so far not a single reply to what I hoped was a very basic and simple problem. I'll wait until tomorrow and if I still haven't had any response and a solution so I can start using the software I'll make sure the deal will be called off.

Share this post


Link to post
Share on other sites
Richard, Exactly the same experience as you. I can't see the client picture, and the computers refuse to connect. I opened port 24800, but it seems like 24801 is listening. Hours of searching for good answers has not worked so far.

Share this post


Link to post
Share on other sites
Sorry to hear that, this piece of software belongs in the trash and that are charging for it is a bad joke. To solve the problem though I learned you need to drag the screen icon in the top right down on the grid. You can then configure it as your client. However that made me experience next problem...as soon as I move the cursor over to the client screen it disappears and only the keyboard works. Or maybe the mouse works too only the cursor is invisible but it's a bit tricky using the mouse doing guesswork... I've deleted this crappy software from my PC and went back to a FREE software called Input Director which comes highly recommended! Even when it's rather old and has a couple of issues it works 300% better than this junk and again...it's free. Let me know if you have any questions about how to set it up and I would be happy to help you out.

Share this post


Link to post
Share on other sites
For future reference, for anyone else who finds this thread when experiencing the issues mentioned. The error "server refused client with our name" means you need to add the client into your server configuration. Here are the steps: On the Synergy Server, click Configure Server. You should get a grid showing your computers represented by screen icons. You should have one icon on the grid for each computer in your Synergy setup. The icons should be named to match the Screen Names on each computer. If you need to add one, you can drag a new icon onto the grid from the upper right corner. If you need to remove one, you can drag its icon off the grid onto the trash can icon in the upper left corner. If you need to change the name on one, double-click on it to bring up its settings window. The name goes in the "Screen Name" box at the top. This name must match the actual name of the client computer in order to work. Do not add any aliases here unless you need to. Click OK when done. Click OK and click Apply and that should get you going. The issue with the mouse disappearing while running a Windows server is due to a Windows bug relating to the way screen scaling is handled. There is a workaround currently in testing: http://synergy-project.org/nightly?filt ... c1-ceab3a8

Share this post


Link to post
Share on other sites
Just to add a small note on the excellent reply by [b]the-wes[/b]. I had problems with my computers, where I tried to connect my laptop (as a client) to my stationary (server), but it keept giving the error [b]server refused client with name ****[/b]. I solved it by adding an alias in the "Screen settings" under "Configure Server...". You can find it by doubleclicking on the screen that represent the client. When I added the name, in your case [b]TheMiniNest[/b], and applied the changes (pressed Apply in the main window), immediately it worked. Afterwards I tried to alter the Screen name, so my previously set Alias now was the actual Screen name. It still works, but now I know exactly which computer I have where, instead of a skewed Screen name :-) I can see that the Alias might be good, when your computer name is not very saying and you want to identify it easily by example calling it [b]Laptop[/b] instead of [b]TheMiniNest[/b]. I hope this helps a bit more.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now