Matt Dresser

El Capitan - No Keyboard

26 posts in this topic

Updated to OS X 10.11 and lost keyboard functionality when acting as a server to connect with my two Linux boxes. Attempted reinstalling on each machine with no luck. Is anyone else running into this issue? [EDIT]: If I have one of the Linux boxes act as the server and have OS X act as a client (keyboard hooked up to the Linux box), works without any issues. Seems to just be an issue with OS X hosting it's keyboard.

Share this post


Link to post
Share on other sites
i too had that issue. until i switched off the wifi on my mac mini. both computers (macbook pro and Mac Mini) are connected via LAN but the mac mini also had wifi running. the moment i turned it off, it worked again. although it now works after toggling on and off my wifi for both computers, but that initial action solved my issue. hope it works for you.

Share this post


Link to post
Share on other sites
I have a very similar problem. Running El Capitan 10.11.1 here. - Synergy 1.7.4 (also tried nightly build 1.7.5-rc1 with no difference) on my Mac - Synergy 1.7.4 client running on CentOS 6.5. My mouse works. Interestingly enough, at least my shift key also works, bringing up the screen saver dialog. But once I try to enter the password, the characters appear in my terminal window on my Mac. So, for now, a non-functional product. Please fix it!

Share this post


Link to post
Share on other sites
Same problem here have two macs both running the newest version of El Capitain. I move the mouse to my client computer and it doesn't detect any typing at all even if I roll my fingers across the keyboard. Pretty frustrating considering I just bought this piece of software and haven't even gotten 1 days worth of work out of it.

Share this post


Link to post
Share on other sites
I also am having this issue. I recently updated my Mac desktop and laptop to El Capitan, and now I can only get the mouse to work. Also, my copy now says (UNREGISTERED) across the top on my Mac Desktop. Still says Synergy Pro on my laptop.

Share this post


Link to post
Share on other sites
Basically the same issue here..El Capitan as the host and keyboard is not working to the Windows 10 client.

Share this post


Link to post
Share on other sites
Same problem as well, El Capitan (10.11.3) as the host and no keyboard with Windows 7. Any idea on timeline to fix? From multiple replies in this post it should be repeatable to determine the problem.

Share this post


Link to post
Share on other sites
I have the same issue with El Capitan as host and client. I'm using version 1.7.5 of Synergy

Share this post


Link to post
Share on other sites
their facebook page states there will be a 1.7.6 release in the next couple of days. Here's hoping that resolves this frustrating issue.

Share this post


Link to post
Share on other sites
Same problem. Synergy 1.7.5 (REGISTERED). El Capitan 10.11.3 on Mac Mini. Have similar issue with MacOS screensaver coming and stopping keyboard. Solution was to move to MacOS screen (without seeing it), typing the MacOS PW and then moving back. Annoying but manageable. Client was Win 10 on DELL notebook (if that matters). This is different. Interestingly when I booted Win 7 (on Mac Air) it would let me type in the PW but keyboard stopped responding after that. I was careful not to type something into the Mac side and thus lose some kind of keyboard binding as other commentators have mentioned. Awaiting solution.

Share this post


Link to post
Share on other sites
Is there any news on this at all? This has made Synergy unusable across my Mac's for the past 3 months? When is the fix for this coming??

Share this post


Link to post
Share on other sites
Bump. I purchased Synergy back in November and just updated both Server (OS X 10.11.3) and Client (Ubuntu 15.10) to version 1.7.6. I cannot use the keyboard on the Ubuntu Client. I would appreciate a fix, or I'll be asking for my money back.

Share this post


Link to post
Share on other sites
installed 1.7.6 and I noticed that it has gotten worse. Now my return key also doesnt work. It has become super laggy too.

Share this post


Link to post
Share on other sites
I am seeing the same issue with 1.7.6 stable. Server OS X 10.11.3 client Win 8.1, mouse moves to and works on client but when I use the keyboard the input goes to my MAC. Kinda frustrating since I finally paid for the app just last week...

Share this post


Link to post
Share on other sites
There are a couple of things to check when the keyboard doesn't work on a client while the server is a Mac. 1. Keyboard layout. Pull up System Preferences, and then go into Keyboard Preferences and look under "Input Sources". It needs to be "U.S." exactly. If that doesn't appear there, you should be able to add it with the + sign at the bottom. 2. There is also a setting on Macs which can cause problems. It's hard to find in the interface, but various software triggers it automatically. The best place I've found is in the Terminal. With it open, open the Terminal menu up in the menubar. There is an item there for "Secure Keyboard Entry". If it's checked, uncheck it. If it's unchecked, check it and then uncheck it again. 3. Are you running SecureAnywhere? Try disabling it and see if the problem goes away. 4. Do you use LastPass or any other security-related software? This does the same as SecureAnywhere.

Share this post


Link to post
Share on other sites
Thanks for the reply. I got the keyboard to work once after toggling the "Secure Keyboard Entry" settings from Terminal. After Synergy restarted this stopped working. I am not looking for a workaround, I'm looking for a permanent, reliable, fix to be released. Thanks,

Share this post


Link to post
Share on other sites
I just purchased this software today. And I want my money back because of this issue. This is not what I remember Synergy doing AT ALL. :x

Share this post


Link to post
Share on other sites
Hello, I apologize for the delay in addressing this issue. I have created a bug report for this issue at https://github.com/symless/synergy/issues/5380. We do not yet have a fix for this, but thanks to this forum page and other user input, we do have some work arounds, as shown below: Option 1: Disable "Secure Keyboard Entry" Open the Terminal Go to the Terminal menu Uncheck "Secure Keyboard Entry" If it's already unchecked, check it and then uncheck it again Option 2: If a LAN is available, disable wifi Option 3: Swap the Mac to a client role Please let us know how this works for you.

Share this post


Link to post
Share on other sites
Hello, I have recently been made aware that some keystroke listening applications will block keystrokes to the client. LastPass is such an application. I have created a bug report for it, here: https://github.com/symless/synergy/issues/5382 We currently have no plans to develop a fix for this, as it was just added to the tracker. That said, I doubt that this will be a top priority for our developers.

Share this post


Link to post
Share on other sites
I'm running two iMac's with both operating systems running El Capitan. The Synergy software on both computers is version 1.7.6. I'm having the same frustrating problem of having the mouse work just fine but the keyboard does not work at all. I can't understand why the Synergy people are not at least responding that they are working on a solution. Why have a forum if you just ignore it?

Share this post


Link to post
Share on other sites
The Synergy people have replied multiple times. The issue is that those people are not clearly marked. However the primary purpose of the forum is for users to be able to help and get help from each other. The Synergy (now Symless) staff come in here when they are prompted to, however most of their focus goes to Pro users who submit help requests into their helpdesk ticketing system. This issue isn't strictly a Synergy problem - it's a quirk of the way OSX works. Of course Synergy will have to find a workaround for it, since we all know Apple is never going to fix anything, but until that workaround is found we will have to use our own. Did you try any of the tips mentioned in previous comments yet?

Share this post


Link to post
Share on other sites
Same problem occurred to me, the way it fixed for me, I had to quit my chrome browser on server machine and keys started working back fine on client. I restarted chrome browser on server and still the keyboard is working fine on client, not sure how long it will be until it stops working again. Hope this helps.

Share this post


Link to post
Share on other sites
In my case, the issue was the LastPass plugin in Safari. After login out from LastPass and close the browser, the keyboard started working in my client. So, as a workaround I am using the LastPass desktop application. Having this app running in the background does not interfere with the keyboard in my Synergy client box. The Lastpass desktop version has an option to "copy to clipboard" the password, so is pretty usable until a real fix is available.

Share this post


Link to post
Share on other sites
This seems odd, because I haven't had any issues at all using El Capitan (now running 10.11.6, but has worked in .3 - .6) as my server, with a linux client, using Synergy 1.7.6. I haven't configured anything in a terminal window, etc. I do not use LastPass. joe

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now