Jean Guillaume Dion

Problems installing on linux

3 posts in this topic

Hi, noob here. After unpacking the .deb im trying to start synergy and i get a /lib/x86_64_linux-gnu/libc.so6: version 'GLIBC_2.14' not found . Im using Kali 1.1.0 . Can anyone help? Thanks! EDIT: Nevermind found it.

Share this post


Link to post
Share on other sites
Hello all, I just purchased Synergy. Installing on linux I have a libc version problem, same as OP, but the cause may be different. On my debian wheezy desktop (glibc ver 2.13) synergy latest stable (1.7.5) tells me it requires glibc 2.14. I have a great deal of dev stuff on this machine and have to rely on it 100% so I am not about to "fake out" 2.14 for synergy specifically, or drop everything and upgrade to jessie. I cannot find any info in the changelog on github about how far back in synergy releases I have to go to get a release compiled against 2.13 glibc. I guess I could compile my own maybe, but I just paid $10 to save that time+effort... Please could someone suggest a glibc 2.13 release of synergy so I can avoid trial and error? In case anyone thinks to ask: [code] # synergy --help synergy: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by synergy) ... # ldd --version ldd (Debian EGLIBC 2.13-38+deb7u1) 2.13 ... [/code] Thanks.

Share this post


Link to post
Share on other sites
Update on my previous post. Summary: trying to install synergy as server on loaded up wheezy dev machine, and add OSX 10.11 client. Current problem: can't find compatible versions. I can install synergy (1.3.8-2 Debian:7.9/oldstable [amd64]) via apt-get (thank you to irc #synergy folks for help here :) ) and also synergy (1.4.16-1~bpo70+1 Debian Backports:/wheezy-backports [amd64]) from backports. The OSX client (1.7.5) will not talk to either of these, with a message like "cannot connect client 1.5" (sorry I do not have the precise message in front of me (or packages installed) right now. I've tried compiling from source on my wheezy machine versions 1.7.5, 1.6.3, 1.5.1 and 1.4.18 with the following error in all cases (I've confirmed all the deps listed for debian 8 (not 7.5 nb.) are installed): [code]$ ./hm.sh conf -g1 ... QMake command: qmake gui.pro -r Entering dir: src/gui Project MESSAGE: Warning: unknown QT: widgets [/code] google seems to think 'widgets is a Module of Qt5'? So I have tried: [code]$ QT_SELECT=4 ./hm.sh conf -g1 [/code] ..with same error. I only have QT4 (plus a compatibliity lib for QT3) installed. Would really appreciate any suggestions on what to try next...

Share this post


Link to post
Share on other sites
Following [url=http://stackoverflow.com/questions/23979798/include-qtwidgets-not-working-in-qt-4]this stackoverflow hint[/url] I edited src/gui/gui.pro and made the following change: [code]from QT += widgets \ to QT += gui \ [/code] The 1.7.5 source then compiles ok. I have not even skimmed any other synergy source code, so I have no idea if there are other impacts, but I get synergy binaries that run on my wheezy machine, and accept OSX10.11 client, so #worksforme. (Seems very quiet here?)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now