Alberto Zeledon

Failed to accept secure socket

5 posts in this topic

I recently ugraded my "Server" machine to Windows 10 and installed Synergy version 1.7.4 Windows Firewall is turned off. The client machine was working before...firewall exceptions were created When trying to connect the Client machine the server reports the following: [2015-09-28T15:22:53] NOTE: accepted client connection [2015-09-28T15:23:02] WARNING: failed to accept secure socket [2015-09-28T15:23:04] NOTE: accepted client connection [2015-09-28T15:23:17] WARNING: failed to accept secure socket [2015-09-28T15:23:18] NOTE: accepted client connection is there a way to fix this??

Share this post


Link to post
Share on other sites
I have the exact same problem but have not gotten a suitable response. One person did suggest turning off SSL (which) I did and that stopped the error message. However now any time get within a few inches of the swtich over to the client my mouse disappears and will not return on the client or server. I am able to ctrl-alt-del to get the task manager screen and the mouse then comes back to the server...until I try it again. This started about a week+ ago and I have not been able to correct it. My guess is the issue is known and Synergy wants us to "buy" support for the fix. Even after we have donated to buy the product.

Share this post


Link to post
Share on other sites
I have a similar problem Mac 10.10.5 as either server or client using 1.7.4 connecting to Mac 10.8.5 using 1.7.4 ssl error occurred (generic failure) [2015-09-30T11:40:50] ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol [2015-09-30T11:40:50] ERROR: failed to connect secure socket [2015-09-30T11:40:51] NOTE: disconnected from server I saw others say they turned off ssl on windows How do I do that on my Mac?

Share this post


Link to post
Share on other sites
Edit > Settings ... uncheck the option "Use SSL encryption (unique certificate) " even on linux client they have this setting (attached screenshot..)

Share this post


Link to post
Share on other sites
I had this issue and was able to fix it. Turn off SSL encryption settings on all clients and servers, and apply the config. Turn on SSL encryption on the server and apply. Then turn on ssl encryption on each client and apply - once you click apply, you will be prompted with a fingerprint of the SSL certificate from the server. After accepting, all was good.

Share this post


Link to post
Share on other sites
Please tell me to turn off SSL encryption setting on OSX 10.11.1 I have a similar problem Mac server and Windows7 client El Capitan installed synergy1.7.4 Windows7 installed synergy 1.3.4 Synergy showed below log [2015-10-26T23:26:22] NOTE: accepted client connection [2015-10-26T23:26:33] WARNING: failed to accept secure socket [2015-10-26T23:26:35] NOTE: accepted client connection [2015-10-26T23:26:47] WARNING: failed to accept secure socket [2015-10-26T23:26:48] NOTE: accepted client connection

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now