Sign in to follow this  
Reno McDonald

incompatible client 1.4

3 posts in this topic

I am very unhappy at the moment. I have used Synergy since I first discovered it years ago. It has been free. Now seeing that it costs, I dug up the old versions I used in the past. Okay. So after being frustrated that Synergy was only working one way for me (I want the client/server swapped) I decided to buy the Basic version for $10 so I could have a function I already had before. Now both machines, Ubuntu and OSX 10.9, have the same version. I verifie this on the about page of both. Version 1.7.4 freshly downloaded from the website. However, I still get the same issue: [code][2015-09-19T13:30:39] NOTE: connecting to '192.168.1.3': 192.168.1.3:24801 [2015-09-19T13:30:39] WARNING: failed to connect to server : incompatible client 1.4 2015-09-19 13:30:39.743 synergyc[22999:507] starting cocoa loop [2015-09-19T13:30:40] NOTE: connecting to '192.168.1.3': 192.168.1.3:24801 [2015-09-19T13:30:40] WARNING: failed to connect to server: incompatible client 1.4 [2015-09-19T13:30:41] NOTE: connecting to '192.168.1.3': 192.168.1.3:24801 [2015-09-19T13:30:41] WARNING: failed to connect to server: incompatible client 1.4 [2015-09-19T13:30:42] NOTE: connecting to '192.168.1.3': 192.168.1.3:24801 [2015-09-19T13:30:42] INFO: stopping synergy desktop process [2015-09-19T13:30:42] WARNING: failed to connect to server [2015-09-19T13:30:42] INFO: process exited normally[/code] Now, if I get this working, I normally would ask for a refund as I wouldn't have needed this version (seeing as the problem was NOT version related (I thought perhaps 1.4 was hard cut-off by the devs)) but instead im just going to call it a day and chalk it up to good software support :). Sorry if I seem frustrated; I think I spent too much time troubleshooting when I should have came on the forums ages ago :P. Thanks for helping. ;)

Share this post


Link to post
Share on other sites
Hi! So you have been using Synergy for some time now? After upgrading to the 1.7.x version, running the Registration Wizard immediately after upgrading is really good idea. There are a few files that aren't part of the installation package, they are generated when you run the wizard. If you still have the ones from the previous version then it won't connect. So first we need to know if you have gone through the Registration Wizard again.

Share this post


Link to post
Share on other sites
Ive been running Synergy on my mac machines in the past before (I did the setup again from archived setup files (which are now really old)). I was shocked to find it cost money now. I ran the setup wizard on the client (OSX) and it seemed to work. I also did a reboot on the host machine (linux) so Im not sure if that helped either. Wow what an easy fix 0_0. Im not sure what fixed it but thanks for the help :D

Share this post


Link to post
Share on other sites
Excellent! If the setup wizard doesn't give any errors then you are all set. Just remember to do it first thing after every Synergy upgrade.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this