Arturo Espinosa Aldama

FIXED - Windows 10: mouse trapped in clients, pointer gone

8 posts in this topic

Not actually fixed, but I found a workaround. I hope a bug fix is eventually available with the following information: I have a simple setup: three computers, two with Windows 10 (Used to have 7, upgraded to 10), one Vista. The server is a Windows 10 machine. All software upgraded to 1.7.4 using Pro. When I move the mouse to either edge to reach either client, the pointer first "bounces" off the edge, back into the server's screen. Move the pointer a second time into the same edge and then the pointer disappears and I can't move it back to the server. The keyboard still works, so I use it to stop the client, and so the mouse is predictably back to the center of the screen in the server machine. When the mouse is trapped in either of the clients, you can tell that focus is still happenning, in a weird way, so some sort of tracking is still going on. OK, while trying to document the bug, I have found the origin of the problem (and a solution for me): Windows 10 user interface scaling on the server is causing a screen geometry calculation error. This probably happens on the clients as well, you would have to test. To reproduce, on the server side (Windows 10), right-click on the desktop and select Display settings. A metro app with the System Settings will appear, with the Display section selected (title: "Customize your display"). There's a horizontal scrolling selector with the text "Change text size of text, apps, and other items". If you select something different to 100% (say, 125%), and click Apply, and then probably restart synergy afterwards, the bug will happen. If I move this setting to 1:1 (100%), synergy works correctly. This started happening when I configured a new user account on the server which used the default 125% scaling. I noticed that when I used the original account, synergy went on just fine. I am unsing a copy of the same sgc configuration file for both accounts. Now I have put scaling on the new account to 100% and everything is fine now.

Share this post


Link to post
Share on other sites
I have this same problem. Thanks for the tip. I am not happy with this bug. Synergy is a great product but I cannot use it and windows scaling at the same time.

Share this post


Link to post
Share on other sites
Check the link to the github tracker above. There is a solution using compatibility parameters that allows synergy to run with no problems under a desktop that uses scaling.

Share this post


Link to post
Share on other sites
i am having this problem now, disabling the scaling hasn't provided a work around. I was running Windows 7 as the server with a Windows 10 client, last week i upgraded Windows 7 to 10 and everything was working fine and then shutdown the server machine for the weekend, now i have this problem on Monday. the mouse bounces a few times away from the edge of the server machine, then gets stuck on the client in the lower right hand corner. i've attempted to disable scaling on both, restarted the services, nothing. using version 1.7.4 any help would be appreciated, thanks.

Share this post


Link to post
Share on other sites
went back and read through all the comments on the bug report and after using the "change settings for all users" as others have reported doing, this workaround is now working for me.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now