David Rice

mouse moves too fast on client machine

11 posts in this topic

I am running my synergy host on a mac book pro (10.10). I have a client machine running on Windows 8.1. When I move the mouse to the client Windows 8.1 machine the mouse moves extremely fast. Is there some way to slow it down so I can use it? If I only move my mouse a very small bit it moves a long ways. If I really slow down my mouse movement, I can get it to work but it is a bit annoying. Thank you for any help. David Rice

Share this post


Link to post
Share on other sites
I am having the same issue. I play a game on two machines and when I move the mouse to the client machine and attempt to use the mouse it moves extremely when using it to manuver a character in the game. The mouse movement itself, moving around, seems OK. But if I use it to try and move the character in the game, it will spin the character real fast et cetera. I cannot seem to find a setting to combat this.

Share this post


Link to post
Share on other sites
Is it always too fast? Mine occasionally speeds up on the client (PC), typically if my server (mac) locks/sleeps then wakes. I found stopping and starting the server on the mac fixed it.

Share this post


Link to post
Share on other sites
[quote="Tom Scase"]Is it always too fast? Mine occasionally speeds up on the client (PC), typically if my server (mac) locks/sleeps then wakes. I found stopping and starting the server on the mac fixed it.[/quote] It is always fast. If I stop it on my main and start it it slows it down on the main, but the client is always fast.

Share this post


Link to post
Share on other sites
Good news Everyone! I think I might have figured it out! I'm running Linux as the server, and Windows 7 as the client. In my case, I see the extreme mouse sensitivity when I launch a 3D or fullscreen app. Tooling around the desktop is fine, no problems. If I set a keyboard hotkey in Synergy to "Lock" the cursor to my current screen, my mouse sensitivity immediately returns to normal. Toggling my Lock hotkey will toggle that insane mouse speed. Try setting a cursor lock hotkey in Synergy, from the server. Hopefully that will normalize your mouse speed.

Share this post


Link to post
Share on other sites
[quote="Ben Koenig"] Try setting a cursor lock hotkey in Synergy, from the server. Hopefully that will normalize your mouse speed.[/quote] Can you explain how to do this and what exactly it's doing? I found the Hotkey's section under Server Config. I can set a Hotkey, then for the action I set Press a Hotkey? Or Release or Press & Release? Then I choose Lock Cursor to Screen, do I pick Toggle, On or Off? Then under This action is performed when: The hotkey is pressed or the hotkey is released? Can you give the steps to the configuration you did so we can replicate? I would appreciate it a lot! Thanks!

Share this post


Link to post
Share on other sites
Sure thing. For my action I set "Lock cursor to screen" as a toggle. everything else as defaults should be fine. What this does is stop your mouse cursor from hopping server to client. Maybe there are some applications that get confused when synergy is controlling your mouse/screen, and for some of those this helped me.

Share this post


Link to post
Share on other sites
[quote="Ben Koenig"]Sure thing. For my action I set "Lock cursor to screen" as a toggle. everything else as defaults should be fine. What this does is stop your mouse cursor from hopping server to client. Maybe there are some applications that get confused when synergy is controlling your mouse/screen, and for some of those this helped me.[/quote] Ah, there is a default key for that already, just hit Scroll Lock. It does seem to resolve the speed issue when you lock a mouse to a screen. Hopefully Synergy will fix the issue or make a setting so we don't have to lock the mouse to a screen. Like whatever separation changes happen when you lock a mouse to a screen have that done automatically when you switch screens with the cursor. Thanks!

Share this post


Link to post
Share on other sites
I have this same problem. I'm running a Synergy server on a MacBook Pro (10.10.5 Yosemite), and a client on a Windows 7 desktop. Usually, like Tom, stopping and restarting Synergy on my server solves the problem.

Share this post


Link to post
Share on other sites
Same problem here - the mouse movement on the client sometimes goes crazy fast. Possibly after server sleep/wake. Restarting the server machine makes the mouse movement on the client go back to normal speed.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now