Chase Olson

Linux Client error Server is Dead

10 posts in this topic

Hello, I have 3 machines running the Synergy software Windows 10(server), Linux Deepin "Ubuntu" desktop (client), and a macbook pro osx 10.10 (client). The software works great between the windows 10 machine and the Mac but the Linux client randomly disconnects and says the server is dead. I will post the log below. If I click apply on the linux client synergy software it connects again right away, please help because this is a really annoying problem. I also have all of the machines on the same Gigabit switch so there isn't a networking issue that would be causing the client to disconnect. 2015-08-31T08:59:14] NOTE: server is dead [2015-08-31T08:59:21] INFO: stopping synergy desktop process [2015-08-31T08:59:21] INFO: process exited normally [2015-08-31T08:59:21] INFO: starting client [2015-08-31T08:59:21] INFO: config file: /tmp/qt_temp.PR2312 [2015-08-31T08:59:21] INFO: log level: NOTE [2015-08-31T08:59:22] NOTE: started client [2015-08-31T08:59:22] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-08-31T08:59:22] NOTE: connected to server [2015-08-31T09:01:37] NOTE: server is dead

Share this post


Link to post
Share on other sites
I've seen this also but my Synergy server is running on a MacBook Air running OS X 10.9.5 and the Linux client is a Centos 6.7.

Share this post


Link to post
Share on other sites
I see this problem very often too. Can someone from synergy team look into it? It is annoying. My server is on osx 10.10 and client on ubuntu. I don't need to restart the server in order to bring it back to work. I just stop - start the client and it reconnects successfully.

Share this post


Link to post
Share on other sites
I am trying to reproduce this on Linux/Win7. In the meantime there is a setting (Edit -> Settings) to produce a more detailed log. While I fiddle with my setup, can you post your log after enabling "Debug1"?

Share this post


Link to post
Share on other sites
There is a lot of info missing which would help reproduce. What is the Synergy version in each case? 32-bit or 64-bit? Is each OS 32-bit or 64-bit? Are you using any non-default settings? What is your network setup (physical topography, settings such as non-default firewall settings, etc.)? Is there any security software which could be interfering, and if so what is it (name and version)? It might be helpful to get debug log on both server and client, and with debug level turned up. It might help us to get more info about the "random" disconnects: how often, are you doing anything with the systems when this happens or can it even happen at idle, and so forth.

Share this post


Link to post
Share on other sites
Server: Windows 10 64bit (this was happening before the upgrade to windows 10) Client Center: deepin Linux 64bit (Debian) Client Right: Macbook Pro OSX el capitain It does it randomly and when I use copy and paste, I will get you the log once it happens again.

Share this post


Link to post
Share on other sites
Hi, I have the exact same problem with the following setup : Server: synergy 1.7.4 64bits on macbook pro with OSX El Capitan Client: synergy 1.7.4 64bits on linux fedora 20 I'm experiencing several random disconnection from the client, just by reopening synergy window on the client, it reconnects itself. Here's the log : [2015-10-09T10:28:38] INFO: leaving screen [2015-10-09T10:28:38] DEBUG1: thread 0x0000000e entry [2015-10-09T10:28:38] DEBUG: open clipboard 1 [2015-10-09T10:28:38] DEBUG1: request selection=PRIMARY (1), target=TIMESTAMP (440), window=2c00004 [2015-10-09T10:28:38] DEBUG1: request succeeded [2015-10-09T10:28:38] DEBUG1: selection conversion failed for target TIMESTAMP (440) [2015-10-09T10:28:38] DEBUG1: can't get ICCCM time [2015-10-09T10:28:38] DEBUG: ICCCM fill clipboard 1 [2015-10-09T10:28:38] DEBUG1: request selection=PRIMARY (1), target=TARGETS (438), window=2c00004 [2015-10-09T10:28:38] DEBUG1: request succeeded [2015-10-09T10:28:38] DEBUG1: selection conversion failed for target TARGETS (438) [2015-10-09T10:28:38] DEBUG1: selection doesn't support TARGETS [2015-10-09T10:28:38] DEBUG: available targets: STRING (31) [2015-10-09T10:28:38] DEBUG1: request selection=PRIMARY (1), target=text/html (548), window=2c00004 [2015-10-09T10:28:38] DEBUG1: request succeeded [2015-10-09T10:28:54] DEBUG: ssl connection closed [b][2015-10-09T10:28:54] NOTE: server is dead[/b] [2015-10-09T10:28:54] DEBUG1: selection conversion failed for target text/html (548) [2015-10-09T10:28:54] DEBUG1: no data for target text/html (548) [2015-10-09T10:28:54] DEBUG1: request selection=PRIMARY (1), target=image/bmp (549), window=2c00004 [2015-10-09T10:28:54] DEBUG1: request succeeded [2015-10-09T10:28:54] DEBUG1: selection conversion failed for target image/bmp (549) [2015-10-09T10:28:54] DEBUG1: no data for target image/bmp (549) [2015-10-09T10:28:54] DEBUG1: request selection=PRIMARY (1), target=text/plain;charset=UTF-8 (550), window=2c00004 [2015-10-09T10:28:54] DEBUG1: request succeeded [2015-10-09T10:28:54] DEBUG1: selection conversion failed for target text/plain;charset=UTF-8 (550) [2015-10-09T10:28:54] DEBUG1: no data for target text/plain;charset=UTF-8 (550) [2015-10-09T10:28:54] DEBUG1: request selection=PRIMARY (1), target=UTF8_STRING (301), window=2c00004 [2015-10-09T10:28:54] DEBUG1: request succeeded [2015-10-09T10:28:54] DEBUG1: selection conversion failed for target UTF8_STRING (301) [2015-10-09T10:28:54] DEBUG1: no data for target UTF8_STRING (301) [2015-10-09T10:28:54] DEBUG1: request selection=PRIMARY (1), target=text/plain;charset=ISO-10646-UCS-2 (551), window=2c00004 [2015-10-09T10:28:54] DEBUG1: request succeeded [2015-10-09T10:28:54] DEBUG1: selection conversion failed for target text/plain;charset=ISO-10646-UCS-2 (551) [2015-10-09T10:28:54] DEBUG1: no data for target text/plain;charset=ISO-10646-UCS-2 (551) [2015-10-09T10:28:54] DEBUG1: request selection=PRIMARY (1), target=text/unicode (552), window=2c00004 [2015-10-09T10:28:54] DEBUG1: request succeeded [2015-10-09T10:28:54] DEBUG1: selection conversion failed for target text/unicode (552) [2015-10-09T10:28:54] DEBUG1: no data for target text/unicode (552) [2015-10-09T10:28:54] DEBUG1: request selection=PRIMARY (1), target=text/plain (553), window=2c00004 [2015-10-09T10:28:54] DEBUG1: request succeeded [2015-10-09T10:28:54] DEBUG1: selection conversion failed for target text/plain (553) [2015-10-09T10:28:54] DEBUG1: no data for target text/plain (553) [2015-10-09T10:28:54] DEBUG1: request selection=PRIMARY (1), target=STRING (31), window=2c00004 [2015-10-09T10:28:54] DEBUG1: request succeeded [2015-10-09T10:28:54] DEBUG1: selection conversion failed for target STRING (31) [2015-10-09T10:28:54] DEBUG1: no data for target STRING (31) [2015-10-09T10:28:54] DEBUG: close clipboard 1 [2015-10-09T10:28:54] DEBUG1: thread 0x0000000e exit [2015-10-09T10:28:55] DEBUG: retry in 1 seconds [2015-10-09T10:28:55] WARNING: failed to connect to server: server is not responding [2015-10-09T10:28:56] NOTE: connecting to '192.168.202.25': 192.168.202.25:24800 [2015-10-09T10:28:56] DEBUG1: connecting to server [2015-10-09T10:28:56] DEBUG1: connected; wait for hello

Share this post


Link to post
Share on other sites
Same problem here. My setup consist of two Linux Boxes on Ubuntu Vivid on which one of the nodes occasionaly is booted in Windows 7. With the (outdated) packages from the Ubuntu repositories I had no problem. To get my windows system connected I upgraded to the paid version 1.7.4. Since then I have problems in the Linux-Linux setup which lead to stop and start the synergy server to get the client connected again. It is reproducable by the following steps - move mouse pointer to client - use clipboard (select text - right mouse click - copy) - move mouse pointer to server After that mouse can not be moved back to the client. Below what happens in the log of the server: (servername: micro, clientname: neo) [code] [2015-10-17T09:35:06] NOTE: started server, waiting for clients [2015-10-17T09:35:07] NOTE: accepted client connection [2015-10-17T09:35:07] NOTE: client "neo" has connected [2015-10-17T09:35:13] INFO: switch from "micro" to "neo" at 3519,919 [2015-10-17T09:35:13] INFO: leaving screen [2015-10-17T09:35:14] INFO: switch from "neo" to "micro" at 45,666 [2015-10-17T09:35:14] INFO: entering screen [2015-10-17T09:35:15] INFO: switch from "micro" to "neo" at 3519,781 [2015-10-17T09:35:15] INFO: leaving screen [2015-10-17T09:35:16] INFO: switch from "neo" to "micro" at 18,683 [2015-10-17T09:35:16] INFO: entering screen [2015-10-17T09:35:20] INFO: switch from "micro" to "neo" at 3519,745 [2015-10-17T09:35:20] INFO: leaving screen [2015-10-17T09:35:21] INFO: screen "neo" grabbed clipboard 1 from "micro" [2015-10-17T09:35:22] INFO: screen "neo" grabbed clipboard 0 from "micro" [2015-10-17T09:35:23] INFO: switch from "neo" to "micro" at 35,557 [2015-10-17T09:35:23] INFO: entering screen [/code] Same time on the client [code] [2015-10-17T09:35:07] NOTE: connected to server [2015-10-17T09:35:13] INFO: entering screen [2015-10-17T09:35:13] INFO: clipboard was updated [2015-10-17T09:35:13] INFO: clipboard was updated [2015-10-17T09:35:14] INFO: leaving screen [2015-10-17T09:35:15] INFO: entering screen [2015-10-17T09:35:16] INFO: leaving screen [2015-10-17T09:35:20] INFO: entering screen [2015-10-17T09:35:23] INFO: leaving screen [2015-10-17T09:35:31] NOTE: server is dead [2015-10-17T09:35:31] WARNING: failed to connect to server: server is not responding [2015-10-17T09:35:32] NOTE: connecting to '192.168.1.2': 192.168.1.2:24800 [2015-10-17T09:35:47] WARNING: failed to connect to server: Timed out [/code]

Share this post


Link to post
Share on other sites
2015-10-21T17:15:23] NOTE: disconnected from server [2015-10-21T17:15:24] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-21T17:15:31] NOTE: connected to server [2015-10-22T05:16:00] NOTE: disconnected from server [2015-10-22T05:16:01] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T05:16:04] NOTE: connected to server [2015-10-22T05:16:06] NOTE: disconnected from server [2015-10-22T05:16:07] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T05:16:10] NOTE: connected to server [2015-10-22T08:07:02] NOTE: disconnected from server [2015-10-22T08:07:03] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T08:07:06] NOTE: connected to server [2015-10-22T08:07:12] NOTE: disconnected from server [2015-10-22T08:07:13] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T08:07:16] NOTE: connected to server [2015-10-22T08:12:02] NOTE: server is dead [2015-10-22T08:12:21] INFO: stopping synergy desktop process [2015-10-22T08:12:21] INFO: process exited normally [2015-10-22T08:12:23] INFO: starting client [2015-10-22T08:12:23] INFO: config file: /tmp/qt_temp.qq1667 [2015-10-22T08:12:23] INFO: log level: NOTE [2015-10-22T08:12:23] INFO: log file: /var/log/synergy.log [2015-10-22T08:12:23] NOTE: started client [2015-10-22T08:12:23] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T08:12:23] NOTE: connected to server [2015-10-22T08:54:46] NOTE: disconnected from server [2015-10-22T08:54:47] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T08:54:50] NOTE: connected to server [2015-10-22T10:31:14] NOTE: disconnected from server [2015-10-22T10:31:15] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T10:31:18] NOTE: connected to server [2015-10-22T10:40:08] NOTE: server is dead [2015-10-22T10:40:24] INFO: stopping synergy desktop process [2015-10-22T10:40:24] INFO: process exited normally [2015-10-22T10:40:25] INFO: starting client [2015-10-22T10:40:25] INFO: config file: /tmp/qt_temp.Sa1667 [2015-10-22T10:40:25] INFO: log level: NOTE [2015-10-22T10:40:25] INFO: log file: /var/log/synergy.log [2015-10-22T10:40:26] NOTE: started client [2015-10-22T10:40:26] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T10:40:26] NOTE: connected to server [2015-10-22T10:43:17] INFO: process exited normally [2015-10-22T10:43:17] INFO: detected process not running, auto restarting [2015-10-22T10:43:18] INFO: starting client [2015-10-22T10:43:18] INFO: config file: /tmp/qt_temp.sc1667 [2015-10-22T10:43:18] INFO: log level: NOTE [2015-10-22T10:43:18] INFO: log file: /var/log/synergy.log [2015-10-22T10:43:18] NOTE: started client [2015-10-22T10:43:18] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T10:43:18] NOTE: connected to server [2015-10-22T10:43:26] INFO: stopping synergy desktop process [2015-10-22T10:43:26] INFO: process exited normally [2015-10-22T10:43:28] INFO: starting client [2015-10-22T10:43:28] INFO: config file: /tmp/qt_temp.FV1667 [2015-10-22T10:43:28] INFO: log level: NOTE [2015-10-22T10:43:28] INFO: log file: /var/log/synergy.log [2015-10-22T10:43:28] NOTE: started client [2015-10-22T10:43:28] NOTE: connecting to '10.1.124.50': 10.1.124.50:24800 [2015-10-22T10:43:28] NOTE: connected to server

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now