jimbro1000

Corruption of keyboard input

12 posts in this topic

I am currently using 1.7.4 on two workstations running windows 7 pro x64 but this particular problem has plagued me for a while (at least three releases of Synergy). I've seen post here that hint at a similar problem but I can't see anything that really matches. Periodically the keyboard input on a client workstation becomes corrupted. Initially I just thought the keyboard had stopped working (indeed I grabbed a new keyboard at one point to see if that was the problem - it wasn't). The mouse continues to operate correctly. Since this started happening though I have noticed that the keyboard is still working but it is as if various modifier keys (ctrl, shift, alt) are being pressed and this is resulting in some very strange behaviour. Since 1.7.4 was installed this has also affected the mouse input too, single clicks become ctrl-clicks or ctrl-alt-clicks. I haven't found any particular pattern to this behaviour, I can go days without it happening and sometimes it starts within a relatively short time. The only consistency to this is that if I leave my computers locked for any length of time, once unlocked it will already be in this state or soon fails afterwards. In terms of fixing it I can sometimes get away with stopping and starting the Synergy service on both computers but the most reliable method is a straight forward reboot, usually just the client will suffice but occasionally it needs both the server and client workstations to be rebooted. I've not seen any errors in the log when this happens and other than the bizarre keyboard input I cannot see anything wrong at all. Anyone got any ideas on how to fix this - it is really disruptive when it happens A colleague of mine is running the same setup and has not had any of these symptoms and all of our workstations are imaged from a common build image, this doesn't exclude problems with the OS but seems to point straight back at Synergy. The only big difference I can find is that my two workstations are running on different subnets (the reason why I have two workstations to begin with).

Share this post


Link to post
Share on other sites
+1 on this! I have 1 keyboard and mouse, 2 windows 10 computers x64 using build 1.7.4 from time to time the keyboard will act funny when controlling the server computer. For example Right now I am typing this sentence on the client computer and all is good. On the server computer I have a word document open. If I try to type in the document on the server the letters don’t come out but instead it makes the computer do something else almost like running a macro. If I type the letter D the document will minimize. If I type the letter S then Cortina pops up. If I type the #2 the file explorer pops up. Ever letter is a new adventure. If I shut down synergy and restart then some times this fixes the issue for a while. If I (Ctrl-C) on the client and then (Ctrl-V) it into a document on the server sometimes this fixes it for a while. Only consistent fix is computer reboot. [b]This is a huge pain in the ass![/b]

Share this post


Link to post
Share on other sites
I just posted in another thread but I'm having these issues as well. I ended up uninstalling Synergy as it was causing way too many problems. Shouldn't software you pay for work correctly? I understand it's a small dev team and we don't pay much but something like copy/paste should at least work.

Share this post


Link to post
Share on other sites
I am also experiencing a similar issue at least a couple of times a day. I'm only running with one client (server is win 7, client is win 10) and every once in a while the alt, shift or ctrl keys will get stuck when I move back to the server. Every keyboard or mouse interaction acts as though one of those keys is pressed and held down. I can unstick them by pressing those keys once and things are fine for a while again.

Share this post


Link to post
Share on other sites
I am using Windows 10 and I have two keyboards installed on the server computer, US English and Punjabi. Often times when I move the mouse back and forth between the server and the client, Synergy changes the active keyboard on the server. Very annoying.

Share this post


Link to post
Share on other sites
I had a, I presume, related issue where after locking my pc and Mac, the key mapping would corrupt. I would type "qwerty" on the server keyboard and end up with "uaaeeruu" on the client side (the "q" would yield "ua"). I am using a Win7x64 server and MacOSX Capitan client. It is a recurring issue after I come back to locked computers. What dose not resolve these issues for me is restarting/quitting Synergy 1.7.5. What resolved the issue was either rebooting both pc and Mac or changing the keyboard layout from my usual language to another and back. Maybe this last tip also helps other users?

Share this post


Link to post
Share on other sites
I was able to make a change to my windows configuration and i can fix it by hitting the shift key to turn off this permanent background caps lock that synergy generates. I am running windows 7 with a linux client machine. This seems to be a problem since april 2015. Is there any fix in sight?

Share this post


Link to post
Share on other sites
I'd like to add my +1 to this issue - Running 1.7.4 as Server on Win10, 1.7.4 as client on Win7. I don't have key corruption, so much as stuck keys when switching back to server desktop from client, usually the Windows key. Quitting Synergy fixes it.

Share this post


Link to post
Share on other sites
[quote="scott coburn"]+1 on this! ... If I try to type in the document on the server the letters don’t come out but instead it makes the computer do something else almost like running a macro. If I type the letter D the document will minimize. If I type the letter S then Cortina pops up. If I type the #2 the file explorer pops up. Ever letter is a new adventure. ... [b]This is a huge pain in the ass![/b][/quote] Yep, same thing I get - those are Windows Key shortcuts (Win+D = show desktop, Win + S = search, Win+2 = Explorer (as is Win+E).

Share this post


Link to post
Share on other sites
+1 for this fix I have Win7 server with keyboard running 1.7.6 and Win 10 client running 1.7.6 ( was having the issue in 1.7.5 but I just upgraded and saw the same issue ). Overall I LOVE Synergy but it gets tiring when I switch screens and just start typing only to find that I am hitting a bunch of ctrl+<key> sequences instead. When I switch from the server to the client it will some times act like I am holding down ctrl, shift or alt. There seems to be no rhyme or reason to what causes it and it is usually only one key acting stuck at a time. I have a keyboard connected to the client computer as a backup. If I hit ctrl, shift AND alt on it and then do the same on the server keyboard then the key becomes "unstuck". I have a non-standard setup of Synergy in that I have hot key mappings so "ctrl-shift-1" does switchToScreen(client) and "[email protected]" does switchToScreen(server). I then have those hot keys mapped to mouse buttons 6 and 5 respectively on my Evoluent mouse. I can consistently replicate the error using my mouse switching back and forth quickly. I can not as easily replicate by mousing between screens or using the hot keys. *NOTE* I just tested this again setting the hot key action to happen on key stroke release instead of key stroke press. This made it slightly harder to replicate but it still occurs.

Share this post


Link to post
Share on other sites

Seems this is still an issue on the latest version (1.8.2-stable-36cd521).

 

I have Windows 10 Pro as the server and Linux as the client (specifically Fedora 21 - 4.1.13-100.fc21.x86_64). No fancy config other than to map my mouse back/forward buttons to Alt+Left and Alt+Right keystrokes.

 

I'm finding that mostly CTRL and SHIFT keys become "stuck", and generally only become unstuck if I press/release the correct one. I haven't been able to determine any common scenario to repeat it. It just seems to happen at random.

 

Other than that ... amazing app!

Share this post


Link to post
Share on other sites

Hi, I am getting extremely frustrated as I just installed synergy and the only key I can use on my keyboard is the letter a. Anyone understand what I should do to fix this...

using Imac keyboard and mouse and mac book pro.

Thank you,

Agathe

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now