Sign in to follow this  
B. Thomas Romeo

1.71 Issues with Win10/Mac

2 posts in this topic

I was using earlier versions of Synergy fine between a Win 10 laptop and an iMac. But now the cursor just "bounces" back from the Windows server when trying to go to the Mac and the Mac says "WARNING: cursor may not be visible INFO: entering screen INFO: leaving screen" pretty much over and over as I try to drag to the Mac. Any thoughts?

Share this post


Link to post
Share on other sites
This issue appears to be due to a feature relating to high-resolution screens called "desktop display scaling" - while the screen is zoomed, the mouse position is reported to Synergy incorrectly - always lower and to the right of the actual position. Since most clients are to the right of their servers, this usually results in the mouse cursor getting stuck in the lower right corner of the client screen. When the client is to the left of the server, the incorrect position is actually back across the border on the server screen, so the mouse cursor appears to "bounce" off the edge. There are two possible solutions to this that I've found so far. I hear each of them are successful about equally, so I can't say one is necessarily better than the other. The first is to set Synergy specifically to ignore the zoomed-screen info using compatibility settings: Go to the synergy install folder Right click on synergys.exe and click Properties Switch to the "compatibility" tab "Change Settings for all users" (synergys can run as a different user) Click the checkbox for "Deactivate scaling for high DPI value" (the one above run as admin) Click OK Open your Synergy app the usual way (from the Start screen, you can just type synergy) and click Apply or Stop/Start Alternatively, if you set the whole screen to not scale, keeping it at 100% all the time, Synergy will get the right mouse position info. Here are the instructions for that: Right-click on the Desktop (any empty spot) Click Personalize Click Display in the lower-left corner (under "see also") Click the checkbox for "Let me choose one scaling level for all displays" Select the option for "Smaller - 100%" Click Apply This is tracked here: https://github.com/synergy/synergy/issues/4041

Share this post


Link to post
Share on other sites
A similar situation Configuration Win 10 server running Synergy 1.7.4 Win 8.1 client using same Synergy; client has high resolution screen obliging me to use large text size (250%) Problem: once PCs sync, mouse disappears on client screen and stays there, cannot get control of server back unless I kill synergy with task manager on client side using local mouse. I've tried suggestion to change properties of synergy.exe (Click the checkbox for "Deactivate scaling for high DPI value") but no change. I can't use standard 100% text size because letters are the size of fly droppings. I can't use synergy any more. any suggestions would be welcome (apologies but I posted it also on another subject in 1.7.4 crashes

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this