Mike Nelson

Default (bold) IP address on server is incorrect one

16 posts in this topic

Hello, Running the server on a Win8.1 machine with multiple IP's due to VMware Workstation install. When Synergy starts up, it takes one of the Host-only IP's that Workstation creates and not the true Ethernet IP. This causes "auto-config" not to work and having to input a manual IP address into the client. This is problematic since the DHCP IP address on the server could change and the point is to avoid manual intervention with this product. Now, I do see a field under "Edit -> Settings called "Interface:". But no idea on what to put there so it always takes the ethernet0. Bug? Feature Request? Help? Thanks! Mike

Share this post


Link to post
Share on other sites
I assume you mean in the interface field. if it works, it should be added to the Wiki. Thanks for the info!

Share this post


Link to post
Share on other sites
I think the best fix for you would be the same as for another users problem when using his VPN. Change your connection order... control panel, network and sharing center, change adapter settings, advanced (if you don't see it press alt), advanced settings. Make sure the Network Adapter you want synergy to see as the default is the first in the list.

Share this post


Link to post
Share on other sites
Thanks TheMartyJoy, but it did not change the default (bolded) IP that Synergy has. I did restart the computer and checked the binding order again and it is set with the Ethernet connection as first, but Synergy shows the VMware vNic as bold still. So, that fix doesn't always seem to work. Mike

Share this post


Link to post
Share on other sites
I'm having the same problem, my primary NIC is the top one but it's using the wrong one (specifically it's using the virtualbox virtual network adapter) It's worth noting that my home network using 10.0.0.X and the virtualbox is using 192.168.X.X so I wonder if it's trying to find the default network using a pattern.

Share this post


Link to post
Share on other sites
I also am having the same problem with Synergy selecting the wrong IP address. I also have a VM instance running on this system some of the time. I have tried settings-> Interface to the mac address (00 0a cd 1c 29 b0) of the NIC card I want it to use and i get the following error INFO: starting new process activeDesktop:Default INFO: starting new process synergys.exe: address not found for: 000acd1c29b0 Try `synergys.exe --help' for more information. WARNING: detected application not running, pid=12372 There doesn't be a way to specify which IP address the server should run on.

Share this post


Link to post
Share on other sites
I'm having the same issue. I have VMware Player installed, and Synergy takes its virtual interface address as default IP address. So "Auto config" setup with Bonjour is not working as client tries to connect to the server with this non-reachable IP address. I need to control the order of interfaces Synergy looks up in order to determine its "default" IP address. At least, I need to be able to specify 2 interfaces - one for wired LAN and the other for wireless LAN. ----- I then noticed the post by TheMartyJoy, and it worked! So the feature was there, it just I wasn't able to reach it.

Share this post


Link to post
Share on other sites
*bump* Anyone for Synergy acknowledging this? The suggested solutions do not work, running Windows 8 so maybe that's why the suggestion didn't work but been trying to use Synergy and this renders the product unusable so it's kinda a big deal in my opinion.

Share this post


Link to post
Share on other sites
[quote="Dailen"]*bump* Anyone for Synergy acknowledging this? The suggested solutions do not work, running Windows 8 so maybe that's why the suggestion didn't work but been trying to use Synergy and this renders the product unusable so it's kinda a big deal in my opinion.[/quote] +1 [url=http://shot.qip.ru/00zh4R-6NGYkKe2v/][img]http://f6.s.qip.ru/NGYkKe2v.png[/img][/url] Same situation - I have a lot of subnets and want to specify IP-address I want to use. Now bold one - is wrong.

Share this post


Link to post
Share on other sites
I am having the same problem. The wrong IP address is highlighted and my client will not recognize when I type in the 172.27.30.23.

Share this post


Link to post
Share on other sites
I unchecked the Use SSL Encryption box and my Synergy is now working, even with the Bolded VPN address. Yay!

Share this post


Link to post
Share on other sites
The fix below did change the interface order in the GUI. However, when switching from wired to wireless or VPN, sometimes the wrong one would be bold. [quote="TheMartyJoy"]Change your connection order... control panel, network and sharing center, change adapter settings, advanced (if you don't see it press alt), advanced settings. Make sure the Network Adapter you want synergy to see as the default is the first in the list.[/quote] [quote="TheMartyJoy"]Try using the MAC address of the adapter using the proper IP[/quote] Entering the MAC Address under Settings > Interface didn't work for me, but [b]entering the IP address here did[/b]. From the synergys.exe --help, it sounds like it is looking for an IP address? [quote]The argument for --address is of the form: [<hostname>][:<port>]. The hostname must be the address or hostname of an interface on the system. The default is to listen on all interfaces.[/quote] In the configuration file, aliases can be entered for the screen name. FQDN and IP addresses seem to work here too.

Share this post


Link to post
Share on other sites
In Edit -> Settings -> Interface I was able to specify an actual IP address. For running multiple NIC's you do need to be explicit and tell Synergy which IP you are currently using. This is an advanced use case where the automagical solution (Bonjour) can fail. I suggest picking an interface to use for Synergy and avoid changing it. Wired without DHCP is ideal. This helps me keep track instead of letting addresses bounce around.

Share this post


Link to post
Share on other sites
I thought the issue went away with viewtopic.php?t=77#p986 , but it came back again. [attachment=0]20150607-netif-detail.png[/attachment] [attachment=1]20150607-SynergyPro.png[/attachment] Both LAN and WLAN interface have higher priority than VMware virtual interface, but Synergy still uses IP address of the virtual one for zeroconf annoucement. So there must be something other than Windows interface ordering that make Synergy use wrong interface for server IP announcement.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now