csp

Synergy won't auto start on Debian stretch (using autologin)

1 post in this topic

I have synergy working mostly has a few quirks, but the biggest 2 issues for me right now are the following:

1- synergy doesn't auto start when restarted or booted.  I am using auto login so it bypasses the login portion of linux start up, but i have to physically use the old mouse for the system to click on the synergy icon to start the program and be able to use the keyboard and mouse of the server (windows 10 machine).  I can't find any settings to set the program to start automaticially on system startup or reboot, only the check box for hide after start.  can anyone help me figure out why its not running at startup?  figured this would have been part of the boot process like a regular keyboard or mouse i would expect?

 

2- if i use the copy/paste function or anything else that is a bit astray from mouse clicking or keyboard text entry, it has a tendancy to lock me in the windows machine which again requires the linux machine to have the mouse on standby.  i am connecting using wifi, only have one IP address,and have the security features turned off. i have tried the auto config method with the same result.  it gets very frustrating. 

 

when it works its fantastic when it breaks its more annoying having to fix then it was before without it.  i have a ordered a crossover cable to see if a direct connection makes any difference over the wifi connection, hoping that resolved the connection drop out, but it im not sure if that will resolve the start up issue, thinking not since it needs to start in order to work.

 

Any help is greatly appreciated!

 

Chris

 

thanks in advance!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now