james425

Windows 10 supported?

21 posts in this topic

Has Synergy been tested with Windows 10? Before I upgrade I want to make sure that my Synergy solution will continue to work. Has the dev team tested this? Or have any users tried it? Result? Thanks! James

Share this post


Link to post
Share on other sites
I have been using the program on Windows 10 since the early beta. My Mac OSX has been the server and the Windows Machine has been the client. I have found little quirks, but the program works overall. The only quirk that I did find was on an active directory. When a computer is set to login, it takes a few minutes for Synergy to register that the app is active. I had to move the mouse to the edge of my Mac OSX window and try to move into the Windows area. It won't register at first but try a few times. Eventually, it will click and move into the Windows 10 area. Very tollerable.

Share this post


Link to post
Share on other sites
Thanks Charles- appreciate it. Sounds like it should work fine. Will give it a try at some point here and report back.

Share this post


Link to post
Share on other sites
I have found an issue with Windows 10. I have been using Windows 10 on my Surface for a while now, and it didn't really have any issues until I upgraded my work laptop yesterday. THe configuration is one laptop that is the server, only yesterday upgraded to Win10. The client is my surface. When using Synergy now, it exits the Laptop screen and enters the client but then the cursor disappears. You can't get back to the control of the mouse with the server unless you stop Synergy on the client. If you right click, a prompt comes up to 'Show Desktop' and 'Peek Desktop'. Setting debug on the logging levels you see the following message: [2015-07-31T09:20:47] DEBUG: SetCursorPos did not work; using fakeMouseMove instead So for some things Synergy and Windows 10 works, for others...not so much.

Share this post


Link to post
Share on other sites
Same issue as Mitch Nicholls, Windows is my server and I have Ubuntu 15.04 on my client, once server was updated to Windows 10 I move the cursor to the Ubuntu box and it will disappear and I am unable to return control to the server until synergy is killed or pc is rebooted on the client. I had to roll back to Windows 7, as I use this setup daily. Hope this gets ironed out soon.

Share this post


Link to post
Share on other sites
[quote="David Michael"]Same issue as Mitch Nicholls, Windows is my server and I have Ubuntu 15.04 on my client, once server was updated to Windows 10 I move the cursor to the Ubuntu box and it will disappear and I am unable to return control to the server until synergy is killed or pc is rebooted on the client. [/quote] Im running Windows 10 on Desktop PC and Surface 2. This problem only appears, if client screen is positioned (and configured in synergy) to the right of the servers screen.

Share this post


Link to post
Share on other sites
I upgraded my synergy server PC first yesterday and had no issues, my laptop (on the left of my server pc) was fine while still running 8.1 I just upgraded my laptop to windows 10 and now I am having the same cursor issues listed above. The cursor moves over but disappears. My client periodically shows the error message ERROR: corrupted clipboard data, expected size=4 actual size=0 i can get control of my mouse back if i keep scrolling it to the right even thought i cant see it, eventually the client freaks out and i get my cursor back on my server pc

Share this post


Link to post
Share on other sites
[quote="Florian Klein"][quote="David Michael"]Same issue as Mitch Nicholls, Windows is my server and I have Ubuntu 15.04 on my client, once server was updated to Windows 10 I move the cursor to the Ubuntu box and it will disappear and I am unable to return control to the server until synergy is killed or pc is rebooted on the client. [/quote] Im running Windows 10 on Desktop PC and Surface 2. This problem only appears, if client screen is positioned (and configured in synergy) to the right of the servers screen.[/quote] I did not know this, but yes my client is configured to the right side of the server. I will have to do some testing for different positions but that seems like a pretty good isolation of the issue, if that is the case.

Share this post


Link to post
Share on other sites
So would it be fair to say... that when windows 10 is the client, there are little to no issues. And the issues only arise when Windows 10 is the server?

Share this post


Link to post
Share on other sites
I have Windows 10 working as a server with a Windows 7 as client. I originally had issues when I was using 125% text size where the mouse cursor disappears when moving into the client screen. Once I changed the text size setting to 100%, it works. It is not ideal and my fonts look really small now on my display.

Share this post


Link to post
Share on other sites
[quote="Steven Wong"]I have Windows 10 working as a server with a Windows 7 as client. I originally had issues when I was using 125% text size where the mouse cursor disappears when moving into the client screen. Once I changed the text size setting to 100%, it works. It is not ideal and my fonts look really small now on my display.[/quote] Steven - on which computer did you have to change the text setting (and where did you locate this setting)

Share this post


Link to post
Share on other sites
[quote="Andrew Anderson"][quote="Steven Wong"]I have Windows 10 working as a server with a Windows 7 as client. I originally had issues when I was using 125% text size where the mouse cursor disappears when moving into the client screen. Once I changed the text size setting to 100%, it works. It is not ideal and my fonts look really small now on my display.[/quote] Steven - on which computer did you have to change the text setting (and where did you locate this setting)[/quote] I have been watching this thread before I do the upgrade, but to change the font size, if it's the same as Windows 7, Control Panel>>>Display>>>Set Custom DPI. But on Windows 7 the default is 100% unless it's changed by the user.

Share this post


Link to post
Share on other sites
[quote="David Michael"]Same issue as Mitch Nicholls, Windows is my server and I have Ubuntu 15.04 on my client, once server was updated to Windows 10 I move the cursor to the Ubuntu box and it will disappear and I am unable to return control to the server until synergy is killed or pc is rebooted on the client. I had to roll back to Windows 7, as I use this setup daily. Hope this gets ironed out soon.[/quote] I wonder if this is 2 things as currently I have Windows 7 and a Mint 17.2, someone has suggested changing the font size on Windows 10, but on my Mint box I installed Synergy from Synaptic, which is obviously an older version. In start up applications I run the following command.....synergyc ip address of synergy server...so it's setup as; Name: Synergy Command: Synergyc 192.168.1.XXX Start Up Delay: 5 So I don't actually run the synergy app as such on the Mint box as I do on the server side.

Share this post


Link to post
Share on other sites
This is what I am experiencing. Server Windows 10 Client windows 7 pro.When I move the mouse to the client I can't see the mouse but if I right click I get the alternate menu. I can do nothing with it. I can see the alternate menu but I can not select anything from it. No Mouse on the client and I have to use my touch screen to regain mouse control on the server. I am using the latest available build on both machines and the registered version. Has anyone found a fix yet?

Share this post


Link to post
Share on other sites
I seem to have found my problem at least, I bet others are having the same problem as well. Windows 10 reset my server display scaling level. Go to Control Panel>Hardware and Sound>Display I have an option for "set a custom scaling level" - Mine was set to 125% on my server. I changed it back to 100% and Wham, no more issues. It should be noted that my client is a laptop also running windows10 but for some reason that one was still set to 100%. (both server and client running new windows 10) Let me know if this helps anyone else out.

Share this post


Link to post
Share on other sites
This helped me find my issue thanks, but my config is slightly different. Windows 8.1 server, Windows 10 client. I changed the resolution scale as you suggested on the Windows 10 box but it did not help. On a hunch i checked the windows 8.1 resolution settings and it was set for 125 as well. Once I changed the windows 8 settings synergy is now working without issue. Check both Client and server resolution scaling if you are having issues to be safe.

Share this post


Link to post
Share on other sites
[quote="Andrew Anderson"]I seem to have found my problem at least, I bet others are having the same problem as well. Windows 10 reset my server display scaling level. Go to Control Panel>Hardware and Sound>Display I have an option for "set a custom scaling level" - Mine was set to 125% on my server. I changed it back to 100% and Wham, no more issues. It should be noted that my client is a laptop also running windows10 but for some reason that one was still set to 100%. (both server and client running new windows 10) Let me know if this helps anyone else out.[/quote] This did it for me. I set both the server , Windows 10, and the client win 7 pro to 100% and everything worked as it should . Now the issue is I have multiple large monitors and I really need the 125% to see everything clearly. Has anyone fixed this so we can go to the custom screen resolution/image scaling and have synergy still work?

Share this post


Link to post
Share on other sites
I am using Windows 10 as the server and Mac OS X (Yosemite) as the client. It all works quite well with two exceptions: 1. Still no shift or modifier keys in Microsoft Remote Desktop on the Mac (previous unresolved bug). 2. When I use VMware Workstation on my Windows machine the keyboard and mouse sometimes stop working in the Mac client, I have to restart Synergy service on the PC to get it working again.

Share this post


Link to post
Share on other sites
I'm having the Exact same issue as Andrew R. Issue 1: Modifier keys do not work with Microsoft Remote Desktop on the Mac. I am using Synergy 1.7.5 Pro. I have having to use two Mice and Keyboards. I keep finding my self having to use two Mice and Keyboards to get work done. :(

Share this post


Link to post
Share on other sites
The only Synergy compatibility problem I have had since upgrading to Windows 10 is that I can no longer use Alt + numeric keypad to enter special characters. I have Synergy as a server on the Windows 10 machine and as a client on an XP machine. It works fine whilst on the client but not on the server. I do not have any Hot Keys specified.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now