walter

[Fixed] Spacebar types the letter "s"

44 posts in this topic

Hello, I have a problem, with the OSX Server and OSX Client, on a client the space bar produce a "s", I can't use, Could you fix the problem? I read other post and there are other users with the same problem. [b]Update:[/b] This bug was fixed in Synergy 1.8.3 ([url=http://symless.com/download/]download[/url])

Share this post


Link to post
Share on other sites
I have the same problem. When typing in the server computer everything goes ok, but when I use the keyboard for writing in the client I get a "s" letter when pressing the spacing key. This is annoying and I do not know how to solve it. Any help? Thanks!! My server is Windows (64 bit) and client Mac OS 10 Edited by Guest

Share this post


Link to post
Share on other sites
In the new version 1.7.4 this problem continue. My problem is (synergy server on mac os 10.10 and synergy client on mac os 10.9) Please we need a fix. Please we need a fix. Please we need a fix. Please we need a fix. Please we need a fix. Please we need a fix.

Share this post


Link to post
Share on other sites
If we can make this the official "Why does spacebar type an s??" thread that would be really cool. I'm not 100% but after some googling the internal numbering system seems to vary from platform to platform. So something that would be really helpful from you guys is, what are the keyboards you are using? Both the server and client. If you can find a model/date for them that would be a bonus. Either there's some sort of internal translation error or something is happening with your keyboard layout. So post here what kind of keyboards you are using and if you have any special layouts in use.

Share this post


Link to post
Share on other sites
Hi, I´m using the keyboard of my Asus Laptop (F554L Series) that is the server computer. It works ok in this laptop but it produces and "s" when typing spacebar on the client screen (client is iMac). No special layout in use.

Share this post


Link to post
Share on other sites
Yes, the problem continue in 1.7.5 version. Please someone read this forum? developers? admins? this is the serious problem, we can work fine, I need to other keyboard to write in other mac

Share this post


Link to post
Share on other sites
Somebody have a solution for this problem? I have 1.7.5 version with mac server and clients running OSX 10.11.1

Share this post


Link to post
Share on other sites
Solve this problem by setting the mac and windows as server and client, once done I work without problem.

Share this post


Link to post
Share on other sites
This is a serious problem that needs a fix. Also using 1.7.5 here. A more detailed post is here: viewtopic.php?f=16&t=1042&p=3258&hilit=keyboard+mapping#p3258 Edit: The actual character produced on the client when I press the space bar is '§'. Pressing the '/' key also gives this character. Going through the entire keyboard also reveals a number of other mapping errors. The product is unusable for me in its present state. Server: Kubuntu 14.04 Client: Mac OS X 10.11.2 (El Capitan) I am using a brand new Logitech MK700/MK710 keyboard. Standard US keyboard layouts on both the server and the client. Trying different layout gives differing results, but always with some mapping errors. Btw, is there any documentation on how changing keyboard layouts is supposed to work? Some of us need to change layouts in order to write in different languages, of course.

Share this post


Link to post
Share on other sites
@the-wes Thanks. I actually posted there earlier today. I also sent in a customer support request via the web form and e-mailed a copy directly to Nick Bolton. Any idea when we can expect someone to take a serious look at this? This has been an issue for literally over a year. A number of folks mention in their comments that they've given up on the product and are thus lost customers to Synergy. This must count for something, no?

Share this post


Link to post
Share on other sites
It's been an issue for several years. The problem is that there are other issues which affect more users, so those have to come first. However this one is nearly the only major one with no workaround whatsoever. Losing customers certainly does count. But you have to compare it to other things that cause customers to be lost. Resources are devoted to whatever is losing the most customers at the moment, balanced with whatever will draw in the most new customers.

Share this post


Link to post
Share on other sites
[quote]It's been an issue for several years. The problem is that there are other issues which affect more users, so those have to come first. [/quote] You do realize that this issue is number one in the number of views on the General Discussion forum, don't you? Coming in at number 4 out of 520 topics is '[url=http://synergy-project.org/forum/viewtopic.php?f=16&t=1042]Keyboard mapping errors Mac OS X[/url]'. In the number three spot is [url=http://synergy-project.org/forum/viewtopic.php?f=16&t=1079]Keyboard not working[/url], which also seems to be Mac OS X related. Given this, it's hard to believe there are not a significant number of users affected by keyboard mapping bugs. [quote]However this one is nearly the only major one with no workaround whatsoever.[/quote] This makes it sound as if you're throwing up your hands in the face of this bug and basically just throwing Mac OS X users under the bus. If that's the case, maybe you should consider removing Mac OS X from the list of supported operating systems. As I mentioned on my GitHub comment (https://github.com/symless/synergy/issues/2765), keyboard mapping issues seemed to be much less prevalent in the pre-Synergy2 (Synergy 1.4.x?) versions that shipped with QuickSynergy. This observation is echoed elsewhere in the comments in this forum. Has any effort been given into looking at what changed in the way keyboard handling was done that would account for the massive increase in keyboard mapping bugs in later releases? User @atyoung also commented on the GitHub thread. His analysis seems to suggest major design flaws in the way input maps between the different system types are handled. Any chance you will ever get around to addressing this in a reasonable time frame or are drag and drop and synchronized screen savers (for a KVM switch application! :shock: ) simply that much more important?

Share this post


Link to post
Share on other sites
I realize how very frustrating it is to have a problem and not have a solution available. However please try to keep in mind that you are in the (less than) 1% of OSX users experiencing this. I'm not dismissing your evidence - it's quite compelling actually - but I happen to have access to contradictory evidence which I'm not really at liberty to share. Drag & drop absolutely is a higher priority, but not synchronized screen savers. The screen saver thing is a bigger problem because it causes monitors to be stuck "on" forever. It's happening to many times more people than the spacebar issue, and it does real damage. There is a workaround available for it, but it sucks and it needs to get fixed. No one has thrown up any hands. It's a simple matter of making a very difficult choice as to which thing to work on first.

Share this post


Link to post
Share on other sites
I wanted to try to resolve any issues with this that are still occurring, but none of these posts give enough information. * specific OS (including version) on each system? * which system is server/client, on which system do you have the issue? * language setting for OS on each system involved (important to give exact name)? * language setting in Synergy on each system? * if keyboard is not designed for US-English, then what language/country? * what is the keyboard brand/model, and is there any key between left Shift and Z keys? Often, users resolve this issue by setting compatible settings for OS/Synergy/physical keyboard. I look forward to seeing your responses! - Brian

Share this post


Link to post
Share on other sites
None of these posts give enough info. For anyone still having a problem with the space bar, please let us know all of these details? * make/model of keyboard (or if a laptop, the laptop's make/model) * language setting for OS on each system involved (give exact language name)? * language setting in each Synergy? * version of Synergy installed on each system * version of OS on each system (please tell us ''Windows 7 Pro 64-bit'' not just ''Windows'', ''Ubuntu 14.04 64-bit'' not just ''Linux'') * any non-default Synergy settings * the exact behavior (does this happen everywhere? in apps, at a command line...) * is issue intermittent? * please have your logging level set to "Debug1" and post a log of the time period where you've used space bar a few times on both client and server - Brian

Share this post


Link to post
Share on other sites
I just purchased Synergy and i'm facing the same spacebar-s bug. I'll try to give the info you are requesting: * Keyboard on server is a Rapoo E6100. On the keyboard preferences control pane the layout is set to "Spanish ISO". The keyboard has a spanish layout with middle-L-dot. The keyboard has the "< >" key between left shift and Z. * Keyboard on client is the macbook's keyboard. On the keyboard preferences control pane the layout is set to "Spanish ISO". The latptop keyboard has a spanish layout with middle-L-dot. The keyboard has the "< >" key between left shift and Z. * Language setting on both server and client is the default "English" * I don't see any synergy-specific setting on synergui GUI nor in the configuration file. What do you mean with "language setting in each synergy"? If you are referring the language choosen at setup, is English at both client and server. * 1.7.5 in both server and client * OSX 10.11.3 "El Capitan" in both server and client * Attached you can find the settings i'm using (i've extrated them running Synergy binary from the terminal and looking at the temp config file that it generates) * Behaviour: whenever i press the space bar key in the server , the client prints a 's'. It happens always, on any app i've tried (browsers, text editors, terminal) * Is intermitent: no * Attached you can find the logs for a session, with two space bar strokes, for both client and server. Hope it helps to resolve this issue. Thank you.

Share this post


Link to post
Share on other sites
I'ts been almos two weeks since I provided all the required information, any update on this?

Share this post


Link to post
Share on other sites
I have the same BUG long time ago. I purchased Synergy -- synergy server 1.7.6 - macmini - OSX yosemite version 10.10.5 - keyboard Español ISO - synergy language (español / english) -- synergy client 1.7.6 - macbook pro 13" - OSX El Capitan version 10.11.2 - keyboard Español ISO - synergy language (español / english)

Share this post


Link to post
Share on other sites
I have the same problem using macbook pro an imac. Server imac or server macbook, its the same. I have payed for nothing i cant use.

Share this post


Link to post
Share on other sites
Same problem Windows 10 is my server and my client is a MacBook Pro with the lastes OSX. I read over the internet that people are resolving this using another Synergy app for the client. Is I use the Mac for server I dont have any issue using it. The problem happen in the OSX Client mode

Share this post


Link to post
Share on other sites
Workaround On MAC removed spanish keyboard language and set it to English ABC. On Windows, switch keyboard language to English. Restarted both server and client and is working. Synergy should state that the software is not working with spanish language.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.