hiphopbros

Two icons

10 posts in this topic

Two icons are in deck. I can remove it, but it appears everytime I reboot. My OS is Mojave. How do I make only one icon available? Is this possible hacking situation?

Share this post


Link to post
Share on other sites

Hi,

Looks like this is known issue with Mojave. Can you please try following?

1. Reinstall from fresh

2. Remove the app from System Preferences' "Security & Privacy > Accessibility" list

3. Open the app

4. From System Preferences, enable Accessibility access, as requested

5. Back in Synergy, enable Auto Config (in Preferences)

6. Allow the client to connect (accept fingerprint on the client machine)

7. Configure server in client machine name.

Share this post


Link to post
Share on other sites
15 hours ago, Alexey Pilyaev said:

I don't understand your instructions.

1. I have already tried many reinstallation.

2. There is not the app in the "Accessibility" list in "System Preferences" on Mac.

3. It automatically opens at system startup as I configured in Mac.

4. I enabled the "enable Accessiblity access" button. I think this doesn't affect anything to synergy program.

5. I enabled the autoconfig feature in synergy program, but I think this also doesn't quite related to my issue.

6. My synergy is working fine except the duplicated icons.

7. My synergy is working fine except the duplicated icons.

None of your procedure makes sense to me regarding the duplicated icon issue.

Share this post


Link to post
Share on other sites

Almost same here. Have 3(!) icons though.

Share this post


Link to post
Share on other sites

OMG, 3 icons? synergy everywhere. Good for you.I wish I had more icons like being hacked.

Share this post


Link to post
Share on other sites

@Henke

Lunch System Preferences (the gray gear icon in your Dock) and select Dock. Alternatively, right-click (or Control-click) on one of the dividing lines in the Dock and select Dock Preferences. From the window that appears, uncheck the option labeled Show recent applications in Dock.

The change will take effect immediately. The extra icons in your Dock are now gone, at least if their corresponding application was not running. If the app was still running, the icon will be merged to the right side of your Dock. This replicates the same behavior as pre-Mojave versions of macOS.

Share this post


Link to post
Share on other sites

Yea this is working, but why is Synergy launching three times when first starting up?

Edited by Henke

Share this post


Link to post
Share on other sites

Changing dock preference is working, but it is not the solution.

Share this post


Link to post
Share on other sites

This is actually not Synergy but Mojave known issue with many third-party applications.

Apple still did not have any ETA for this.

Share this post


Link to post
Share on other sites
On 11/20/2018 at 11:50 AM, Henke said:

Yea this is working, but why is Synergy launching three times when first starting up?

 

On 11/21/2018 at 6:09 AM, Alexey Pilyaev said:

This is actually not Synergy but Mojave known issue with many third-party applications.

Apple still did not have any ETA for this.

@Henke - The reason that the fix that Alexey provided works is that the Synergy starts a bunch of processes and programs before the actual client starts. The synergy-service process is an example of this.

When it does this, Mojave recognizes this as a separate application and as such, when the process instructs the OS that it is going to become "invisible", Mojave doesn't pick up that cue and doesn't remove it from the recently opened applications because the OS will think that it has been closed.

It shouldn't be an issue anymore with that turned off.

I hope you understand why the issue exists.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now