hiuwo

Executable could not be started error appears only when server side disconnect

4 posts in this topic

Hi all,

I have had this problem since half a year ago, my Client is Mac OS 10.12 Sierra, and my server is Win10 newest. Both running synergy 1.10.0

I normally do not turn off my Mac but I do turn of my PC.

At night when I do turn off my PC in this case at about half past 2, my mac client goes crazy, and in the morning I check the computer, this repeating log will come up (https://pastebin.com/T5gp7eYi) saying: 

Quote
  1. [2018-11-11T04:19:11] INFO: drag and drop enabled
  2. [2018-11-11T04:19:11] FATAL: A display invalid exception error occurred: failed to initialize screen shape
  3. [2018-11-11T04:19:21] ERROR: process exited with error code: 1
  4. [2018-11-11T04:19:21] INFO: detected process not running, auto restarting
  5. [2018-11-11T04:19:22] INFO: starting client
  6. [2018-11-11T04:19:22] INFO: config file: /var/folders/2z/5m02m7dx38b9cp74ry0fd0g40000gn/T/Synergy.wS9340
  7. [2018-11-11T04:19:22] INFO: log level: INFO
  8. [2018-11-11T04:19:22] INFO: drag and drop enabled
  9. [2018-11-11T04:19:22] FATAL: A display invalid exception error occurred: failed to initialize screen shape
  10. [2018-11-11T04:19:32] ERROR: process exited with error code: 1
  11. [2018-11-11T04:19:32] INFO: detected process not running, auto restarting
  12. [2018-11-11T04:19:33] INFO: starting client
  13. [2018-11-11T04:19:33] INFO: config file: /var/folders/2z/5m02m7dx38b9cp74ry0fd0g40000gn/T/Synergy.yY9340
  14. [2018-11-11T04:19:33] INFO: log level: INFO
  15. [2018-11-11T04:19:33] INFO: drag and drop enabled
  16. [2018-11-11T04:19:34] FATAL: A display invalid exception error occurred: failed to initialize screen shape
  17. [2018-11-11T04:19:44] ERROR: process exited with error code: 1
  18. [2018-11-11T04:19:44] INFO: detected process not running, auto restarting
  19. [2018-11-11T04:19:45] INFO: starting client
  20. [2018-11-11T04:19:45] INFO: config file: /var/folders/2z/5m02m7dx38b9cp74ry0fd0g40000gn/T/Synergy.tH9340
  21. [2018-11-11T04:19:45] INFO: log level: INFO
.............

and this prompt will come up and say (The executable ... could not be started, although it does exist) (same as this ref image: https://symless.com/forums/topic/3064-the-executable-could-not-be-started-although-it-does-exist/)

 

P.S. I have read a few other posts and I only could find remedies such as this

Quote

For anyone out there who might stumble across this thread, here's the solution:

  • Exit Synergy
  • Open Terminal
  • "rm ~/Library/Preferences/com.http-symless-com.Synergy.plist" then hit Enter
  • "rm -rf ~/Library/Synergy/" Enter
  • "killall -u $USER cfprefsd" and again Enter
  • Restart Synergy

apple script

Quote

set appName to "Synergy"

tell application appName to quit

repeat

tell application "System Events"

if appName is not in (name of application processes) then exit repeat

end tell

do shell script "sleep 0.5"

end repeat

tell application appName to launch

The deleting plist thing doesn't help and while the apple script does help me relaunch the service easier, this happens every single day.

I am also not sure if I could ask about errors on this forum board, but please help ><

thanks in advance for the time

H

Edited by hiuwo

Share this post


Link to post
Share on other sites

Problem still persists, I really hope someone can pick this up :(

Share this post


Link to post
Share on other sites

Hi,

Can you please send us an email here and someone from our team will work with you. Looks like you have something new for us.

Share this post


Link to post
Share on other sites

sent, thanks!! my support ticket number is: 82773

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now