GSH

Synergy did not show the correct IP to input into client. Had to use the one in Preferences>Network.

10 posts in this topic

I wanted to use my MacBook Air as a server and a Mac Desktop in my office as a client. Both are connected to the university network. My server IP on my laptop was 192.168.x.x and I could not get the client to connect to it when I entered that info on the desktop (client). I looked in the network pane in preferences on my laptop and saw that it listed my IP as 10.11.x.x which I entered into the client instead of the synergy suggested one and it worked immediately.

I'm sure this is because I'm on the university network as this has never happened at my house or any other place I've used Synergy but I thought I'd point it out.

Synergy Version: 1.10.1-stable-8941241e

Share this post


Link to post
Share on other sites

Can you please provide me with the screenshot of your Synergy Server settings and screenshot where I can see IP addresses?

Share this post


Link to post
Share on other sites

This is what Synergy showed:

5be1ab489c16a_ScreenShot2018-11-06at9_47_14AM.png.6dad0d40b4434616e40402879f2f6c3b.png

This is what Preferences > Networks showed

5be1ab7eec50f_ScreenShot2018-11-06at9_47_31AM.png.35cc08b351ee5dc463d0603d247e31c9.png

I believe the problem was that synergy did not refresh on my mac (server). Even when I selected client and then selected server again, it still showed the incorrect IP address which is the IP address from my residence and not at the university.

If I quit synergy and then start it up again, it displays the correct IP (seen below)5be1abe200ea4_ScreenShot2018-11-06at9_48_35AM.png.bd680fab609f1c4753c610ec18030775.png

Share this post


Link to post
Share on other sites

Can you check under settings if Auto Config is enabled? 

Share this post


Link to post
Share on other sites

Auto Config is not enabled. It is also visible in the screenshots as it asks me to enable it but I wasn't able to figure out from the documentation what exactly it did.

When I enabled it in the past, I had to disable it in order to change the server from a windows computer at the university to the windows computer at my residence. I tend to use my MacBook as a server in my office and as a client in my lab and at my residence.

Share this post


Link to post
Share on other sites

Can you try to enable it now?

Share this post


Link to post
Share on other sites

what do you want me to do after enabling it??

I enabled it and the IP is still the same. It should be different now since I'm in another building and Preferences shows my IP to be something other than what Synergy suggests it is.

Share this post


Link to post
Share on other sites

Could you send me your log links for both computers?

Please respond to this ticket with the links/URLs (do not paste logs contents directly in your reply).

Here's how to send me your log links:
https://symless.com/help/s1-troubleshooting/s1-sending-logs

Screenshots of the config screen on both computers would also be very useful.

 

Share this post


Link to post
Share on other sites

do you want me to do something specific when collecting logs? right now they don't show anything I'm not using synergy right now it just shows the server starting. 

Share this post


Link to post
Share on other sites

Can you check if auto config is enabled under your Settings?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now