Jayson Garrett

macOS Mojave releases a week

39 posts in this topic

This isn't going to be good. There are going to be people who are unaware of the incompatibility and upgrade to Mojave, and then be left with Synergy nonfunctional.

It would be nice to get a comment from Symless as to whether a fix is even being worked on.

Share this post


Link to post
Share on other sites

We are running macOS Mojave and so far we haven't encountered any problems with Synergy. That's not to say there aren't any, but we need to reproduce the issue before we can start solving it. We're still trying to reproduce the issues that some users appear to be experiencing and will continue to do so. Any more information and logs would be greatly appreciated.

Share this post


Link to post
Share on other sites

Gladly.

I'm using Synergy 1.10.1 on macOS Mojave Developer Beta 11. The behavior has been the same throughout the beta process.

I've attached a Debug2 level log.

 

 

Synergy Debug2 Error Log.log

Share this post


Link to post
Share on other sites

Also, if there's any other information I can give you that might help, please let me know. I'm very willing to help in any way I can.

Share this post


Link to post
Share on other sites

Also, see this in the /var/log/system.log 

Sep 26 11:48:47 Rennsport synergy[7055]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug

Share this post


Link to post
Share on other sites

What do you need in the realm of information?

Share this post


Link to post
Share on other sites

I am also seeing the same error that @William Brinkmann is seeing:

Sep 27 08:02:28 2445-MBP15 synergy[41260]: DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug
Sep 27 08:02:28 2445-MBP15 com.apple.xpc.launchd[1] (synergy.1772[41260]): Service exited with abnormal code: 1

I believe this occurs whenever I try an add Synergy to the Privacy->Accessibility settings so that Synergy can control the computer.

Another note is that this appeared to work immediately after upgrading, but did not after a reboot of my MBP

Share this post


Link to post
Share on other sites

I GOT IT WORKING!!

There appears to be an issue when "Enable Auto Config" is disabled. 

Here's what I did (macOS Mojave is Server):

  1. I followed the steps to reinstall from fresh
  2. Removed the app from System Preferences' "Security & Privacy > Accessibility" list
  3. Opened the app
  4. From System Preferences, I enabled Accessibility access, as requested
  5. Back in Synergy, enabled Auto Config (in Preferences, picture below)
  6. Allowed my client (Windows 10) to connect (had to accept fingerprint on Windows machine)
  7. Configured server with my Windows machine name

Hope this helps!

Screen Shot 2018-09-27 at 3.19.57 PM.png

Edited by Valor Poland
  • Like 1

Share this post


Link to post
Share on other sites

Unfortunately, following Valor's procedure, for me Synergy 1 still fails in the same manner as before - the error with the quartz event tap.

 

Share this post


Link to post
Share on other sites

Same here.  And if it makes a difference my MBP is running as a client not a server.

Share this post


Link to post
Share on other sites

I also followed Valor's procedure and still can't get it to work.

Windows 10 used to be server and Mac was client. After Mojave install on Mac I could not get it to work. Tried server, client switch. Tried fresh install of Synergy 1 and 2. Both no longer will work either way.

Share this post


Link to post
Share on other sites

My Mojave laptop is a client to High Sierra mini which is the one running as a server.

I see these messages on the server

[2018-09-27T15:21:35] INFO: accepted secure socket

[2018-09-27T15:21:35] INFO: network encryption protocol: TLSv1.2

[2018-09-27T15:21:35] NOTE: accepted client connection

[2018-09-27T15:21:35] WARNING: unrecognised client name "Virgo.hitronhub.home", check server config

[2018-09-27T15:21:35] NOTE: disconnecting client "Virgo.hitronhub.home"

[2018-09-27T15:21:35] NOTE: client "Virgo.hitronhub.home" has disconnected

 

Client is indicating that the server refused the client. And the server is showing that the client is unrecognized.

 

OH and just changed the autoconfig and it made no difference.

Edited by Brad Smith
Additional information.

Share this post


Link to post
Share on other sites

Once I enabled the autoconfig on the client the server popped up and said it saw a new client and please drag the new client to where it's located on the server config. Once I did that and saw that the two sides started talking I could see that it works!

 

So I ran a fresh install  from scratch on the Mojave laptop client. Once I did that, I clicked the link to enable the autoconfig on the client which prompted some authorization to happen on the server side. Once that is done I'm able to go back and forth again between the mac's. I have to work tomorrow but I'm thinking I'm going to update the server to mojave and update the client on Windows. I might also follow the instructions to reinstall on windows if need me. I'll respond back once those two tasks are done.

 

Just to be clear, Mojave as a client is working but I had to completely clean and reinstall from scratch. Something didn't work right after the update to Mojave.

Share this post


Link to post
Share on other sites

Tried the same approach as Valor proposed but still getting the same error - ERROR: failed to create quartz event tap

Share this post


Link to post
Share on other sites
20 minutes ago, kojoro said:

Just got this working on my end. It looks like the key is removing Synergy from "Security & Privacy > Privacy > Accessibility" before reinstalling.

Kojoro, are you using your Mac as the client or server?

Share this post


Link to post
Share on other sites
1 minute ago, Joel Gray said:

Kojoro, are you using your Mac as the client or server?

I'm using Mac (Mojave 10.14) as the server.

  • Thanks 1

Share this post


Link to post
Share on other sites

Kojoro,

That seems to have done the trick for me as well! THANK YOU!

What I just did:

  1. Ran the steps to reinstall from fresh.
  2. Removed the Synergy entry from the "Security & Privacy > Privacy > Accessibility" pane in System Preferences.
  3. For safety's sake, deleted the Synergy app from the Applications folder.
  4. Rebooted.
  5. Mounted the Synergy 1.10.1 DMG and dragged the Synergy app to the Applications folder.
  6. Started Synergy. The system asked me to verify that I wanted to run it, and asked if I wanted to allow Synergy to control my system. I went to the "Security & Privacy > Privacy > Accessibility" pane again, unlocked it, and checked the Synergy item in the iist.
  7. Restarted Synergy.
  8. I use a configuration file, so I selected that option and pressed Start. It started listening successfully. I started Synergy 1.10.1 on my Windows 10 client, and they exchanged key information and connected successfully.
  9. Yay!

Once again, thanks to Kojoro, and the others that have contributed help with this issue!

  • Like 1

Share this post


Link to post
Share on other sites

And if Synergy isn't in the Accessibility pane to begin with???

Share this post


Link to post
Share on other sites

Thank you, Valor Poland.  I followed your instructions on my Mojave box which (should) act as the Synergy server and Synergy now runs and my Windows 10 client can connect.  I still have 3 Synergy icons in my Dock, but as long as it's working, I won't complain about cosmetic problems for now.

Share this post


Link to post
Share on other sites

Korojo! 

You da man!

I followed the instructions Jayson Garrett outlined and got Synergy to run.

Thanks all!!!

 

Share this post


Link to post
Share on other sites

Thanks so much, it also worked for me :)

 

Share this post


Link to post
Share on other sites

Are any of you that got this to work using the Mac as the client rather than the server?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now