Dojii

UAC kicking Synergy 1 off momentarily

3 posts in this topic

So I joined the Synergy scene when Synergy 2 was out.  So I've only used Synergy 2 till today.  On a fresh install of Windows 10 pro, and a fresh install of Synergy 1 on both PC's I am running into a problem I didn't have with Synergy 2.  

Whenever I try to run a program as administrator on the Client PC I lose control of the Client PC.  This never happened with Synergy 2.  Should I just go back to Synergy 2?  

Synergy 1 seems more responsive... but I use the client PC for my broadcast so I will be activating programs as administrator a lot... is there any work around for this in Synergy 1?  thanks.

Share this post


Link to post
Share on other sites

Synergy 1 has had this behavior for a long time. This is one of the advantages of Synergy 2. I chose to put up with this behavior rather than deal with the bugs in Synergy 2.

Share this post


Link to post
Share on other sites

There are advanced options you can configure on the server and clients to elevate Synergy "always". These are still a little hit and miss, but they're far more reliable than the default 'kick when prompted' behavior.

You can fix this on the client by opening the Synergy GUI then going to Edit, Settings, change Elevate to "Always". Click OK, then Apply. It'll restart Synergy. When finished it *shouldn't* kick you when prompted for elevation in the future.

You can also accomplish this with a batch file, too:

:: force elevation "Always" on Synergy v1 (*usually* eliminates the UAC kick)
reg add "HKLM\SOFTWARE\Synergy" /v Elevate /d 1 /t REG_SZ /f
FOR /F "tokens=1,2*" %%a IN ('reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Synergy" /v Command') DO SET syncmd1=%%c
SET syncmd2=%syncmd1:--stop-on-desk-switch=%
reg add "HKLM\SOFTWARE\Synergy" /t REG_SZ /f /v Command /d "%syncmd2:"=\"%"
net stop synergy
net start synergy

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now