Maxim

Mouse and keyboard extremely laggy on client device

5 posts in this topic

Just bought,installed and set up synergy on my PC and laptop.I have my PC set up as the server and my laptop set up as the client. It works, but is almost unusable due to the amount of lag and random jumping my cursor is doing on my client laptop.
My keyboard is lagging as well, for example when i type the letters come onto the screen all at once a few seconds after i typed them.

Specs:

On my  PC, connected via CAT-6 ethernet cable:
OS:  Windows 10 Home, version 1803.
Processor: AMD FX-8320
Ram: 16 GB ddr3
GPU: nvidia geforce gtx 760
Resolution: 1920x1080

 

On my laptop, connected via very stable wifi:
OS:  Windows 10 Home, version 1803.
Processor: Intel i7-6700HQ
Ram: 8gb ddr4
GPU: nvidia geforce gtx 965m
Resolution: 1920x1080

The mouse settings are exactly the same on both devices.
I am running version 1.10.1-stable-8941241e on both devices.
In the log it only says "switch from " x " to " x " and leaving / entering screen on both devices.

In the advanced server settings i only have enable drag and drop file transfer and enable clipboard sharing checked, the latter is set on 3 mb.

I have no hotkeys set up.

I have synergy opened on both devices.

 

I hope this problem can be solved, or i'd like to get a refund on the $29 i just spent if i cannot make the program work properly.

 


 

 

 

Share this post


Link to post
Share on other sites

I had the same problem (except it was working fine then it changed). Turned out my wifi has both slower 2.4Ghz and faster 5Ghz and for some reason my laptop started connecting to the 2.4Ghz side. As soon as I forced it onto the 5Ghz it started working normally again. So from my experience it's a wifi network speed issue.

  • Like 1

Share this post


Link to post
Share on other sites

Can you temporarily try connecting the laptop by ethernet to see if the problem goes away? That would narrow down WiFi speed vs other issues.

  • Like 1

Share this post


Link to post
Share on other sites

@CurtisB @Davewill  Thanks for your input, i have tried connecting my laptop via an ethernet cable and it solves the problem completely! So now i know that it is a wifi issue, and i will look into the different ghz thing. When playing games via wifi on my laptop ( wich i do rarely ) i have no problem with ping or responsiveness, but since synergy works perfectly fine with an ethernet cable and is laggy on wifi it does narrow it down.

Again, thanks for you intput! 

 

Share this post


Link to post
Share on other sites

There is a common problem with some older Intel wireless cards that support 802.11ac (aka "VHT Mode"). You can disable VHT Mode to vastly improve stability if your laptop will be okay at only 802.11n speeds (ac is theoretically about 3x faster than n) or if you're using a 2.4GHz band (802.11ac is a 5GHz-only protocol).

The thing is it's a simple fix, and if it doesn't work, it's just as easy to revert, so no harm, no foul.

Open regedit, browse to "HKLM\SYSTEM\CurrentControlSet\Control\Class" and search for "IEEE11nMode". If found, and the Value is 2, change it to 1 then restart the computer. Unfortunately, the location is dependent on the specific build of hardware and it affects several models, so it requires a search.

You can also (sometimes) manage this option under Device Manager, Network adapters, select your wireless adapter, properties, Advanced, and the value name is something like "802.11n/ac mode" (sometimes). Values under here vary by version/build, but you're looking for disabling ac and using n only. 

The usual caveats apply: If you aren't comfortable using regedit, don't. If you aren't comfortable fiddling with advanced device properties, don't.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now