JShumaker

Settings (disable changing of app focus)

6 posts in this topic

Synergy 2 badly needs a settings option.  Synergy 1 has some behavioral settings that are key to toggle. One of the "Features" is to drop focus from current application on the server when mouse goes to a client. In numerous cases this causes problems or undesirable behavior, so in Synergy 1 I always turned it off.

I recently started using Synergy between Windows and Kubuntu 18.04, I found Synergy 1 has a bug where it breaks the thumb buttons.  While Synergy 1 client was installed, I could not use them. Uninstalled, and I could. Decided to try Synergy 2 and was pleasantly surprised the thumb buttons work. Thus I'm happier to use Synergy 2, but frustrated that there appears to be no way to disable features I don't want.  All for automating the connection between server/client, but there's several other options beyond that we still need to adjust.

Share this post


Link to post
Share on other sites

Hey,

i posted about the "Alt Gr" shortcut issue in may this year as it makes it a nightmare to code on a secondary computer switching to the main monitor every time you hit that key.
It is a mystery to me how the devs  did not fall over the same issue.

The tool over all is really great but this "feature" got me to the point that i stopped promoting this product to my colleagues because you can not really use it for coding purposes at the moment without getting a big headache, such a bummer. 

Also the the progress on the "beta" looks pretty stalled at the moment?

Share this post


Link to post
Share on other sites

Especially as this isn't so much adding functionality, but instead giving us the option to shut it off. I guess they have to re-implement the UI etc., but if they could just give us a config file or something we could manually edit for the time being... 

Share this post


Link to post
Share on other sites

There is a config file at the following location (on Windows).

%localappdata%\Symless\Synergy\synergy.conf

This file does contain a setting called "win32KeepForeground" that is set to "false" by default.  You can change it to "true", but after making the change and saving the file you need to set the read-only flag on it, otherwise the service will overwrite it with the defaults.  You also need to restart the Synergy service after setting the file to read-only so that it will pick up the change.

Share this post


Link to post
Share on other sites

Thank you so much, I feel a bit blind now as i looked in local app data, but got too focused on old synergy folder in there and didn't notice symless one next to it. I was also able to disable screenSaverSync which never seems to work well and tends to stop clients screensaver from ever kicking on.

Share this post


Link to post
Share on other sites

I found the same file in linux, but since the service starts as root, was a bit tricker to make it read only.

sudo chattr +i /var/lib/synergy/synergy.conf

However, doesn't quite seem to take effect. More of still seems to interfere with screensaver, and win32KeepForeground doesn't help with it changing focus in Linux. Still though the vast majority of my issues are solved on the windows side by being able to enable win32KeepForeground there so again, thanks.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now