Gareth

Teach me / learn with me

8 posts in this topic

Hi,


As someone with more complex requirements than a single-set-up use case, I've concluded I need to learn to understand and use Synergy (1 and / or 2) better than a normal end-user. I'm sharing here (and signed up to the Slack) with the intention that this discussion may help others too now or in future with similar challenges.

Currently there's nothing working for me but rather than finding a quick fix, I'll take my time and I'm starting anew.

First question: 

>Is there a link to instruction on how to uninstall and log out of everything (locally and in the cloud, S1 & S2) and be rid of old configurations so I can start anew?

I've had both S1 and S2 running on a 3-pc network, one of the 'clients' (S1) in this scenario (is the laptop that I move about to other networks).

I received the tip from @GranPaSmurf on Slack of using Revo Uninstaller to clean up the PCs before trying again which I've done. This worked in terms of enabling me to use new license keys for my two test PCs. If I'm going back to S2 at one point I'll need to test whether Revo Uninstaller worked from that perspective. In the meantime. Let's move on to what I'm installing on what OSs.

Gareth

Share this post


Link to post
Share on other sites

First, what OSs are you using?

Next, which version of Synergy are you working with?

Share this post


Link to post
Share on other sites

I'm using three 64 bit Win10 machines and have installed on both: synergy_1.10.0-stable_b39-275cdc1c_windows-x64

I got S1 working in the end the other day with clean installs on all three after using Revo Uninstaller, which enabled me to activate them with the same (my personal) P1 Pro activation key - and after figuring out that I'd forgotten I needed both to tell the Clients what the IP address of the Server was and to manually add and name the Clients in the Server Configuration.

Happy days; up and running again!

 

Share this post


Link to post
Share on other sites

The good news is that SSL and copy & paste between machines also appear to be working though not drag 'n drop folders from desktop to desktop but that's fine, given almost everything lives in dropboxes anyway!

One of the reasons I welcomed S2 when it first came out is, contrary to what I'm gathering is common experience, I found it more reliable and it allowed me to use copy & paste for the first time which, until now, I've never had working on S1.

Share this post


Link to post
Share on other sites

The key thing for me is that I use my own Win10 laptop (dropped into monitor-connected docking stations) in two of my clients' offices and in my own. My laptop is set up as one of the Clients.

So the next test has been to remove my laptop and have it all continue to work between the Server and the remaining Client. It works which is great!

Share this post


Link to post
Share on other sites

I guess the next thing I need to figure out is how the licensing and keys work.

I've bought a heap of licenses in a combination of Basic and Pro for myself and for my clients without really understanding what the difference between them is!

Ah, now I've gone to look again and apparently neither license is suitable for professional use i.e. either for me as a business serving my clients nor for my clients which are businesses! If the licensing enforcers would bear with me for the duration of this learning process and allow me to 'abuse' my (and my clients') current licenses, can we postpone the purchase of business license/s until I've got it all working as I'd like? 

Share this post


Link to post
Share on other sites

In the meantime, I seem to recollect one of the differences between basic and pro was the number of user licenses though that doesn't show on the comparison chart any more.
 

If the number of users still counts, does a 'user' equate to a setup. i.e. can I (in practical terms, if we put aside the 'no business users' clause) with one 3-user S1 Pro license use the same activation key in three setups?

The main reason I ask is because I use the same laptop (as a Client) in the three setups and ideally, I don't want to be needing to re-set and re-activate S1 on my laptop with the relevant activation key for my clients' licenses every time I change offices!

I'm hoping my talking through this makes sense and is useful to someone other than me!

Share this post


Link to post
Share on other sites

Good work with your installations. 

In my systems, I end up having to use the manual setting without SSL. Since, for the most part, I'm using 3 desktop machines that don't go anywhere, this seems to be OK.

BTW, I appreciate your thorough explanations. You've just helped the next guy.

As to the license discussion, I'd suggest you return to Slack and send Nick a direct message explaining your need and future plans. See what you can work out.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now