kamkie

alt gr is moving focus to "main computer"

11 posts in this topic

left alt is ok, but when i try to enter some national characters using right alt (alt gr) focus and mouse cursor are moved to main pc

Share this post


Link to post
Share on other sites

Having the same problem. This issue needs to be looked at as soon as possible as it is really annoying, and can lead to information loss as explained in the second paragraph! I'm in Quebec, Canada, and use a French Canadian keyboard configuration on all my computers. As soon as I type the "@" character using the combination of the "Alt GR" and the top row "2" keys, the focus is switched to the display on the Synergy server computer. As you know, the "@" character is used quite often as it is part of all email addresses, and email addresses are used quite extensively as login user IDs throughout the Web as well as, obviously, sending emails. Computers configured for use with standard US English keyboards won't have this issue since the "@" character is obtained using the combination of the "Shift" and top row "2" keys.

This is a big issue because of the implications of the Synergy focus being switched back to the Server computer without knowing it did. For example, this is what happened to me: Not knowing that the focus had switched when I typed the "@" character, I continued typing the email address I needed to enter on the client computer, looked up at the screen, noticed then that the email address was not entered completely, noticed that the focus had been switched to my Thunderbird email application on the Server computer. I didn't realized it immediately, but two email messages were erased from my Inbox! As it turns out, the letter "a" can be used to erase email messages in any active Thunderbird screen. There were two "a" letters in the email address after the "@" character.

Note 1: the "Alt GR" key is labeled as "Alt Car" on some keyboards. On a standard US English "QWERTY" keyboard, it is the "Alt" key located immediately at the right of the space bar.

Tested:

Standard US English "QWERTY" keyboard configuration: no issue since the right "Alt" key acts as a regular "Alt" key, and since the "@" character is obtained using the combination of the "Shift" and top row "2" keys.

US English International keyboard configuration: no issue with the "@" character since it is still obtained with the combination of the "Shift" and top row "2" keys, BUT focus will be switched to the Synergy Server computer as soon as the "Alt" key located immediately at the right of the space bar is pressed and released, be it labeled "Alt GR", "Alt Car" or just plain "Alt".

Synergy 2.0.12 Beta on Windows 10 Home version 1809 (both Synergy Server and Client)

Note 2: Absolutely no such issues with Synergy 1.10.0-stable-275cdc1c or Synergy 1.10.1-stable-8941241e on Windows 10 Pro version 1809 (Synergy Server) and Windows 10 Home version 1803 (Synergy Client).

Share this post


Link to post
Share on other sites

Hi Alexey,

Ticket opened with requested information from my computers right after I recreated the problem.

Have a great day!

Paul

Share this post


Link to post
Share on other sites

Any news on this... or workarounds? For me its not just moving focus to main computer, it is also dropping the connection, so I have to wait for the machines to reconnect before I can continue working on the 2nd machine.

Edited by Nick Brandwood

Share this post


Link to post
Share on other sites

Hi Nick,

I'm also waiting for news on this. In the meanwhile, I went back to Synergy version 1 which seems to be the only workaround for the time being.

Share this post


Link to post
Share on other sites

Looking at another post in the forum on the same topic, using Ctrl + Alt does the same thing, just not always. It works in notepad and chrome but not in word (only place I've tested).

(I'm using an Italian keyboard where the @ symbol is right of the L)

Interestingly, the character is displayed on the client so it is sent before the disconnect.

Share this post


Link to post
Share on other sites

Nick,

If you haven't done so already, you should open a support ticket using the link supplied in a previous post by Alexey Pilyaev. I did so shortly after his request. Doing so should speed up the resolution process.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now