zachn

Workaround: macOS WiFi ping spikes

8 posts in this topic

I've accidentally noticed that while pinging somewhere the lag was reduced but my knowledge on network stuff is just enough to get by so I dropped that workaround.

Awesome and neat solution.

I'm using a macbook air as server and an imac as client (all conected to an airport router). It's not lagging at all now.

Thank you very much, @zachn!!

  • Like 1

Share this post


Link to post
Share on other sites

Why the hell does this work so well?

Regardless, neat little solution. Fixed my issues right up. I'll put this into a script so I can easily toggle it.

Thanks so much!

  • Like 1

Share this post


Link to post
Share on other sites

@RWAnderson my working theory is that we're preventing the wireless card from going to sleep. I'm glad it has helped you!

Share this post


Link to post
Share on other sites

You know, I was just going to post a new issue as it seemed that with TLS on, that my Mac had experienced a lot of new latency and jitter after updating to Mojave 10.14.1 ... but your solution makes Synergy run like butter, so no matter.

Apple must have tweaked the power management stuff a bit more in the latest release. (Writing these details here for future seekers)

 

Followup thought: I changed my -i interval to 1s instead of .1 to reduce the overhead. Seems to work every bit as good.

Another thought: This would be trivial to include as an option in Synergy, would it not? I'm thinking like a checkbox that reads "Continually poll the server (reduces mouse latency as a result of certain power-saving features)".  Since the client knows the IP/Hostname of the host, just throw a packet at the host every N ms.

Edited by Chekhov's Chainsaw
  • Like 1

Share this post


Link to post
Share on other sites

Had the same issue and this does indeed work. I noticed that it was also in my case on a 2018 macbook pro, tied in someway to the battery %, so that must be some sort of condition in their setup for the wifi on/off.

  • Like 1

Share this post


Link to post
Share on other sites

Setup between Win10 (server) and OSX (client). Didn't get Synergy 1 to work properly, same network, allowed in firewall on both OSes and also in the router. Pings went trough without problems.

Really needed this to work to actually utilize the 49" monitor I just got.

Took a gamble with Synergy 2, experienced lot of lag and DC from the client. Installed Share-Mouse. Proved itself being 200 times worse.

Was just about to give up, at least for now but then i tried this. Decreases lag and keeps the connection alive (still have some DC issues) however seems to work pretty well when using the Mac for longer periods.

Basically, I just wanted to say thank you @zachn

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now