Stefano Petracca

ERROR: invalid message from client

4 posts in this topic

Hi All, I am using Synergy on Ubuntu 14.04 and share mouse + keyboard with another ubuntu 14.04 and a Windows machine (win 7). Since I have updated to the latest version of Synergy I had a lot of problems (starting from the SSL issue which kind of created some problem in my case). The latest problem is this: connection drops randomly during the day (today it happened already 3 times in less than 4 hrs). On synergy terminal I see: INFO: screen "stpt-tomtom" grabbed clipboard 0 from "xxxxxxxxxxx" INFO: switch from "xxxxxxxxxxxx" to "xxxxxxxxxx" at 3563,480 INFO: entering screen [b]ERROR: invalid message from client "xxxxxxxxx": DCLP[/b] NOTE: accepted client connection NOTE: client "xxxxxxxxxx" has connected INFO: switch from "xxxxxxxxxx" to "xxxxxxxxxxxx" at 0,227 INFO: leaving screen INFO: screen "xxxxxxxxx" grabbed clipboard 1 from "xxxxxxxxxx" INFO: switch from "xxxxxxxx" to "xxxxxxxxxxx" at 3561,653 INFO: entering screen help?

Share this post


Link to post
Share on other sites
I am having the same problem. This is probably connected to the clipboard issue; I am now unable to copy text from one computer to another, both directions (Win7 server, Ubuntu 14 client) and the message appears when I try to do that. Edited to add that I have SSL disabled.

Share this post


Link to post
Share on other sites

greetings, just purchased license key for synergy, and experiencing the exact same issue

i presume it's because ERROR: invalid message from client "CLIENT-XUbuntu16.04": DCLP

 

[2017-09-22T21:06:27] DEBUG: close clipboard
[2017-09-22T21:06:27] INFO: screen "SERVER-win7" updated clipboard 0
[2017-09-22T21:06:27] DEBUG: open clipboard
[2017-09-22T21:06:27] DEBUG: close clipboard
[2017-09-22T21:06:27] INFO: screen "SERVER-win7" updated clipboard 1
[2017-09-22T21:06:30] INFO: switch from "CLIENT-XUbuntu16.04" to "SERVER-win7" at 6,173
[2017-09-22T21:06:30] INFO: entering screen
[2017-09-22T21:06:32] INFO: switch from "SERVER-win7" to "CLIENT-XUbuntu16.04" at 1365,272
[2017-09-22T21:06:32] INFO: leaving screen
[2017-09-22T21:06:32] DEBUG: open clipboard
[2017-09-22T21:06:32] DEBUG: close clipboard
[2017-09-22T21:06:32] DEBUG: ignored screen "SERVER-win7" update of clipboard 0 (unchanged)
[2017-09-22T21:06:32] DEBUG: open clipboard
[2017-09-22T21:06:32] DEBUG: close clipboard
[2017-09-22T21:06:32] DEBUG: ignored screen "SERVER-win7" update of clipboard 1 (unchanged)
[2017-09-22T21:06:32] DEBUG: dropped bogus delta motion: -1036,-159
[2017-09-22T21:06:35] DEBUG: received client "CLIENT-XUbuntu16.04" grabbed clipboard 1 seqnum=5
[2017-09-22T21:06:35] INFO: screen "CLIENT-XUbuntu16.04" grabbed clipboard 1 from "SERVER-win7"
[2017-09-22T21:06:35] DEBUG: open clipboard
[2017-09-22T21:06:35] DEBUG: empty clipboard
[2017-09-22T21:06:35] DEBUG: close clipboard
[2017-09-22T21:06:35] DEBUG: clipboard changed: synergy owned
[2017-09-22T21:06:35] DEBUG: received client "CLIENT-XUbuntu16.04" grabbed clipboard 0 seqnum=5
[2017-09-22T21:06:35] INFO: screen "CLIENT-XUbuntu16.04" grabbed clipboard 0 from "SERVER-win7"
[2017-09-22T21:06:35] DEBUG: open clipboard
[2017-09-22T21:06:35] DEBUG: empty clipboard
[2017-09-22T21:06:35] DEBUG: close clipboard
[2017-09-22T21:06:37] INFO: switch from "CLIENT-XUbuntu16.04" to "SERVER-win7" at 1,0
[2017-09-22T21:06:37] INFO: entering screen
[2017-09-22T21:06:37] DEBUG: open clipboard
[2017-09-22T21:06:37] DEBUG: empty clipboard
[2017-09-22T21:06:37] DEBUG: close clipboard
[2017-09-22T21:06:37] DEBUG: open clipboard
[2017-09-22T21:06:37] DEBUG: empty clipboard
[2017-09-22T21:06:37] DEBUG: close clipboard
[2017-09-22T21:06:37] ERROR: invalid message from client "CLIENT-XUbuntu16.04": DCLP
[2017-09-22T21:06:37] DEBUG: active sides: 2
[2017-09-22T21:06:38] NOTE: accepted client connection
[2017-09-22T21:06:38] DEBUG: received client "CLIENT-XUbuntu16.04" info shape=0,0 1366x768 at 683,384
[2017-09-22T21:06:38] DEBUG: active sides: 2
[2017-09-22T21:06:38] NOTE: client "CLIENT-XUbuntu16.04" has connected
[2017-09-22T21:07:10] DEBUG: clipboard changed: lost ownership
[2017-09-22T21:07:10] INFO: screen "SERVER-win7" grabbed clipboard 0 from "CLIENT-XUbuntu16.04"
[2017-09-22T21:07:10] DEBUG: send grab clipboard 0 to "CLIENT-XUbuntu16.04"
[2017-09-22T21:07:10] INFO: screen "SERVER-win7" grabbed clipboard 1 from "CLIENT-XUbuntu16.04"
[2017-09-22T21:07:10] DEBUG: send grab clipboard 1 to "CLIENT-XUbuntu16.04"

 

Edited by lim

Share this post


Link to post
Share on other sites
On 7/30/2015 at 8:42 PM, Miroslaw Majorek said:

I am having the same problem. This is probably connected to the clipboard issue; I am now unable to copy text from one computer to another, both directions (Win7 server, Ubuntu 14 client) and the message appears when I try to do that. Edited to add that I have SSL disabled.

That most likely is the cause of your issue; the cause of the clipboard issue. Your systems may be attempting to send corrupt messages to each other, hence messing with the Synergy encoding code and creating the issues that you are experiencing. Have you tried reinstalling the Synergy program? And if so, have you tried changing some other variables (ex. computer, creating a personal area network between the systems, etc.) in order to further troubleshoot? Please feel free to update us with any findings and/or further questions that you may have and we'll continue to work with you towards a resolution of your issue.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now